Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 42

Thread: 4.53: tomcat is not running

  1. #11
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Do you use the imap proxy?

  2. #12
    michaeln is offline Active Member
    Join Date
    Feb 2007
    Posts
    47
    Rep Power
    8

    Default

    Is this correct?

    Code:
    mailhost:/opt/zimbra#  ls -ld /opt/zimbra
    drwxr-xr-x  41 root root 4096 Mar  2 10:39 /opt/zimbra/

  3. #13
    michaeln is offline Active Member
    Join Date
    Feb 2007
    Posts
    47
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    Do you use the imap proxy?
    That's what started this. I turned it on, as mentioned in my original post of this thread. I have not used it. And now I can't get back in to turn it off.

    In fact we aren't *using* this zimbra installation at all yet, I'm trying to convince mgmt to switch from squirrelmail and no collaboration suite to zimbra.

  4. #14
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default Did you read the wiki page?

    http://wiki.zimbra.com/index.php?tit...ring_Perdition

    This will tell you how to correct your port settings
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #15
    michaeln is offline Active Member
    Join Date
    Feb 2007
    Posts
    47
    Rep Power
    8

    Default

    Quote Originally Posted by marcmac View Post
    http://wiki.zimbra.com/index.php?tit...ring_Perdition

    This will tell you how to correct your port settings
    Look, at this point I don't even want the imap proxy. I tried following the wiki:

    Code:
    [zimbra@mailhost ~]$ zmperditionctl stop
    Stopping imap4
    Stopping imap4s
    Stopping pop3
    Stopping pop3s
    [zimbra@mailhost ~]$ zmprov -- -zimbraServiceEnabled imapproxy
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    [zimbra@mailhost ~]$

  6. #16
    michaeln is offline Active Member
    Join Date
    Feb 2007
    Posts
    47
    Rep Power
    8

    Default

    This is getting pretty silly. I clicked one setting in the admin panel and all this follows from that. Something wrong here.

  7. #17
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Try
    zmprov ms server.example.com +zimbraServiceDisabled imapproxy

  8. #18
    michaeln is offline Active Member
    Join Date
    Feb 2007
    Posts
    47
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    Try
    zmprov ms server.example.com +zimbraServiceDisabled imapproxy
    Code:
    [zimbra@mailhost ~]$ zmprov ms mailhost.inc21.com +zimbraServiceDisabled imapproxy
    ERROR: account.INVALID_ATTR_NAME (invalid attr name: [LDAP: error code 17 - zimbraServiceDisabled: attribute type undefined])

  9. #19
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Change the http and https port, then login to the admin interface, and disable the imapproxy:
    The correct command is, while logged in as zimbra user :

    zmprov ms SERVERNAME zimbraMailPort 8000 [/code]

    Then you have to restart Zimbra, still being logged in as zimbra user :
    tomcat stop
    tomcat start

    If you want to change the SSL port to 8001, you have to do this, still logged in as zimbra user :
    zmprov ms SERVERNAME zimbraMaiSSLPort 8001
    tomcat stop
    tomcat start

  10. #20
    michaeln is offline Active Member
    Join Date
    Feb 2007
    Posts
    47
    Rep Power
    8

    Default

    OK, that fixed it. Thank you!

    No, it didn't actually.

    I can now log into the admin panel, but when trying to connect as a user I get:

    While trying to retrieve the URL: http://mailhost.inc21.com/zimbra/

    The following error was encountered:

    * Connection Failed

    The system returned:

    (111) Connection refused

    zimbra@mailhost ~]$ zmcontrol status
    Host mailhost.inc21.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    Last edited by michaeln; 03-02-2007 at 05:07 PM.

Page 2 of 5 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tomcat, Java VM Problems - RAM related? Help
    By Mo_Hong in forum Administrators
    Replies: 3
    Last Post: 03-28-2007, 02:00 PM
  2. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. Why is Tomcat shuting down ever nights?
    By trapanator in forum Administrators
    Replies: 2
    Last Post: 11-30-2006, 11:57 PM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •