Results 1 to 10 of 10

Thread: Relay MTA

  1. #1
    PNE
    PNE is offline Loyal Member
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default Relay MTA

    I have experienced a behaviour that is strange for me and I would be very happy if someone can explain it to me.

    We use Zimbra and MS Exchange in split domain scenario where Exchange is the smart host. Zimbra and Exchange are in different geographics locations. Zimbra uses MS Exchange as the Relay MTA, DNS lookups are disabled. Everything was working well until we set up a site-to-site VPN between Zimbra and Exchange locations. There are also DNS forwarders here (Windows AD integrated) that support VPN with providing DNS for corresponding remote location. After the VPN has been set up, I changed Relay MTA setting from FQDN to the external IP address of the Exchange box to be sure that e-mails are not going through VPN tunnel. But Zimbra still tries to relay using the wrong IP address, in fact the internal address of the Exchange box, even after restart of the Zimbra box. This is what I just don't understand to. Why, when there is the explicit IP address entry in Zimbra Relay MTA Zimbra still tries to deliver using another address? Does Zimbra use recursion?

    I had to create an explicit host entry in CentOS with the external IP of the Exchange box to workaround this issue.

    Using Zimbra 4.0.3 Open Source.

    Thanks Petr
    Last edited by PNE; 03-01-2007 at 06:04 AM. Reason: just added notification

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Do you have split tunneling set up?
    What about adding an entry for the hosts file on the client machine?

  3. #3
    PNE
    PNE is offline Loyal Member
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default

    I do not think that split tunneling is in place.
    I do not know what you mean with client machine. I have added host entry of Exchange public address in Zimbra.

    I did not mention that both sites have independent internet access, but it is obvious I think. Just do not know why Zimbra does not use explicit IP address for relay MTA.

  4. #4
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    Quote Originally Posted by PNE View Post
    Just do not know why Zimbra does not use explicit IP address for relay MTA.
    How did you set up this "IP address for relay MTA" ?

  5. #5
    PNE
    PNE is offline Loyal Member
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default Correction

    Correction - in fact the split tunneling probably exists as the client in remote location has at the same time access to both internet (using local default gateway) and the remote site (using site-to-site VPN). Remote networks are routed, no NAT between them.

    To Klug - I just typed the IP address using web admin interface, MTA tab in server settings. Saved, even restarted the whole CentOS server, did not work.

  6. #6
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    Quote Originally Posted by PNE View Post
    To Klug - I just typed the IP address using web admin interface, MTA tab in server settings. Saved, even restarted the whole CentOS server, did not work.
    As far as I remember (from the wiki and I'm a bit lazy to search right now) you have to add another parameter to get this work. Something that forbids the Zimbra server to use DNS resolution and forces it to use the smarthost.

    Well, not that lazy afterwards :
    Code:
    zmprov mcf zimbraMtaDnsLookupsEnabled FALSE
    There's also (at least in 4.5.x) a checkbox to uncheck in the MTA tab in the adminUI.

  7. #7
    PNE
    PNE is offline Loyal Member
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default

    Thanks Klug! Now I found that I had a different config in Server settings and Global settings.

    Server settings are correct from my point of view (no DNS lookups, relay MTA as IP address.

    In the Global settings there is no relay MTA specified and DNS lookups are enabled.

    zmprov gcf zimbraMtaDnsLookupsEnabled returns TRUE.

    In the Global settings there is said that "Server settings override global settings" - now I do not know if this is really true !?

    Anyway - after I changed the settings on the Global tab, the problem still persists. zimbraMtaDnsLookupsEnabled now returns FALSE. It looks like Zimbra does some re-recursion, as it is possible that it asks local DNS for the FQDN of the IP address of relay MTA and then it again asks local DNS for the IP of previously learned FQDN, but that way it will get the internal IP of the Exchange instead of the external one that is explicitly set - above DNS are just guesses. Without host entry for the Exchange external IP it just does not work as expected.

  8. #8
    PNE
    PNE is offline Loyal Member
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default

    Update - resolved.

    I found out that I need to use IP address instead of FQDN in the following command:

    zmprov md example.com zimbraMailTransport smtp:123.456.789.012

    With above, Zimbra then relays using IP address. In other case, Zimbra tries to resolve IP probably using DNS even when DNS lookups are turned off in both global and server MTA setting AND even when there is a host entry for the 123.456.789.012. I do not know if this is a bug or not, please consider.

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,484
    Rep Power
    56

    Default

    The setting for DNS lookups only affect mail and postfix delivery, for a relay MTA it will do a DNS lookup to try and resolve the server name you enter. Does the server exist in the DNS servers?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    PNE
    PNE is offline Loyal Member
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default

    Well, it depends. We have the site-to-site VPN in place. Zimbra is on one side, server to relay (Exchange) is on the other side of VPN. Then Exchange server has 2 different IPs - public external and internal. We use MS Active Directory on both sides, including DNS forwarders that take care of requests for the other site's computers. So it may happen that there is cached entry in DNS, but it may have Exchange's internal IP. And I want to be sure that we use Exchange's public IP to relay. Zimbra and Exchange are not in the same domain now, but they are setup according to the split domain scenario. I do not want to create split domain in DNS since I consider DNS forwarders as better solution.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Relay MTA for external delivery
    By endorphine44 in forum Administrators
    Replies: 16
    Last Post: 05-08-2009, 08:24 AM
  3. strange MTA Relay Problem
    By pfuschi in forum Installation
    Replies: 0
    Last Post: 10-31-2006, 11:51 AM
  4. send *all* email through relay mta ?
    By keithop in forum Administrators
    Replies: 7
    Last Post: 07-24-2006, 02:27 AM
  5. Server Stats Cont...
    By DMRDave in forum Administrators
    Replies: 15
    Last Post: 02-16-2006, 01:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •