Results 1 to 6 of 6

Thread: Zimbra internal domain mail doesn't work

  1. #1
    slight77 is offline Junior Member
    Join Date
    May 2014
    Posts
    7
    Rep Power
    1

    Default Zimbra internal domain mail doesn't work

    Hi, I'm trying to migrate from kerio to zimbra.
    The problem now is that the mail sended to another internal account (Ex: From a.decaro@copiaincolla.net TO f.vitale@copiaincolla.net) doesn't arrive in mailbox with this error:

    May 29 11:25:57 posta amavis[889]: (00889-01) FWD from <info@copiaincolla.net> -> <f.vitale@copiaincolla.net>,BODY=7BIT 250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 881AACC205
    May 29 11:25:57 posta amavis[889]: (00889-01) Passed CLEAN {RelayedInternal}, ORIGINATING_POST/MYNETS LOCAL [127.0.0.1]:59161 [127.0.0.1] <info@copiaincolla.net> -> <f.vitale@copiaincolla.net>, Queue-ID: 40F59CC206, Message-ID: <192842349.1.1401355553375.JavaMail.zimbra@copiain colla.net>, mail_id: sMUkb0XJ-omp, Hits: -2.9, size: 1213, queued_as: 881AACC205, 1241 ms
    May 29 11:25:57 posta postfix/smtp[5893]: 40F59CC206: to=<f.vitale@copiaincolla.net>, relay=127.0.0.1[127.0.0.1]:10032, delay=1.4, delays=0.1/0.01/0.03/1.2, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 881AACC205)
    May 29 11:25:57 posta postfix/qmgr[1295]: 40F59CC206: removed
    May 29 11:25:57 posta amavis[889]: (00889-01) extra modules loaded: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/SSLeay.pm, unicore/lib/gc_sc/Digit.pl, unicore/lib/gc_sc/SpacePer.pl
    May 29 11:25:57 posta postfix/lmtp[5895]: 881AACC205: to=<f.vitale@copiaincolla.net>, relay=none, delay=0.1, delays=0.04/0.02/0.04/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=posta.copiaincolla.net type=A: Host not found)
    May 29 11:25:57 posta postfix/cleanup[5888]: AC49DCC207: message-id=<20140529092557.AC49DCC207@posta.copiaincolla.n et>
    May 29 11:25:57 posta postfix/qmgr[1295]: AC49DCC207: from=<>, size=3919, nrcpt=1 (queue active)
    May 29 11:25:57 posta postfix/bounce[5896]: 881AACC205: sender non-delivery notification: AC49DCC207
    May 29 11:25:57 posta postfix/qmgr[1295]: 881AACC205: removed
    May 29 11:25:57 posta postfix/lmtp[5895]: AC49DCC207: to=<info@copiaincolla.net>, relay=none, delay=0.07, delays=0.03/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=posta.copiaincolla.net type=A: Host not found)
    May 29 11:25:57 posta postfix/qmgr[1295]: AC49DCC207: removed

    the outgoing mail to other servers arrive without problem.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by slight77 View Post
    Hi, I'm trying to migrate from kerio to zimbra.
    The problem now is that the mail sended to another internal account (Ex: From a.decaro@copiaincolla.net TO f.vitale@copiaincolla.net) doesn't arrive in mailbox with this error:

    May 29 11:25:57 posta amavis[889]: (00889-01) FWD from <info@copiaincolla.net> -> <f.vitale@copiaincolla.net>,BODY=7BIT 250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 881AACC205
    May 29 11:25:57 posta amavis[889]: (00889-01) Passed CLEAN {RelayedInternal}, ORIGINATING_POST/MYNETS LOCAL [127.0.0.1]:59161 [127.0.0.1] <info@copiaincolla.net> -> <f.vitale@copiaincolla.net>, Queue-ID: 40F59CC206, Message-ID: <192842349.1.1401355553375.JavaMail.zimbra@copiain colla.net>, mail_id: sMUkb0XJ-omp, Hits: -2.9, size: 1213, queued_as: 881AACC205, 1241 ms
    May 29 11:25:57 posta postfix/smtp[5893]: 40F59CC206: to=<f.vitale@copiaincolla.net>, relay=127.0.0.1[127.0.0.1]:10032, delay=1.4, delays=0.1/0.01/0.03/1.2, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 881AACC205)
    May 29 11:25:57 posta postfix/qmgr[1295]: 40F59CC206: removed
    May 29 11:25:57 posta amavis[889]: (00889-01) extra modules loaded: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/SSLeay.pm, unicore/lib/gc_sc/Digit.pl, unicore/lib/gc_sc/SpacePer.pl
    May 29 11:25:57 posta postfix/lmtp[5895]: 881AACC205: to=<f.vitale@copiaincolla.net>, relay=none, delay=0.1, delays=0.04/0.02/0.04/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=posta.copiaincolla.net type=A: Host not found)
    May 29 11:25:57 posta postfix/cleanup[5888]: AC49DCC207: message-id=<20140529092557.AC49DCC207@posta.copiaincolla.n et>
    May 29 11:25:57 posta postfix/qmgr[1295]: AC49DCC207: from=<>, size=3919, nrcpt=1 (queue active)
    May 29 11:25:57 posta postfix/bounce[5896]: 881AACC205: sender non-delivery notification: AC49DCC207
    May 29 11:25:57 posta postfix/qmgr[1295]: 881AACC205: removed
    May 29 11:25:57 posta postfix/lmtp[5895]: AC49DCC207: to=<info@copiaincolla.net>, relay=none, delay=0.07, delays=0.03/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=posta.copiaincolla.net type=A: Host not found)
    May 29 11:25:57 posta postfix/qmgr[1295]: AC49DCC207: removed

    the outgoing mail to other servers arrive without problem.
    The error messages tell you exactly what's wrong, you have no A record for your mail server. You've also given no details of whether this is behind a firewall or NAT router, no details of whether this is required to have both your 'old' server and the new ZCS server in the same domain, no details of which version and release of ZCS is installed. You should always give the details of the ZCS version by posting the output of the following command (and updating your forum profile with that information):

    Code:
    zmcontrol -v
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    slight77 is offline Junior Member
    Join Date
    May 2014
    Posts
    7
    Rep Power
    1

    Default

    Hi Bill, thanks for your kind answer.

    Version information is:
    Release 8.0.7_GA_6021.RHEL6_64_20140408123911 RHEL6_64 FOSS edition.

    I reinstalled the whole software to fix a server name problem (just to "start clean") so the old "posta.copiaincolla.net" is now just "copiaincolla.net". It still gave the exact same error, so I added the requested A record and the error is now different:
    May 30 10:44:59 copiaincolla postfix/lmtp[23942]: 644B0A1873: to=<f.vitale@copiaincolla.net>, relay=none, delay=695, delays=694/0.06/0.19/0, dsn=4.4.1, status=deferred (connect to copiaincolla.net[192.185.149.161]:7025: Connection refused)
    My /etc/hosts states:
    127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
    192.168.0.18 copiaincolla.net
    Where 192.168.0.18 is my internal server IP.
    I also tried 127.0.0.1 ofc but to no avail.

    So I got 2 questions:
    1) why is not using the internal IP as stated in /etc/hosts?
    2) what is port 7025 and why it's trying to connect there?

    Thanks in advance!

  4. #4
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    ZCS (especially postfix) relies on DNS, not on /etc/hosts.
    So you _need_ to have correct DNS records.

    About port 7025, read the documentation...
    That's the mailstore LTMP incoming port.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by slight77 View Post
    1) why is not using the internal IP as stated in /etc/hosts?
    Just to add to what Klug has said, you do actually need a valid /etc/hosts file (and yours is incorrect) and I'd suggest you need to read the Split DNS wiki article about the subject. That has examples of what you need to have in your files and DNS records (and your server need a FQDN not the domain name) and a set of commands to check those settings.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    True.

    I should have said "ZCS (especially postfix) relies on DNS, not only /etc/hosts."

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. IM doesn't work in 2nd domain
    By dreamgear in forum Administrators
    Replies: 1
    Last Post: 08-20-2009, 01:47 PM
  2. Replies: 4
    Last Post: 07-29-2009, 07:24 PM
  3. [SOLVED] Mail routing to internal domain not on Zimbra
    By tech-ninja in forum Administrators
    Replies: 4
    Last Post: 07-24-2008, 01:08 PM
  4. Replies: 4
    Last Post: 12-06-2007, 09:26 AM
  5. Replies: 0
    Last Post: 08-29-2006, 01:40 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •