Results 1 to 4 of 4

Thread: Unable to start Zimbra after upgrade to Perl 5.16

  1. #1
    AWSguy is offline Junior Member
    Join Date
    May 2014
    Posts
    6
    Rep Power
    1

    Default Unable to start Zimbra after upgrade to Perl 5.16

    Hi all,

    Zimbra version: ZCS 8.0.4 (patched)
    OS: Amazon Linux 2014.03 (not a supported OS, but it's basically CentOS 6.5)

    Issue: Zimbra's been running great (DNS is properly setup, no issues there). But a recent yum update on the server resulted in Perl being upgraded from 5.10 to 5.16. Since then, attempting to start Zimbra with zmcontrol start results with this error message:

    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_Istack_sp_ptr

    Now, unfortunately our backups only go back one week, and this update occurred two weeks ago (the issue didn't occur until we rebooted last night however).

    I've tried all of the solutions mentioned in other forum posts regarding this issue, but no luck yet. Attempts at rolling back the Perl installation haven't worked either. Any ideas if there's a way I can get Zimbra to work with Perl 5.16?

    Thanks in advance!

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    Quote Originally Posted by AWSguy View Post
    Issue: Zimbra's been running great (DNS is properly setup, no issues there). But a recent yum update on the server resulted in Perl being upgraded from 5.10 to 5.16.
    You must have a non-standard repository in there somewhere, the current version of Perl for a standard CemtOS 6.5 is 5.10. Can't you remove the repository and revet to the earlier version of Perl?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    AWSguy is offline Junior Member
    Join Date
    May 2014
    Posts
    6
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    You must have a non-standard repository in there somewhere, the current version of Perl for a standard CemtOS 6.5 is 5.10. Can't you remove the repository and revet to the earlier version of Perl?
    Thanks for getting back to me Bill. Unfortunately on Amazon Linux, their main repo now uses Perl 5.16. Also, a yum downgrade perl doesn't work either unfortunately.

    Assuming that I can't downgrade Perl, can you think of anyways we could get Zimbra to work with Perl 5.16?

    Thanks!
    Last edited by AWSguy; 05-20-2014 at 08:03 AM.

  4. #4
    AWSguy is offline Junior Member
    Join Date
    May 2014
    Posts
    6
    Rep Power
    1

    Default

    Bump! Any other ideas Bill? Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable To Build Perl in Zimbra
    By rohitl1980 in forum Developers
    Replies: 0
    Last Post: 01-17-2011, 12:29 AM
  2. Unable to Start Zimbra
    By mikemayaka in forum Installation
    Replies: 3
    Last Post: 05-06-2010, 06:12 AM
  3. Replies: 2
    Last Post: 03-30-2008, 08:20 PM
  4. Perl 5.8.8 Blues = No Zimbra Upgrade ?
    By BrasilNut in forum Installation
    Replies: 7
    Last Post: 02-10-2008, 02:00 AM
  5. Unable to start Postfix & Mailbox + trouble on upgrade
    By tamilnandhu in forum Installation
    Replies: 8
    Last Post: 11-01-2007, 09:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •