Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Major Upgrade

  1. #1
    yang is offline Active Member
    Join Date
    Dec 2005
    Posts
    26
    Rep Power
    9

    Exclamation Major Upgrade

    First things first, I know this is my fault. I'm running 3.0.M1_21.FC3 (on FC4) still, and now I got hit by the DST bug, so I'm looking to upgrade to 4.5.2. The release notes said it will upgrade from ANY ZCS version, can anybody verify that it will work going from 3.0.M1 to 4.5.2?
    Many thanks!

    - Yang

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I would upgrade to 3.1GA before upgrading to 4.5.2

    Also, make sure you have a backup. The backup instructions are in the wiki.

    We'll be here if you run into any trouble.

    -john

  3. #3
    yang is offline Active Member
    Join Date
    Dec 2005
    Posts
    26
    Rep Power
    9

    Talking

    I know I have asked about this before, but I can do 3.0.M1 upgrade to 3.1GA directly right?

    Thanks,

    - Yang

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Yup.

    -john

  5. #5
    yang is offline Active Member
    Join Date
    Dec 2005
    Posts
    26
    Rep Power
    9

    Default Argh!!!

    The upgrade from 3.0.0_M1 to 3.1.0GA failed, looks like a mysql DB schema change required. I'm going to try to do from 3.0.0M1 to M4 now and see what happens, but this is the error message I got, please help.....

    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save\par
    HOSTNAME=cnmail.risktechgroup.com\par
    LDAPHOST=cnmail.risktechgroup.com\par
    LDAPPORT=389\par
    SNMPTRAPHOST=cnmail.risktechgroup.com\par
    SMTPSOURCE=none\par
    SMTPDEST=none\par
    SNMPNOTIFY=0\par
    SMTPNOTIFY=0\par
    LDAPROOTPW=aDc6idXi9i4bzPMTmAhP14gPHxu8Z9k5\par
    LDAPZIMBRAPW=WXdrJzFrgRHC94wC3RsKmLE86pK0phGN\par
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done\par
    chown: cannot access `/opt/zimbra/conf/slapd.crt': No such file or directory\par
    Operations logged to /tmp/zmsetup.log.20519\par
    Setting defaults...Setting defaults from existing config...Warning: null valued key 'mysql_logger_root_password'\par
    Done\par
    Upgrading from 3.0.M1_21.FC3-20050920155949_ to 3.1.0_GA_332\par
    Fri Mar 2 21:24:08 2007: Stopping zimbra services\par
    Fri Mar 2 21:24:11 2007: Checking mysql status\par
    Fri Mar 2 21:24:11 2007: Starting mysql\par
    Fri Mar 2 21:24:12 2007: SELECT value FROM config WHERE name = 'db.version'\par
    I can't upgrade version 3.0.M121.FC3-20050920155949_\par
    \par
    UPGRADE FAILED - exiting\par

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Why is there a "\par" at the end of every line.
    Did it display it that way?

  7. #7
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I'm running 3.0.M1_21.FC3 (on FC4) still
    I missed it the first time. Upgrade to 3.0.M1_21 FC4 first, then upgrade to 3.1GA

  8. #8
    yang is offline Active Member
    Join Date
    Dec 2005
    Posts
    26
    Rep Power
    9

    Default

    3.0.0M1.FC4 is not in the download list, the lowest version available appears to be zcs-3.0.0_M2_746.FC4.tgz?

    Also, I made a backup of the /opt/zimbra dir before I started, and I copied it back after the failed backup, the zmcontrol still reports it's 3.1.0GA, instead of the old 3.0.0M1, should I remove all of the 3.1.0GA rpm packages that was installed as well?


    Thanks,

    - Yang

  9. #9
    yang is offline Active Member
    Join Date
    Dec 2005
    Posts
    26
    Rep Power
    9

    Angry urgent help needed

    Hi,
    I remove the 3.1.0G rpm packages, and reinstalled the 3.0.0M1 rpm packages, restored the /opt/zimbra from backup, it is at least now getting further than before, but now I'm getting this mta auth problem, it's prompting me for a password! and I don't remember what this is...

    ---
    zimbra@mail ~]$ zmcontrol startup
    Calling startup (mail.mycomp.com)

    Password:
    Password:
    Password:
    Password:
    Password:
    Password:
    ----

    also in the /var/log/zimbra.log

    ---
    Mar 2 22:51:45 cnmail zimbramon[20725]: 20725:err: Can't start running app mtaconfig
    Mar 2 22:51:45 cnmail zimbramon[20725]: 20725:info: start app postfix
    Mar 2 22:51:45 cnmail zimbramon[20725]: 20725:err: SMTP RESPONSE: FAILURE from localhost: problem connecting to "localhost", port 25: Connection refused
    Mar 2 22:51:45 cnmail zimbramon[20725]: 20725:info: Starting child postfix: (20070302225145)
    Mar 2 22:52:40 cnmail zimbramon[20725]: 20725:err: SMTP RESPONSE: FAILURE from localhost: problem connecting to "localhost", port 25: Connection refused

    ----

    can you please help?

    many thanks,

    - Yang

  10. #10
    yang is offline Active Member
    Join Date
    Dec 2005
    Posts
    26
    Rep Power
    9

    Default

    ER,
    3.1.0GA changed something in the /etc/passwd file, I'm guessing the ldap user ID, once I restored the file from backup, it was able to start without any problems.

    - Yang

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •