Results 1 to 3 of 3

Thread: Signatures not working

  1. #1
    pup_seba is offline Loyal Member
    Join Date
    Aug 2012
    Posts
    98
    Rep Power
    2

    Default Signatures not working

    Hi,

    I'm trying to enforce a single signature to a whole domain but I'm having troubles even trying to have the simplest kind of signatures

    These are the two lines I played with.

    # zmprov gacf |grep -i mailsignature
    zimbraDomainMandatoryMailSignatureEnabled: TRUE
    zimbraDomainMandatoryMailSignatureText: This is text signature

    Following instructions I found in several wikis and posts, I can't find the reason why nothing is happening. The emails get sent without any signature and I can't find any log that points me towards the root 'cause of this behaviour.

    I tried this in a lab with a single server in version 8.0.6 running over a CentOS 6.5 and in a second lab with 2x8.0.6 servers running on top of two CentOS 6.5 machines with same result (second configuration is 1store+1mta). In both scenarios avamvis is installed, enabled and running.

    Any ideas?

    Regards,
    Sebas

  2. #2
    ccelis5215 is offline Elite Member
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    461
    Rep Power
    4

    Default

    Hi Sebas,


    I confirm this behaviour in Release 8.0.6.GA.5922.UBUNTU12.64 UBUNTU12_64 FOSS edition.


    A messsage after zmprov and restart

    Bit of zimbra.log:

    Code:
    Mar  6 18:03:22 mail amavis[17696]: (17696-01) (!!)collect_results from [19789] (/opt/zimbra/altermime/bin/altermime): DIED, signal 11 (008b) mime_alter.c:1401:AM_disclaimer_load_text:ERROR: Cannot stat '/opt/zimbra/data/altermime/global-default.txt' (No such file or directory)\nmime_alter.c:1401:AM_disclaimer_load_text:ERROR: Cannot stat '/opt/zimbra/data/altermime/global-default.html' (No such file or directory)\nAttempting to add disclaimer\n
    Mar  6 18:03:22 mail amavis[17696]: (17696-01) (!)mangling by altermime failed: Program /opt/zimbra/altermime/bin/altermime failed: 139, mime_alter.c:1401:AM_disclaimer_load_text:ERROR: Cannot stat '/opt/zimbra/data/altermime/global-default.txt' (No such file or directory)\nmime_alter.c:1401:AM_disclaimer_load_text:ERROR: Cannot stat '/opt/zimbra/data/altermime/global-default.html' (No such file or directory)\nAttempting to add disclaimer, mail will pass unmodified

    Then i created the /opt/zimbra/data/altermime/global-default.html and /opt/zimbra/data/altermime/global-default.txt as user root


    Code:
    Mar  6 18:06:41 mail amavis[17698]: (17698-01) mangling by altermime (disclaimer) done, new size: 713, orig 711 bytes

    ccelis

  3. #3
    pup_seba is offline Loyal Member
    Join Date
    Aug 2012
    Posts
    98
    Rep Power
    2

    Default

    Hi ccelis!

    First of all, thank you very much for your help!!!

    I don't have those messages in my zimbra.log files. I do have those files in the correspondent folder:
    [zimbra@zimbra1 altermime]$ ls -la
    total 16
    drwxr-xr-x 2 zimbra zimbra 4096 Mar 6 14:05 .
    drwxr-xr-x 12 zimbra zimbra 4096 Dec 13 12:28 ..
    -rw-r----- 1 zimbra zimbra 1 Mar 6 18:11 global-default.html
    -rw-r----- 1 zimbra zimbra 17 Mar 6 18:11 global-default.txt
    [zimbra@zimbra1 altermime]$
    The content of those files is what I expect according to the conf I defined in previous steps "zimbraDomainMandatoryMailSignatureText: This is text signature"

    This is one of the first things I look into as explained in this post (lots of good stuff in there BTW ) Stjepan Gro? - Homepage

    Anyone else is having this problem? I don't know what I'm missing here!!! Any idea is more than welcome!

    Regards,
    Sebas

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Different Signatures for Different Recipients
    By tobias.dinse in forum Administrators
    Replies: 0
    Last Post: 12-02-2011, 08:03 AM
  2. Signatures not working in ZD2
    By SiliconJunkie in forum General Questions
    Replies: 1
    Last Post: 10-22-2010, 05:12 AM
  3. Signatures
    By snute2008 in forum General Questions
    Replies: 1
    Last Post: 10-22-2010, 04:56 AM
  4. Centralised signatures
    By DavidMorrison in forum General Questions
    Replies: 1
    Last Post: 06-22-2010, 09:01 AM
  5. Signatures not saving
    By drking in forum General Questions
    Replies: 3
    Last Post: 08-15-2009, 08:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •