Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Zimbra will not start.

  1. #1
    myles is offline Active Member
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default Zimbra will not start.

    Hello I am using Zimbra 4.5.0_GA_612.FC4_20070115195933 FC4 on Fedora Core 4 and I am having problems starting it. When I use zmcontrol to start the server it starts the ldap and nothing else.

    Code:
    [zimbra@mail ~]$ zmcontrol start
    Host mail.monkeyinyoursoul.com
            Starting ldap...Done.
    After much trouble I tried reinstalling Zimbra and I get this error:

    Code:
    The system will be modified.  Continue? [N] Y
    
    Shutting down zimbra mail
    
    Backing up ldap
    
    bdb_db_open: unclean shutdown detected; attempting recovery.
    bdb_db_open: Recovery skipped in read-only mode. Run manual recovery if errors are encountered.
    Please note that I have force zimbra and slapd to stop. Nothing that Zimbra uses is running.

    Update: the zimbra /tmp/install.9026 file says:
    Code:
    COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save
    COMMAND: zmcontrol shutdown
    Host mail.monkeyinyoursoul.com
            Stopping mta...Done
            Stopping spell...Done
            Stopping snmp...Done
            Stopping antivirus...Done
            Stopping antispam...Done
            Stopping imapproxy...Done
            Stopping mailbox...FAILED
    Killing mysqld with pid 2706 /opt/zimbra/bin/mysql.server: line 58: kill: (2706) - No such process
    .............................. gave up waiting!
    
    
            Stopping logger...Done
            Stopping ldap...Done
    Last edited by myles; 02-11-2007 at 08:34 PM.

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I think there's more going on here. Did you have a power failure while ZCS was running?

    In any case, try this:
    ldap start

    and let's see if it starts. . . .

  3. #3
    myles is offline Active Member
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor View Post
    I think there's more going on here. Did you have a power failure while ZCS was running?
    No, but I did have to force a reboot.

    Quote Originally Posted by wannabetenor View Post
    In any case, try this:
    ldap start
    It starts but I cannot access it though telnet.

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    How do you know it starts? Is there something in the log?

  5. #5
    myles is offline Active Member
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default

    It is more of a guess than anything.

    Code:
    [zimbra@mail ~]$ ps -A | grep sla
     6605 ?        10:05:26 slapd
    [zimbra@mail ~]$

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Let's make sure it's the zimbra ldap

    ps auxx | grep zimbra

    is ldap in there?

  7. #7
    myles is offline Active Member
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor View Post
    is ldap in there?
    Code:
    [zimbra@mail ~]$ ps auxx | grep zimbra
    zimbra    6605 93.5  0.6   7808  2480 ?        Rs   Feb11 621:09 /opt/zimbra/ope
    nldap-2.3.21/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldap://mail.monkeyinyoursou
    l.com:389 -f /opt/zimbra/conf/slapd.conf
    root     12534  0.0  0.3   4428  1188 pts/1    S    08:59   0:00 su - zimbra
    zimbra   12535  0.0  0.3   4508  1488 pts/1    S    08:59   0:00 -bash
    zimbra   13487  0.0  0.2   2408   816 pts/1    R+   09:16   0:00 ps auxx
    zimbra   13488  0.0  0.1   1688   496 pts/1    S+   09:16   0:00 grep zimbra
    [zimbra@mail ~]$
    Yes I think so.

  8. #8
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    You mentioned that you could not telnet to LDAP.

    Is this because you were running:
    telnet localhost 389 ?

    If so, you need to telnet to:
    telnet mail.monkeyinyoursoul.com:389

  9. #9
    myles is offline Active Member
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor View Post
    If so, you need to telnet to:
    telnet mail.monkeyinyoursoul.com:389
    I still cannot telnet into ldap with telnet mail.monkeyinyoursoul.com:389 and mail.monkeyinyoursoul.com 389

  10. #10
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    What does netstat -a return?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  3. Logger
    By jholder in forum Installation
    Replies: 24
    Last Post: 03-31-2006, 11:50 AM
  4. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-04-2006, 12:19 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •