Results 1 to 2 of 2

Thread: Auto Reply Randomly Doesn't Work

  1. #1
    qbeukes.jacklin is offline Starter Member
    Join Date
    Jan 2014
    Posts
    2
    Rep Power
    1

    Default Custom Content filter to be invoked after Amavis

    Hey,

    I have a custom content filter which I wish to add in _after_ Amavis approves a mail.

    It's defined in master.cf.in as:
    mailstream unix - n n - 10 pipe
    flags=Rq user=postfix null_sender=
    argv=/opt/tools/mailstream/mailpipe.sh ${sender} ${recipient}

    And inserted into the delivery chain at:
    [%%zimbraLocalBindAddress%%]:10030 inet n - n - - smtpd
    -o local_recipient_maps=
    -o virtual_mailbox_maps=
    -o virtual_alias_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_delay_reject=no
    -o smtpd_milters=inet:localhost:8465
    -o smtpd_client_restrictions=permit_mynetworks,reject
    -o smtpd_sender_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,rej ect
    -o smtpd_reject_unlisted_sender=no
    -o smtpd_relay_restrictions=
    -o smtpd_data_restrictions=
    -o smtpd_end_of_data_restrictions=
    -o syslog_name=postfix/dkimmilter
    %%uncomment SERVICE:antispam%% -o content_filter=mailstream:smtp-amavis:[%%zimbraLocalBindAddress%%]:10032

    Specifically the last line. How can I get the "smtp-amavis:[%%zimbraLocalBindAddress%%]:10032" to be used before "mailstream"? Simply adding mailstream to the end gives a fatal error:
    Jan 24 13:53:26 quintindev postfix/smtp[25493]: fatal: garbage after numerical service in server description: [127.0.0.1]:10032:mailstream
    Last edited by qbeukes.jacklin; 01-24-2014 at 06:19 AM.

  2. #2
    qbeukes.jacklin is offline Starter Member
    Join Date
    Jan 2014
    Posts
    2
    Rep Power
    1

    Red face

    Can an administrator please update the thread title to "Custom Content filter to be invoked after Amavis"? I posted into the wrong one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Difference between auto-reply and manual reply
    By berjos in forum Administrators
    Replies: 0
    Last Post: 03-23-2011, 04:47 AM
  2. zd 2.0 reply prefix doesn't work by default
    By egts in forum General Questions
    Replies: 8
    Last Post: 11-16-2010, 02:40 PM
  3. auto-reply can only use once ?
    By marisu in forum Developers
    Replies: 5
    Last Post: 10-30-2008, 06:30 PM
  4. auto-reply
    By russgalleywood in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 08-28-2008, 10:24 AM
  5. auto reply doesn't work on forwarded messages
    By borispr in forum Administrators
    Replies: 1
    Last Post: 06-02-2008, 03:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •