Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Cannot run program "/opt/zimbra/bin/zmamavisdctl" (in directory "/root")

  1. #1
    mafiabusiness is offline Active Member
    Join Date
    Jan 2014
    Location
    London, UK
    Posts
    27
    Rep Power
    1

    Default Cannot run program "/opt/zimbra/bin/zmamavisdctl" (in directory "/root")

    Hi there,

    once a minute, on the dot, I get this in my zimbra.log.

    Jan 23 21:37:44 mail zmconfigd[48798]: Fetching All configs
    Jan 23 21:37:44 mail zmconfigd[48798]: All configs fetched in 0.05 seconds
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmamavisdctl: (Cannot run program "/opt/zimbra/bin/zmamavisdctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmclamdctl: (Cannot run program "/opt/zimbra/bin/zmclamdctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/ldap: (Cannot run program "/opt/zimbra/bin/ldap" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmloggerctl: (Cannot run program "/opt/zimbra/bin/zmloggerctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmstorectl: (Cannot run program "/opt/zimbra/bin/zmstorectl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmmailboxdctl: (Cannot run program "/opt/zimbra/bin/zmmailboxdctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmmemcachedctl: (Cannot run program "/opt/zimbra/bin/zmmemcachedctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmmtactl: (Cannot run program "/opt/zimbra/bin/zmmtactl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmopendkimctl: (Cannot run program "/opt/zimbra/bin/zmopendkimctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmsaslauthdctl: (Cannot run program "/opt/zimbra/bin/zmsaslauthdctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmswatchctl: (Cannot run program "/opt/zimbra/bin/zmswatchctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmspellctl: (Cannot run program "/opt/zimbra/bin/zmspellctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmstatctl: (Cannot run program "/opt/zimbra/bin/zmstatctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Exception in bin/zmclamdctl: (Cannot run program "/opt/zimbra/bin/zmclamdctl" (in directory "/root"): error=13, Permission denied)
    Jan 23 21:37:44 mail zmconfigd[48798]: Watchdog: service antivirus status is OK.
    Jan 23 21:37:44 mail zmconfigd[48798]: All rewrite threads completed in 0.01 sec
    Jan 23 21:37:44 mail zmconfigd[48798]: All restarts completed in 0.00 sec

    I have run the…

    [root@mail ~]# /opt/zimbra/libexec/zmfixperms --extended --verbose

    …as root, as you can tell, and still, no difference — exactly the same appears.
    I have even run it twice, just to be sure, and still, same thing. It does not work to run that as the Zimbra user. I believe that is a bug in 8.0.5 that was fixed in 8.0.6, but I am not in a position to update this production server, a HP Proliant DL380E with 32Gb of RAM, 2x2.4Ghz quadcore, CentOS 6.4 and OpenSource version of Zimbra 8.0.5.

    Any ideas?

    Miguel

  2. #2
    mafiabusiness is offline Active Member
    Join Date
    Jan 2014
    Location
    London, UK
    Posts
    27
    Rep Power
    1

    Default

    …anybody?

    hints?
    ideas?

    …?

  3. #3
    ccelis5215 is offline Elite Member
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    470
    Rep Power
    4

    Default

    hello, do you have SELinux ?

    ccelis

  4. #4
    mafiabusiness is offline Active Member
    Join Date
    Jan 2014
    Location
    London, UK
    Posts
    27
    Rep Power
    1

    Default

    [root@mail ~]# sestatus
    SELinux status: enabled
    SELinuxfs mount: /selinux
    Current mode: enforcing
    Mode from config file: enforcing
    Policy version: 24
    Policy from config file: targeted
    [root@mail ~]#

  5. #5
    mafiabusiness is offline Active Member
    Join Date
    Jan 2014
    Location
    London, UK
    Posts
    27
    Rep Power
    1

    Default

    …and before you ask:

    [zimbra@mail root]$ zmcontrol -v
    Release 8.0.5_GA_5839.RHEL6_64_20130910123908 RHEL6_64 FOSS edition.

  6. #6
    czguy is offline Senior Member
    Join Date
    Jan 2014
    Posts
    73
    Rep Power
    1

    Default

    I know this sounds pretty simple but what happens when you do the following:

    Code:
    su zimbra
    cd ~
    zmamavisdctl
    From your output it looks like the zmconfigd service is attempting to be launched in the /root directory which zimbra doesn't have permission to.

    This is definitely an interesting problem you have.

    Also have you tried temporarily disabling selinux?

  7. #7
    mafiabusiness is offline Active Member
    Join Date
    Jan 2014
    Location
    London, UK
    Posts
    27
    Rep Power
    1

    Default

    [zimbra@mail root]$ cd ~
    [zimbra@mail ~]$ zmamavisdctl
    Usage: /opt/zimbra/bin/zmamavisdctl start|stop|kill|reload|restart|status
    [zimbra@mail ~]$

    I have not tried disabling selinux, for i am not that fluent in Linux / Unix... :-(
    But I am defenitely on your side there, looks, and sounds to me, as if "i have started zimbra as root user as opposed to zimbra user", perhaps, or something along those lines.

    Miguel

  8. #8
    czguy is offline Senior Member
    Join Date
    Jan 2014
    Posts
    73
    Rep Power
    1

    Default

    Quote Originally Posted by mafiabusiness View Post
    [zimbra@mail root]$ cd ~
    [zimbra@mail ~]$ zmamavisdctl
    Usage: /opt/zimbra/bin/zmamavisdctl start|stop|kill|reload|restart|status
    [zimbra@mail ~]$

    I have not tried disabling selinux, for i am not that fluent in Linux / Unix... :-(
    But I am defenitely on your side there, looks, and sounds to me, as if "i have started zimbra as root user as opposed to zimbra user", perhaps, or something along those lines.

    Miguel
    If you're able to run the command as zimbra in the /opt/zimbra directory than most likely it's not selinux causing problems. I'd suggest the following:

    1.) Execute /opt/zimbra/bin/zmcontrol stop as root. In theory this should kill off any zimbra processes that are running as root. This should be cleaner than sending a kill to any zimbra PIDs owned by root.

    2.) Execute zmcontrol start as user zimbra in the /opt/zimbra directory. This should start all processes/services as the zimbra user which should alleviate the permission issues.

    3.) If all else fails, restart. The init scripts should startup zimbra as the zimbra user.

    4.) Have a cup of coffee

  9. #9
    mafiabusiness is offline Active Member
    Join Date
    Jan 2014
    Location
    London, UK
    Posts
    27
    Rep Power
    1

    Default

    …thank you, I will do that tomorrow and report. It's 01.30 here in London, UK, and I know from experience, ever too well, that any entertaining commands to attempt to resolve anything at these hours is futile… :-)) I will report back… seeing that nobody apart from your good self have responded, I am guessing there might be "more of us" out there who could be content with the solution to this.
    Thank you so far for all your help. I am really grateful!
    Point 4 will be done it 7h when I wake up again… :-)
    Miguel

  10. #10
    mafiabusiness is offline Active Member
    Join Date
    Jan 2014
    Location
    London, UK
    Posts
    27
    Rep Power
    1

    Default

    So I ran

    /opt/zimbra/bin/zmcontrol stop

    and it told me that this cannot be run as root, but must be run as zimbra user.
    Whilst still as root, I ran
    /opt/zimbra/libexec/zmfixperms --verbose --extended
    and it made no difference, so, I went back..

    su zimbra
    zmcontrol stop
    zmcontrol start
    zmcontrol status
    …all running, including the error messages that keep coming, once a minute, on the dot.

    Puzzled.
    Miguel

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "Chat" , "Contact" , "Emailed Contact" is not disable in outlook 2013
    By Pareshkaria in forum Zimbra Connector for Outlook
    Replies: 0
    Last Post: 06-06-2013, 11:30 PM
  2. Replies: 3
    Last Post: 09-21-2011, 02:17 PM
  3. Replies: 1
    Last Post: 09-20-2011, 06:54 AM
  4. Replies: 30
    Last Post: 12-09-2010, 05:25 AM
  5. Replies: 0
    Last Post: 01-20-2008, 01:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •