Results 1 to 3 of 3

Thread: Need clarification on Multi Server proxy configuration

  1. #1
    ymarinov is offline Active Member
    Join Date
    Jul 2012
    Posts
    37
    Rep Power
    3

    Default Need clarification on Multi Server proxy configuration

    Hey Zimbra gurus

    On our multi server installation there are 2 mailbox stores, 1 proxy, 1 mta and one 1 ldap.
    Everything is working fine, but once i try to connect through web interface for a user the proxy redirects the connection to port 443 which is not correct and should be 7443 where actual web interface is running.
    Can you advice which server (proxy ot mailstore) should be looked further, and even better can you suggest which option should i change.

    ps. i've tested the proxy server with every option that i have - redirect, both and mixed in order to access mailstores

  2. #2
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    Are zimbrapublicservicehostname, zimbrapublicserviceprotocol and zimbrapublicserviceport correctly setup for the domain?

  3. #3
    pup_seba is online now Loyal Member
    Join Date
    Aug 2012
    Posts
    98
    Rep Power
    2

    Default

    Quote Originally Posted by ymarinov View Post
    Hey Zimbra gurus

    On our multi server installation there are 2 mailbox stores, 1 proxy, 1 mta and one 1 ldap.
    Everything is working fine, but once i try to connect through web interface for a user the proxy redirects the connection to port 443 which is not correct and should be 7443 where actual web interface is running.
    Can you advice which server (proxy ot mailstore) should be looked further, and even better can you suggest which option should i change.

    ps. i've tested the proxy server with every option that i have - redirect, both and mixed in order to access mailstores
    Hi there!

    It looks to me a that there's a missconfiguration. Could you check that your mailstore is configured as a proxy target. For instance with this:
    zmprov gs `zmhostname` |grep -i proxylookup

    Also, the only valid modes for your mailstore to work with a reverse proxy are "http" or "both", so make sure you are using one of them. For isntance with this:
    zmprov gs `zmhostname` |grep -i zimbramailmode

    I also can't remember that port 7443 is used as a default port. Did you change it no purpose? If I remember well, I think that is port 8443 the one that should be listening in your SSL requests. Actually, you should see in your mailbox that "mailSSLPort" is the one that your proxy uses to comunicate with your mailstore (8443) and that SSLProxyPort is 443. Check that with:
    zmprov gs `zmhostname` |grep -i mailssl

    Make sure which ports are being used with "netstat -venputa" and in which interfaces in case you have more than one nic.

    After you got the results, let's take it from there.

    I don't have a similar conf like yours to tell the exact output but "zimbraMailReferMode" should read something like "reverse-proxy"...try to check that with:
    zmprov gs `zmhostname` |grep -i mailrefermode

    With these commands you are not changing anything...just getting the information in order to find where is the missconfiguration.

    Regards,
    Sebas

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 10-20-2011, 06:12 AM
  2. Multi server proxy problems
    By rabettle in forum Administrators
    Replies: 1
    Last Post: 06-10-2011, 11:37 PM
  3. ZCS 6 Multi server install guide and Proxy server
    By gallimore in forum Administrators
    Replies: 0
    Last Post: 09-09-2009, 01:44 AM
  4. [SOLVED] Multi Server setup clarification please
    By gallimore in forum Installation
    Replies: 2
    Last Post: 07-13-2009, 06:46 AM
  5. Replies: 4
    Last Post: 11-11-2008, 06:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •