Results 1 to 5 of 5

Thread: Upgrade/Migration ZCA 8.0.4 to ZCS 8.0.6

  1. #1
    cavj1 is offline Active Member
    Join Date
    Jul 2011
    Location
    NY
    Posts
    40
    Rep Power
    4

    Default Upgrade/Migration ZCA 8.0.4 to ZCS 8.0.6

    Just finished this past weekend. A couple of things I ran into that I wanted to put out there in case other do too.

    My first hiccup was with the License check. For some reason my content filter on my firewall was blocking the check. After resolving that Zimbra support gave me a command to check if I can hit the license server.

    su - zimbra
    zmlicense --ping

    It should reply OK.

    It might be a good idea to check this first. Save the headache of troubleshooting after the fact.

    The next hiccup was pax was not installed. When it did the checks for required applications this came up. Support was kind of surprised but said it was required for 8.0.6 to run properly.

    apt-get install pax

    That did the trick. After that the rest was smooth sailing.

    I am probably over cautious but I ran both a zimbra backup as well as a full backup using my sporty PHD Virtual backup software before going ahead with the install.

  2. #2
    hi-ko is offline Junior Member
    Join Date
    Oct 2012
    Posts
    7
    Rep Power
    2

    Default

    I did the same but went into another trap:
    The installation/upgrade scripts deletes all vmware VAMI artefacts. So if you download the install packages in the common dir like /opt/vmware-installer/packages the migration will fail in an unusable state because the install scripts deletes /opt/vmware-installer/ during execution. We don't miss the files but it's worse to mention :-/

    Packages the installer was complaining:
    apt-get install pax sysstat sqlite3

  3. #3
    pup_seba is online now Special Member
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default

    Hi,

    Sorry to shot this question in this thread, but did you ever try to restore a PHD backup to see if that worked? Do you stop your Zimbra services before making the backup with the PHD software?

    I ask this because snapshots taken by backup software usually don't work with linux machines running mysql instances and although everything seems to run smooth, when restoring the backup is highgly likely to have problems starting up your mysql server as for inconsistencies.

    Just wondering if you had experience with that and if it is possitive or you ran into problems?

    Regards,
    Sebas

  4. #4
    hi-ko is offline Junior Member
    Join Date
    Oct 2012
    Posts
    7
    Rep Power
    2

    Default

    Hi Sebas,
    you should ask this question the PHD guys and the question is vmware generic. We use online snapshot copies which works consistent without any problems as long your vmtools are installed correctly. If you don't trust the vmtools to halt the filesystem for the snapshot you could script this manually using db scripts and LVM snapshots. But again - we have our own backup mechanisms based on snapshot copies which works perfectly fine over years as long your vmtools are up'n running and support filesystem quiesce. Maybe you need to reinstall/recompile the vmtools correctly to support this?

  5. #5
    cavj1 is offline Active Member
    Join Date
    Jul 2011
    Location
    NY
    Posts
    40
    Rep Power
    4

    Default

    I'm unsure why you are re-installing the VAMI tools. I always thought that that was for VMWare appliances. My understanding is once you upgrade to 8.0.6 it becomes Network Edition build on top of Ubuntu 10.04 LTS as if you had built the server from scratch in that manner. No longer being an appliance.

    I'm not sure if the upgrade leaves to ensures the VMWare tools are installed but:

    /etc/init.d/vmware-tools status

    Comes back saying vmtoolsd is running.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade and migration questions
    By timc4 in forum Administrators
    Replies: 1
    Last Post: 03-05-2012, 01:32 PM
  2. Upgrade or Migration from ZCA 6.0.14 to ZCA 7.1.1
    By nevesj in forum Virtualization
    Replies: 3
    Last Post: 01-24-2012, 08:23 AM
  3. Replies: 0
    Last Post: 10-14-2011, 12:37 AM
  4. Server migration + 5.x to 7.x upgrade
    By krzysztof Rutka in forum Administrators
    Replies: 1
    Last Post: 07-22-2011, 08:57 AM
  5. Upgrade and migration. Both Possible?
    By KLGNT in forum Administrators
    Replies: 5
    Last Post: 01-10-2008, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •