Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Email to Hotmail Being Sent to Junk Email

  1. #1
    Jason Hung is offline Active Member
    Join Date
    Feb 2007
    Location
    Phoenix, AZ
    Posts
    46
    Rep Power
    8

    Exclamation Email to Hotmail Being Sent to Junk Email

    Based on my talks with Hotmail staff, my email is failing to send because of certain headers, notably all the X-Spam-* stuff. Is there any way to strip these headers from outbound email?
    X-Virus-Scanned: amavisd-new at
    X-Spam-Score: -2.599
    X-Spam-Level:
    X-Spam-Status: No, score=-2.599 tagged_above=-10 required=5 tests=[BAYES_00=-2.599]
    I have checked another thread that describes a similar plight. I know some of you may find this hard to believe, but it is causing my emails to Hotmail to be sent to the Junk Email folder.

    My question is, is there any way to configure the mail server to strip the X-Spam-*, X-Virus-* headers so that Hotmail's spam filters don't cry wolf? Is there a way to not have it check outbound email? I do not want to set up a relay MTA because the size of our company and the fact that our server is co-located makes it costly for us to add another server just to act as an MTA.

    Thanks,

    Jason Hung
    Network Edition Customer
    Optilab, LLC

  2. #2
    vshah is offline Loyal Member
    Join Date
    Mar 2006
    Posts
    86
    Rep Power
    9

    Default

    I just verified this on our NE setup sending mail to my personal hotmail account. My mail was identified as spam by hotmail. I have no idea why since the X-Spam headers said the mail wasn't spam.
    I can't believe they are IDing mail as spam simply based on the presence of the X-Spam headers.

    Any ideas?

  3. #3
    Jason Hung is offline Active Member
    Join Date
    Feb 2007
    Location
    Phoenix, AZ
    Posts
    46
    Rep Power
    8

    Default

    They filter it because statistically a lot of outgoing spam will have X-SPAM-* type headers, or so is the reasoning that the technical support guy gave me...

  4. #4
    anand is offline Zimbra Employee
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    9

    Default

    Play with these settings in amavisd.conf.in, specially the first one would be my guess as to what causes the spam headers to be set in ham.

    $sa_tag_level_deflt = -10.0; # add spam info headers if at, or above that level
    $sa_tag2_level_deflt = %%range VAR:zimbraSpamTagPercent 0 20%%; # add 'spam detected' headers at that level

    Also file this in bugzilla as two related enhancements please. Outbound mail should not have any SA headers added, and other option is to not have any SA informational headers added at all.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Jason Hung is offline Active Member
    Join Date
    Feb 2007
    Location
    Phoenix, AZ
    Posts
    46
    Rep Power
    8

    Default

    Will do... I'll give this a shot. Should I file a ticket in the Network Edition support center as well?

    Thanks for your help!

  6. #6
    rdargahi is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    49
    Rep Power
    9

    Default

    Jason, filing the enhancements in bugzilla will do the trick. We will get them triaged and slotted into a release asap
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    Jason Hung is offline Active Member
    Join Date
    Feb 2007
    Location
    Phoenix, AZ
    Posts
    46
    Rep Power
    8

    Default

    I'll do that tomorrow when I get a chance... Too tired to think at this point.

    As long as you set your own domains onto the White List and score yourself below -10 (i.e. -11), you won't write the headers onto your email. For example:

    I added:

    Code:
         'opti-lab.com'                           => -10.1,
    to
    Code:
       { # a hash-type lookup table (associative array)
         'nobody@cert.org'                        => -3.0,
         'cert-advisory@us-cert.gov'              => -3.0,
         'owner-alert@iss.net'                    => -3.0,
         'slashdot@slashdot.org'                  => -3.0,
         'bugtraq@securityfocus.com'              => -3.0,
         'ntbugtraq@listserv.ntbugtraq.com'       => -3.0,
         'security-alerts@linuxsecurity.com'      => -3.0,
         'mailman-announce-admin@python.org'      => -3.0,
         'amavis-user-admin@lists.sourceforge.net'=> -3.0,
    Opti-lab.com is my domain. Let me know if you have any questions... EDIT: HOTMAIL WORKS LIKE A CHARM WITH THE FIX ABOVE

    Jason
    Last edited by Jason Hung; 02-08-2007 at 12:42 AM. Reason: Hotmail works

  8. #8
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    what would be really nice is to bypass amavis checks if relaying through smtp-auth, at least the spam checks.

  9. #9
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    Set up postfix submission on port 587, set the content filter to "" (bypassing amavis) then set your web client to use that port for mail submission. No AS/AV on outgoing mail.

    * Details left as an exercise for the reader; I think there's a zimbra wiki on setting up the submission, everything else is in man 5 postconf
    Bugzilla - Wiki - Downloads - Before posting... Search!

  10. #10
    Jason Hung is offline Active Member
    Join Date
    Feb 2007
    Location
    Phoenix, AZ
    Posts
    46
    Rep Power
    8

    Default

    Marc,

    It works if you add all the local domains to hash whitelist. Then X-SPAM-* headers disappear. No need to bypass virus scanning as I still find that very useful.

    Just add
    Code:
    'YOUR DOMAIN NAME'                           => -10.1,
    to
    Code:
     { # a hash-type lookup table (associative array)
         'nobody@cert.org'                        => -3.0,
         'cert-advisory@us-cert.gov'              => -3.0,
    .

    As long as the hash variable for that domain name is more negative than -10, then it will not look add the X-SPAM-* headers. That way you kill the X-SPAM headers but still keep virus scanning.

    Remember, amavis-new has this configuration which requires it to be more negative than -10...
    Code:
    $sa_tag_level_deflt = -10.0; # add spam info headers if at, or above that level
    $sa_tag2_level_deflt = %%range VAR:zimbraSpamTagPercent 0 20%%; # add 'spam detected' headers at that level

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Leave junk quarantined but transport all other email
    By freddirkse in forum Administrators
    Replies: 1
    Last Post: 08-01-2007, 05:40 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •