Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Error message with zmsaupdate

  1. #21
    ludus is offline New Member
    Join Date
    Dec 2013
    Posts
    4
    Rep Power
    1

    Default

    Quote Originally Posted by ianw1974 View Post
    Yes, my colleague is also running Ubuntu 12.04, although he doesn't get the emails, probably because his /etc/aliases is not configured to deliver it to his admin user on the Zimbra install like mine is.
    Then, most probably, on his server, there are some messages in mail queue that Cron Daemon is trying to send to zimbra@$server_fqdn$.

  2. #22
    ludus is offline New Member
    Join Date
    Dec 2013
    Posts
    4
    Rep Power
    1

    Default

    Quote Originally Posted by ianw1974 View Post
    Yes, my colleague is also running Ubuntu 12.04, although he doesn't get the emails, probably because his /etc/aliases is not configured to deliver it to his admin user on the Zimbra install like mine is.
    Then, most probably, on his server, there are some messages in mail queue that Cron Daemon is trying to send to zimbra@server_fqdn.

  3. #23
    ianw1974 is offline Active Member
    Join Date
    Oct 2009
    Location
    UK
    Posts
    32
    Rep Power
    5

    Default

    No, checked that on his, his queue is empty. I'll update after tonight's cron to see if editing the user cron helps. In addition I edited today /etc/crontab and then restarted cron. Perhaps that was why it didn't work the first time, anyway shall soon see.

  4. #24
    ianw1974 is offline Active Member
    Join Date
    Oct 2009
    Location
    UK
    Posts
    32
    Rep Power
    5

    Default

    Well, editing the zimbra user crontab and adding to the beginning, like this:

    Code:
    SHELL=/bin/bash
    
    # ZIMBRASTART -- DO NOT EDIT ANYTHING BETWEEN THIS LINE AND ZIMBRAEND
    #
    seemed to work as I didn't get any error message this morning. Either that, or the reload of crontab after editing /etc/crontab, as I did both. Anyway, it's now fixed. I'll see if this stays after future upgrades, although it should do as it is outside of the ZIMBRASTART and ZIMBRAEND lines. Therefore if you do it, put it at the very beginning like I did.

  5. #25
    ludus is offline New Member
    Join Date
    Dec 2013
    Posts
    4
    Rep Power
    1

    Default

    Great solution. Thanks for your help and testing through this problem.

    Changing SHELL=/bin/sh to SHELL=/bin/bash in /etc/crontab and restarting cron service doesn't work. I tested it by simply creating cron job as zimbra user:

    Code:
    * * * * * env > /tmp/env.txt
    # ZIMBRASTART -- DO NOT EDIT ANYTHING BETWEEN THIS LINE AND ZIMBRAEND
    #
    and the output was this:

    Code:
    LANGUAGE=en_US:en
    HOME=/opt/zimbra
    LOGNAME=zimbra
    PATH=/usr/bin:/bin
    LANG=en_US.UTF-8
    SHELL=/bin/sh
    PWD=/opt/zimbra
    Zimbra user's cron was still using sh.

    Only after applying your last solution:

    Code:
    SHELL=/bin/bash
    * * * * * env > /tmp/env.txt
    # ZIMBRASTART -- DO NOT EDIT ANYTHING BETWEEN THIS LINE AND ZIMBRAEND
    #
    the output of the cron job was:

    Code:
    SHELL=/bin/bash
    PATH=/usr/bin:/bin
    PWD=/opt/zimbra
    LANG=en_US.UTF-8
    SHLVL=1
    HOME=/opt/zimbra
    LANGUAGE=en_US:en
    LOGNAME=zimbra
    _=/usr/bin/env

    Thanks again!
    Last edited by ludus; 12-24-2013 at 06:45 AM.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 07-24-2014, 01:09 PM
  2. zmsaupdate doesn't restart amavisd
    By babyporch in forum Administrators
    Replies: 15
    Last Post: 09-26-2013, 10:09 PM
  3. Enable zmsaupdate
    By babyporch in forum Administrators
    Replies: 2
    Last Post: 09-22-2013, 11:54 AM
  4. Replies: 2
    Last Post: 09-06-2013, 08:21 AM
  5. Replies: 0
    Last Post: 01-05-2010, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •