Only issue I see is your three name servers; two of which are private and 8.8.8.8 which is one of the Google public DNS servers.

When the Google DNS server comes up in rotation it will not resolve your Zimbra server host's IP address to its RFC1918 IP address, which will cause problems, especially if your setting for ldap_url and ldap_master_url is an fqdn instead of an IP address. (If it does work, that means you have port 389 open to the public Internet, which is not good.)

Hope that helps,
Mark