Results 1 to 8 of 8

Thread: Post install completion, starting mta...Failed. --->/lib64/libz.so.1: no version inf

  1. #1
    rodeli is offline New Member
    Join Date
    Nov 2013
    Posts
    4
    Rep Power
    1

    Default Post install completion, starting mta...Failed. --->/lib64/libz.so.1: no version inf

    After a fresh install of Zimbra Open Source on CentOS 6.3(on Windows Azure) I receive the following error:

    Code:
    Starting ldap...Done.
            Starting zmconfigd...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting opendkim...Done.
            Starting snmp...Done.
            Starting spell...Done.
        Starting mta...Failed.
    Starting saslauthd.../opt/zimbra/cyrus-sasl/sbin/saslauthd: /lib64/libz.so.1: no version information available (required by /opt/zimbra/cyrus-sasl/sbin/saslauthd)
    done.
    postfix failed to start
    
    
            Starting stats...Done.
    I configured split DNS and completed the installation but received that error once the server was being started. I also tried the following:

    as Zimbra user zmcontrol stop
    as root user /opt/zimbra/libexec/zmfixperms --extended
    as Zimbra user zmcontrol start


    But nothing changed.

    From what I make out Zimbra is having an issue identifying the version of libz.so.1, but I have no idea how to correct this.

    Any help would be appreciated.

    Thanks in advance!


    esit:

    For reference:
    Release 8.0.5_GA_5839.RHEL6_64_20130910123908 RHEL6_64 FOSS edition.
    Last edited by rodeli; 11-03-2013 at 01:27 AM. Reason: Added Zimbra version

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by rodeli View Post
    After a fresh install of Zimbra Open Source on CentOS 6.3(on Windows Azure)...
    Why don't you update CentOS to the most recent version (it's 6.4) and try again? I hope you have enough real RAM allocated to this server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    rodeli is offline New Member
    Join Date
    Nov 2013
    Posts
    4
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    Why don't you update CentOS to the most recent version (it's 6.4) and try again? I hope you have enough real RAM allocated to this server.
    This is the latest version of CentOS available in windows azure vm Images. The VM has 3.5gb of ram allocated to it for testing.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by rodeli View Post
    This is the latest version of CentOS available in windows azure vm Images.
    In that case I'd guess their vm instance has the problem. I've run ZCS on all versions of CentOS since 2005 and never encountered this problem. Can't you install a 'proper' version of CentOS from their iso images?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    rodeli is offline New Member
    Join Date
    Nov 2013
    Posts
    4
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    In that case I'd guess their vm instance has the problem. I've run ZCS on all versions of CentOS since 2005 and never encountered this problem. Can't you install a 'proper' version of CentOS from their iso images?
    Only the customized images. It's possible to create an image, but that would be too much of a feat just to try zimbra at the moment. Hopefully someone might be able to provide a solution using my current environment.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by rodeli View Post
    Only the customized images. It's possible to create an image, but that would be too much of a feat just to try zimbra at the moment. Hopefully someone might be able to provide a solution using my current environment.
    The error message and information I've seen on the internet would lead me to believe that the specific module is not the standard CentOS one, try asking for support at Microsoft. I had no problems running ZCS 8.x on CentOS 6.3 and I've also recently installed another VM to confirm that it has no problems. I also believe that Azure has disabled updating CentOS from the standard repositories CentOS repositories so I guess you're stuck with their version.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    rodeli is offline New Member
    Join Date
    Nov 2013
    Posts
    4
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    The error message and information I've seen on the internet would lead me to believe that the specific module is not the standard CentOS one, try asking for support at Microsoft. I had no problems running ZCS 8.x on CentOS 6.3 and I've also recently installed another VM to confirm that it has no problems. I also believe that Azure has disabled updating CentOS from the standard repositories CentOS repositories so I guess you're stuck with their version.
    I was afraid it would come down to that.

    Thank you for your help!

  8. #8
    rizz2pro is offline Junior Member
    Join Date
    May 2014
    Posts
    6
    Rep Power
    1

    Default

    Quote Originally Posted by rodeli View Post
    After a fresh install of Zimbra Open Source on CentOS 6.3(on Windows Azure) I receive the following error:

    Code:
    Starting ldap...Done.
            Starting zmconfigd...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting opendkim...Done.
            Starting snmp...Done.
            Starting spell...Done.
        Starting mta...Failed.
    Starting saslauthd.../opt/zimbra/cyrus-sasl/sbin/saslauthd: /lib64/libz.so.1: no version information available (required by /opt/zimbra/cyrus-sasl/sbin/saslauthd)
    done.
    postfix failed to start
    
    
            Starting stats...Done.
    I configured split DNS and completed the installation but received that error once the server was being started. I also tried the following:

    as Zimbra user zmcontrol stop
    as root user /opt/zimbra/libexec/zmfixperms --extended
    as Zimbra user zmcontrol start


    But nothing changed.

    I am having this exact same issue. I am using a 'real' version of CentOS 6.5 with the latest Zimbra 8.0.7

    It seems my postfix can reload/restart OK, but saslauthd is throwing the error:

    Code:
    [zimbra@ottp-corp-paz-proxy-1 ~]$ zmmtactl reload
    Rewriting configuration files...done.
    Stopping milter server...done.
    Starting milter server...done.
    Stopping saslauthd...done.
    Starting saslauthd.../opt/zimbra/cyrus-sasl/sbin/saslauthd: /lib64/libz.so.1: no version information available (required by /opt/zimbra/cyrus-sasl/sbin/saslauthd)
    done.
    /postfix-script: refreshing the Postfix mail system
    [zimbra@ottp-corp-paz-proxy-1 ~]$

    The restart/reload seems OK even with this error message. My MTA is still running and able to send/receieve mail. But could there be any other reason for this? I am also stumped here since I restarted the MTA not long ago and had no problems like this.

    rz2p

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Attachment post failed when deleting
    By bobu in forum Administrators
    Replies: 0
    Last Post: 06-20-2013, 03:48 AM
  2. zmmailbox -> post failed, over 10485760 byte limit
    By pete irvine in forum Virtualization
    Replies: 3
    Last Post: 05-26-2011, 06:57 PM
  3. How to find Zimbra version without starting?
    By brianm1002 in forum Administrators
    Replies: 1
    Last Post: 02-03-2011, 12:26 AM
  4. [SOLVED] Missing /usr/lib64/libtool-ltdl.so.3
    By Rick Baker in forum Installation
    Replies: 2
    Last Post: 02-29-2008, 11:11 PM
  5. Wrong Postfix Version - Post GA Upgrade
    By crichell in forum Installation
    Replies: 5
    Last Post: 02-08-2006, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •