Results 1 to 3 of 3

Thread: zmconfigd is not running after update zimbra 7.1.2 to 8.0.5

  1. #1
    villim is offline Starter Member
    Join Date
    Aug 2011
    Posts
    1
    Rep Power
    3

    Default zmconfigd is not running after update zimbra 7.1.2 to 8.0.5

    Try to update current 7.1.2 to zimbra8. After updated, a lot of services cant start :

    ldap Running
    logger Stopped
    zmlogswatchctl is not running
    mailbox Stopped
    zmmailboxdctl is not running.
    mta Stopped
    zmsaslauthdctl is not running
    postfix is not running
    snmp Running
    stats Running
    zmconfigd Stopped
    zmconfigd is not running.
    after checking, it seems the conf files are not updated. such as /opt/zimbra/postfix/conf/main.cf is empty. It seems caused by zmconfigd not working correctly.

    checking /opt/zimbra/log/zmconfigd.log it has following error message
    Starting zmconfigd...Traceback (most recent call last):
    File "/opt/zimbra/libexec/zmconfigd", line 31, in <module>
    import state
    File "/opt/zimbra/zimbramon/pylibs/state.py", line 17, in <module>
    import localconfig
    File "/opt/zimbra/zimbramon/pylibs/localconfig.py", line 18, in <module>
    import commands
    File "/opt/zimbra/zimbramon/pylibs/commands.py", line 58, in <module>
    class Command:
    File "/opt/zimbra/zimbramon/pylibs/commands.py", line 60, in Command
    P = Provisioning.getInstance(Provisioning.CacheMode.OF F)
    AttributeError: type object 'com.zimbra.cs.account.Provisioning' has no attribute 'CacheMode'
    but there's no problems with Jar files under /opt/zimbra/lib/jars/

    Any body has a clue what happened?

  2. #2
    aamit.rhce is offline Active Member
    Join Date
    Dec 2011
    Location
    INDIA
    Posts
    34
    Rep Power
    3

    Default

    Hi,

    Try following solution :

    # su - zimbra ### run as root user
    $ zmcontrol stop #### run as zimbra user
    $ logout #### run as zimbra user
    # /opt/zimbra/libexec/zmfixperms --verbose --extended ### run as root user
    # su - zimbra ### run as root user
    $ zmcontrol start #### run as zimbra user
    $ zmcontrol status #### run as zimbra user

    Might it helps

  3. #3
    quanah is online now Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,195
    Rep Power
    9

    Default

    It sounds like your LDAP DB is missing some attributes introduced after ZCS 7.2. How exactly did you upgrade?
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Update from 6.0.7 NE to 7.1.4 NE
    By yogg1 in forum Administrators
    Replies: 1
    Last Post: 02-22-2012, 04:41 AM
  2. How to Update Zimbra
    By eniomarconcini in forum Administrators
    Replies: 1
    Last Post: 06-09-2011, 12:45 PM
  3. Zimbra update
    By Sharpey in forum Administrators
    Replies: 2
    Last Post: 07-23-2010, 11:42 AM
  4. Replies: 10
    Last Post: 12-07-2008, 02:44 AM
  5. zimbra update
    By kmuralidharan in forum Administrators
    Replies: 0
    Last Post: 09-05-2007, 08:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •