Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: SQLITE - SUSE issue

  1. #1
    netvadi is offline Member
    Join Date
    Jan 2008
    Posts
    13
    Rep Power
    7

    Default SQLITE - SUSE issue

    Dear all,

    While updating from Zimbra 8.0.4 to Zimbra 8.0.5 in SUSE-Linux SLES 11

    i get the following Error

    Checking for prerequisites...
    FOUND: NPTL
    FOUND: sudo-1.7.6p2-0.2.12.1
    FOUND: libidn-1.10-3.18
    FOUND: gmp-4.2.3-10.99
    FOUND: /usr/lib/libstdc++.so.6

    Checking for suggested prerequisites...
    FOUND: sysstat
    MISSING: sqlite does not appear to be installed.

    ###WARNING###

    The suggested version of one or more packages is not installed.
    This could cause problems with the operation of Zimbra.


    When i try to install sqlite using

    zypper install sqlite - The result was


    Refreshing service 'nu_novell_com'.
    Loading repository data...
    Reading installed packages...
    'sqlite' not found in package names. Trying capabilities.
    'sqlite3' providing 'sqlite' is already installed.
    Resolving package dependencies...


    So zimbra is not recognizing Sqlite3 ... how to resolve this issue.
    pls help.

    Vadi.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,483
    Rep Power
    56

    Default

    Are you on SP3 (it is a requirement)?

    Sent from my HTC Desire using Tapatalk
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    prashant's Avatar
    prashant is offline Zimbra Employee
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    8

    Default

    See if you related this to your issue.

    Zimbra cannot find sqlite
    ~=Prashant=~

  4. #4
    netvadi is offline Member
    Join Date
    Jan 2008
    Posts
    13
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    Are you on SP3 (it is a requirement)?

    Sent from my HTC Desire using Tapatalk
    Yes. It is on SP3.

    Vadi.

  5. #5
    netvadi is offline Member
    Join Date
    Jan 2008
    Posts
    13
    Rep Power
    7

    Default

    See if you related this to your issue.

    Zimbra cannot find sqlite



    Thanks for the reply. it does not solve the issue.


    Vadi.
    Last edited by netvadi; 10-16-2013 at 09:53 PM.

  6. #6
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    Run
    Code:
    zypper install sqlite3
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #7
    netvadi is offline Member
    Join Date
    Jan 2008
    Posts
    13
    Rep Power
    7

    Default

    'sqlite3' providing 'sqlite' is already installed.
    It is already installed.

    Vadi.

  8. #8
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    Well, your rpm database doesn't appear to agree with you. That is what is being queried to discover if it is installed.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  9. #9
    netvadi is offline Member
    Join Date
    Jan 2008
    Posts
    13
    Rep Power
    7

    Default Sqllite install result

    Quote Originally Posted by quanah View Post
    Well, your rpm database doesn't appear to agree with you. That is what is being queried to discover if it is installed.
    zypper install sqlite3
    Refreshing service 'nu_novell_com'.
    Retrieving repository 'SLES11-SP3-VMware-Updates' metadata [done]
    Building repository 'SLES11-SP3-VMware-Updates' cache [done]
    Loading repository data...
    Reading installed packages...
    'sqlite3' is already installed.
    No update candidate for 'sqlite3-3.7.6.3-1.4.4.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...

    Nothing to do.

  10. #10
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    The installer tests for sqlite3 using rpm, as I already stated:

    Code:
    zre-sles11-64:/home/build # rpm -q sqlite3
    sqlite3-3.7.6.3-1.4.4.1
    In fact, the only way the installer checks for "sqlite" rather than "sqlite3" is if it can't identify your platform or you are trying to install the RHEL6 build. So either you downloaded the wrong installer, or there is something fundamentally broken with your OS installation.

    Code:
        if [ $PLATFORM = "RHEL6_64" -o $PLATFORM = "CentOS6_64" ]; then
          PACKAGEINST='yum -y --disablerepo=* localinstall -v'
          PACKAGERM='yum -y --disablerepo=* erase -v'
          PREREQ_PACKAGES="nc sudo libidn gmp"
          PREREQ_LIBS="/usr/lib64/libstdc++.so.6"
          PRESUG_PACKAGES="perl-5.10.1 sysstat sqlite"
          STORE_PACKAGES=""
        elif [ $PLATFORM = "SLES11_64" ]; then
          PREREQ_PACKAGES="netcat sudo libidn gmp"
          PREREQ_LIBS="/usr/lib64/libstdc++.so.6"
          PRESUG_PACKAGES="perl-5.10.0 sysstat sqlite3"
          STORE_PACKAGES=""
        else
          PREREQ_PACKAGES="sudo libidn gmp"
          PREREQ_LIBS="/usr/lib/libstdc++.so.6"
          PRESUG_PACKAGES="sysstat sqlite"
        fi
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zimbra zmapachectl issue on suse 11 server
    By indunil75 in forum Administrators
    Replies: 9
    Last Post: 04-10-2014, 12:21 AM
  2. Creating policies in SQLite for PolicyD
    By gromit08 in forum Administrators
    Replies: 1
    Last Post: 06-03-2013, 08:12 AM
  3. Build sqlite and index
    By spid in forum General Questions
    Replies: 2
    Last Post: 03-20-2013, 03:46 PM
  4. Build sqlite and index
    By spid in forum Migration
    Replies: 0
    Last Post: 03-19-2013, 08:42 PM
  5. dns issue with suse 10.2 and issue with bind
    By zjustin in forum Installation
    Replies: 11
    Last Post: 05-06-2007, 11:18 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •