Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Everything gets tagged as ALL_TRUSTED

  1. #11
    WolfyPDX is offline Intermediate Member
    Join Date
    Aug 2009
    Posts
    24
    Rep Power
    5

    Default

    STILL looking for a solution to this issue.

  2. #12
    WolfyPDX is offline Intermediate Member
    Join Date
    Aug 2009
    Posts
    24
    Rep Power
    5

    Default

    I do believe things are now fixed. I ran yum update on our test Zimbra server yesterday, and that updated several Perl packages and other system libraries. Zimbra is now properly marking things as ALL_TRUSTED only when the mail originates locally.

  3. #13
    moebius is offline Junior Member
    Join Date
    Mar 2014
    Posts
    5
    Rep Power
    1

    Default

    I am having this problem as well with Release 8.0.6.GA.5922.UBUNTU10.64 UBUNTU10_64 FOSS edition

    Here is where things go wrong, an outside IP is considered trusted:

    Code:
    Mar 24 17:50:51 svr02-jls amavis[30876]: (30876-13) SA dbg: received-header: parsed as [ ip=50.31.151.68 rdns=sc1.nanog.org helo=sc1.nanog.org by=svr01-365.unwiredltd.com ident= envfrom= intl=0 id=9E9BD596028 auth= msa=0 ]
    Mar 24 17:50:51 svr02-jls amavis[30876]: (30876-13) SA dbg: netset: trusted_networks lookup on 50.31.151.68, 13 networks, result: 0, 0.359 ms
    Mar 24 17:50:51 svr02-jls amavis[30876]: (30876-13) SA dbg: received-header: originating, 50.31.151.68 and remaining relays will be considered trusted, but no longer internal
    Mar 24 17:50:51 svr02-jls amavis[30876]: (30876-13) SA dbg: received-header: relay 50.31.151.68 trusted? yes internal? no msa? no
    The problem seems to be here; the code decides that everything can be trusted: (Inside Received.pm)

    Code:
              if (!$originating) {
                $in_trusted = 0;    # break the trust chain
              } else {  # caller asserts a msg was submitted from inside or auth'd
                $found_msa = 1;     # let's assume the previous hop was actually
                                    # an MSA, and propagate trust from here on
                dbg('received-header: originating, '.
                    '%s and remaining relays will be considered trusted%s',
                    $relay->{ip}, !$in_internal ? '' : ', but no longer internal');
    Previous hop was not an MSA, this hop is not TRUSTED, but its not breaking the trust chain, I think because $originating is set incorrectly, seems like a bug here?

    I changed the $found_msa = 1; to $in_trusted = 0; and things seem to work more as expected.. Emails from mynets show up with the ALL_TRUSTED tag, and those from outside do not.
    Last edited by moebius; 03-24-2014 at 06:27 PM.

  4. #14
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Did you file a bug with the SpamAssassin team?
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #15
    moebius is offline Junior Member
    Join Date
    Mar 2014
    Posts
    5
    Rep Power
    1

    Default

    No I did not, my guess is its already fixed in a more recent spamassassin build than the one included with 8.0.6.GA.5922.UBUNTU10.64 UBUNTU10_64 FOSS edition
    Perhaps someone from Zimbra who is more clued in here can shed some light on the issue. My guess is a lot of people have it but just don't know it.

  6. #16
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Code is exactly the same in 3.4.0 RELEASE. I'll file a bug with SpamAssassin
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #17
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Hm, except in our environment, most email is *not* tagged as ALL_TRUSTED. So maybe the root cause was something else.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  8. #18
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Yes, I can confirm that ALL_TRUSTED is only firing for us with internally originating email.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  9. #19
    moebius is offline Junior Member
    Join Date
    Mar 2014
    Posts
    5
    Rep Power
    1

    Default

    Is it supposed to be hitting this code for external email? I saw some logging that looked like something funny might be going on with the policy banks, but I'm not sure..

    if (!$originating) {
    $in_trusted = 0; # break the trust chain

  10. #20
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    external = not in zimbraMtaMyNetworks
    internal = in zimbraMtaMyNetworks

    In my environment, ALL_TRUSTED is only firing for "internal" emails. It never fires for "external" emails.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ZD: tagged a date in CALENDAR and then...
    By IamArarat in forum Installation
    Replies: 0
    Last Post: 05-27-2011, 12:14 PM
  2. ALL_TRUSTED not flagging
    By bjquinn in forum Administrators
    Replies: 2
    Last Post: 06-21-2010, 03:44 PM
  3. Why is this getting tagged as spam?
    By jurness in forum Administrators
    Replies: 1
    Last Post: 02-01-2010, 04:32 PM
  4. [SOLVED] tagged
    By wooby in forum Administrators
    Replies: 3
    Last Post: 01-18-2010, 04:32 AM
  5. SPAM enters with "ALL_TRUSTED" bonus
    By Bingo in forum Administrators
    Replies: 6
    Last Post: 12-06-2006, 01:35 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •