Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Polling interval must be at least 0 minutes

  1. #1
    Lascaille is offline Intermediate Member
    Join Date
    Aug 2011
    Posts
    16
    Rep Power
    3

    Default Polling interval must be at least 0 minutes

    Untitled-1.jpg

    Hi,

    Zimbra 8.0.5_GA_5839 (build 20130910123908)

    While logged in as a user, I am trying to set as new mail arrives as the check mail interval in the Preferences>Mail>Displaying Mail section. The initial settings are 2 minutes.

    If I set 1 minute or As new mail arrives or Manually I receive the error 'Polling interval must be at least 0 minutes' when I press save.

    If I set anything above 2 minutes I also receive the error 'Polling interval must be at least 0 minutes' when I press save.

    Only when I set 2 minutes I can save.

    I have set all the polling values in the admin console to '0' and 'seconds' and verified that these have changed to 'unlimited' when the admin console is reloaded.

    I have attached a screenshot, not that it adds much.

    Does anyone have any suggestions?
    Last edited by Lascaille; 10-06-2013 at 04:10 AM. Reason: Addition of screenshot

  2. #2
    Lascaille is offline Intermediate Member
    Join Date
    Aug 2011
    Posts
    16
    Rep Power
    3

    Default

    I created another user, this user's default interval was 5 minutes. For this user I could also not change the interval - setting anything other than 5 minutes generated the 'Polling interval must be at least 0 minutes' error.

  3. #3
    JakeMS's Avatar
    JakeMS is offline Active Member
    Join Date
    Jul 2013
    Location
    /dev/urandom
    Posts
    33
    Rep Power
    1

    Default

    Hi,

    Just tried this on our server, not seeing the issue on my end.

    The only thing I can think of which could cause this, is incorrectly setting the COS minimum time.

    I would suggest you go to edit the Class of Service of the user and check: Preferences -> Receiving Mail -> Minimum mail polling interval

    Ours is set to two (which is lowest) and everything works just fine.

    Just a note:
    "Manually" means a user will have to click check each time they want to check.. it does not mean, set their own value. The fastest option is "As New Mail Arrives".

    Hope this helps .

  4. #4
    Lascaille is offline Intermediate Member
    Join Date
    Aug 2011
    Posts
    16
    Rep Power
    3

    Default

    u2.png

    Already set.

  5. #5
    JakeMS's Avatar
    JakeMS is offline Active Member
    Join Date
    Jul 2013
    Location
    /dev/urandom
    Posts
    33
    Rep Power
    1

    Default

    Try setting to "2" and see if it fixes the issue .

  6. #6
    Lascaille is offline Intermediate Member
    Join Date
    Aug 2011
    Posts
    16
    Rep Power
    3

    Default

    But if you set MMPI to 2 minutes, you can't set 'as new mail arrives' as the PI... there's some sort of issue here although I am making headway. Something to do with the COS 'unlimited' not being passed properly to the user.

  7. #7
    Lascaille is offline Intermediate Member
    Join Date
    Aug 2011
    Posts
    16
    Rep Power
    3

    Default

    Okay here's what works:

    If you, in user administration (not user preferences) set a MMPI of 0 minutes, the user can't change their PI in preferences. Whatever setting you pick (aside from the first initial setting) you get the 'polling interval 0 minutes' error

    If you, in user admin (not user preferences) set a MMPI of 2 minutes, you can't then set a PI of 'as mail arrives' in user admin. You can set 'as mail arrives' in user preferences.

    So I can force 'as mail arrives' on all my users if I set the COS PI to 0 and that stops them from changing it? Maybe that's the idea. Or maybe it's just a bug.

  8. #8
    Lascaille is offline Intermediate Member
    Join Date
    Aug 2011
    Posts
    16
    Rep Power
    3

    Default

    BTW by 'user administration' I mean in the admin console, setting the user's preferences. By 'user preferences' I mean logged in as the user in the normal webmail interface.
    Last edited by Lascaille; 10-06-2013 at 06:37 AM. Reason: Unhhhhhhhhhh can't spell rite

  9. #9
    Lascaille is offline Intermediate Member
    Join Date
    Aug 2011
    Posts
    16
    Rep Power
    3

    Default

    Hmmmmm when I set 'as new mail arrives' in the user's preferences, when I go back into the admin console the setting is set to '500'

    If I set 2 minutes and then set again 'as new mail arrives' in the user's preferences, when I go into the admin console it's set to 'as new mail arrives' but the 'reset to COS default' button is present. If I hit the button, the display does not change apart from the button disappearing.

    I suspect an interface conflict between the WM UI and the AdminUI

  10. #10
    JakeMS's Avatar
    JakeMS is offline Active Member
    Join Date
    Jul 2013
    Location
    /dev/urandom
    Posts
    33
    Rep Power
    1

    Default

    Hmm.

    Not entirely sure why it would act like that at all.

    But on the plus side, at least you can get user preferences to work, but how you choose to proceed is entirely based on how you need the server.

    Personally, I would leave it user configurable. This way, users can choose how they want their mail to be received. Depending on how often you add accounts (and how many) you could probably, create the new account, and then login as the user, and set it upon first creation.

    However, if you are adding a lot of accounts, and often, this is not feasible at all.

    If two minutes is indeed the default, in my opinion that's not so bad. (a two minute delay, can't be that bad, and if the user needs to see stuff quicker, they can set it to be instant still).

    otherwise, if all of the above cannot be done, or is not a good choice for you, I'd advise setting it manually in the COS, and not allowing the user to change it.

    As for why Admin cannot set it in the COS, and allow a user to set the options, that's got to be a bug, no clue as to what's going on there.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 07-13-2009, 08:17 AM
  2. Set Polling Interval
    By gersh in forum Users
    Replies: 3
    Last Post: 12-18-2007, 04:41 PM
  3. Polling interval question
    By alexz in forum Users
    Replies: 1
    Last Post: 04-21-2006, 06:13 PM
  4. polling interval
    By rpvaughnjr in forum Users
    Replies: 8
    Last Post: 02-05-2006, 01:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •