Results 1 to 5 of 5

Thread: Virtual Domain Setup

  1. #1
    LaptopsForLess is offline New Member
    Join Date
    Nov 2006
    Posts
    3
    Rep Power
    8

    Default Virtual Domain Setup

    Hello,

    I have a zimbra server where we have multiple domains. In this case what I need to do is set up a virtual domain that points to a domain on zimbra so that mail destinated to user@domain2.com will automatically go into the user@domain1.com mailbox. I thought I saw that here in the forum but after searching for a couple of hours I'm at a loss. The commands that I have tried dont seem to work as I end up with a relay access denied when trying to send mail to user@domain2.com. Sending mail to user@domain1.com works fine.

    Please advise.

    Thank You

  2. #2
    azilber is offline Senior Member
    Join Date
    Feb 2007
    Posts
    52
    Rep Power
    8

    Default I'm having the same problem...

    It's as if postfix isn't reading the virtual domains from ldap.

    Setting up a virtual domain, I get:

    ...postfix/smtpd[8002]: NOQUEUE: reject: RCPT from ...

    in the zimbra logs.

    At a loss of what could be causing it..


    Quote Originally Posted by LaptopsForLess View Post
    Hello,

    I have a zimbra server where we have multiple domains. In this case what I need to do is set up a virtual domain that points to a domain on zimbra so that mail destinated to user@domain2.com will automatically go into the user@domain1.com mailbox. I thought I saw that here in the forum but after searching for a couple of hours I'm at a loss. The commands that I have tried dont seem to work as I end up with a relay access denied when trying to send mail to user@domain2.com. Sending mail to user@domain1.com works fine.

    Please advise.

    Thank You

  3. #3
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Did you try the wiki ?

  4. #4
    azilber is offline Senior Member
    Join Date
    Feb 2007
    Posts
    52
    Rep Power
    8

    Default Tried it but no cigar..

    I've gone through the wiki, the forums, and opened up a trouble ticket with Zimbra. Unfortunately, I'm trying to resolve this this weekend and of all the issues I've had since last night, this is the only one that remains.

    Basic problem that I have is. When I create a 'Virtual Domain' using the web admin console, I want to have postfix accept email for that domain.

    Quote Originally Posted by Klug View Post
    Did you try the wiki ?
    Trying the above on an existing domain did not work. Here's the result:

    ERROR: account.DOMAIN_EXISTS (domain already exists: xxxxxxx.com)

    Of course the domain exists.. I'm trying to create an alias for it. I've also verified that the domains exist in ldap under 'zimbraVirtualHostname' keys.

    I also see that postfix doesn't grab those values.

    /opt/zimbra/conf/ldap-vmd.cf:

    query_filter = (&(zimbraDomainName=%s)(zimbraDomainType=local)(zi mbraMailStatus=enabled))
    result_attribute = zimbraDomainName


    Maybe I need to modify the query? But if I do that, won't I be screwing myself when it comes to upgrading?

    -Alex

  5. #5
    azilber is offline Senior Member
    Join Date
    Feb 2007
    Posts
    52
    Rep Power
    8

    Default Actually.. it worked!

    That worked. I made a mistake with the domain name since they were nearly identical.

    Thanks!

    I've finally run out of problems! I've had commercial certificate, ssh and relaying problems. All done. Now I can actually begin using the system. w00t! :-)


    Quote Originally Posted by Klug View Post
    Did you try the wiki ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Using Virtual domain name in Outlook
    By russgalleywood in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 06-12-2007, 08:45 AM
  2. virtual domain login problem
    By wkruchas in forum Installation
    Replies: 0
    Last Post: 05-02-2007, 07:52 PM
  3. virtual host for new domain
    By alimovz in forum Administrators
    Replies: 3
    Last Post: 02-03-2007, 08:05 PM
  4. Question about Split Domain setup
    By ericding in forum Administrators
    Replies: 3
    Last Post: 05-05-2006, 05:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •