Results 1 to 10 of 10

Thread: zimbra zmapachectl issue on suse 11 server

  1. #1
    indunil75 is offline Senior Member
    Join Date
    Jul 2009
    Posts
    51
    Rep Power
    5

    Default zimbra zmapachectl issue on suse 11 server

    Hi,

    I installed zimbra 8.0.5 64 bit on suse 11 server. zimbra spell was failed. When I run zmapachectl start commad

    I get below error?


    Any idea?

    zmapachectl start

    Starting apache...httpd: Syntax error on line 148 of /opt/zimbra/conf/httpd.conf: Cannot load modules/libphp5.so into server: /opt/zimbra/httpd/modules/libphp5.so: symbol gzopen64, version ZLIB_1.2.3.3 not defined in file libz.so.1 with link time reference
    failed.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    Does your SLES 11 meet the minimum requirements as mentioned in the Release Notes i.e. does it have SP3 installed? You should post the exact messages from the log files before and after the 'apparent' problem, they may be significant rather than a sinlge out-of-context line. In addition, also post the output of the following command:

    Code:
    zmcontrol -v
    It helps to know the exact version & release of the product that's in use.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    djimbo is offline Starter Member
    Join Date
    Jun 2010
    Location
    Varna, Bulgaria
    Posts
    2
    Rep Power
    5

    Default

    Quote Originally Posted by indunil75 View Post
    Hi,

    I installed zimbra 8.0.5 64 bit on suse 11 server. zimbra spell was failed. When I run zmapachectl start commad

    I get below error?


    Any idea?

    zmapachectl start

    Starting apache...httpd: Syntax error on line 148 of /opt/zimbra/conf/httpd.conf: Cannot load modules/libphp5.so into server: /opt/zimbra/httpd/modules/libphp5.so: symbol gzopen64, version ZLIB_1.2.3.3 not defined in file libz.so.1 with link time reference
    failed.
    I have, try this

    wget http://download.opensuse.org/distrib...8.1.x86_64.rpm
    wget http://download.opensuse.org/distrib...8.1.x86_64.rpm
    wget http://download.opensuse.org/distrib...8.1.x86_64.rpm

    rpm -Uvh --nodeps zlib-devel-1.2.5-8.1.x86_64.rpm
    rpm -Uvh zlib-1.2.5-8.1.x86_64.rpm
    rpm -Uvh zlib-32bit-1.2.5-8.1.x86_64.rpm

    strings /lib64/libz.so.1 | grep 1.2.3.3

  4. #4
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,367
    Rep Power
    10

    Default

    Please ssh in to your SLES Zimbra server and post the results of the following command:

    Code:
    cat /etc/SuSE-release
    Mark

  5. #5
    djimbo is offline Starter Member
    Join Date
    Jun 2010
    Location
    Varna, Bulgaria
    Posts
    2
    Rep Power
    5

    Default

    Quote Originally Posted by LMStone View Post
    Please ssh in to your SLES Zimbra server and post the results of the following command:

    Code:
    cat /etc/SuSE-release
    Mark
    Hello Mark,

    xxx:~ # cat /etc/SuSE-release
    openSUSE 11.1 (x86_64)
    VERSION = 11.1
    xxx:~> zmcontrol -v
    Release 8.0.5_GA_5839.SLES11_64_20130910123623 openSUSEUNKNOWN_64 FOSS edition.

  6. #6
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,367
    Rep Power
    10

    Default

    Quote Originally Posted by djimbo View Post
    Hello Mark,

    xxx:~ # cat /etc/SuSE-release
    openSUSE 11.1 (x86_64)
    VERSION = 11.1
    xxx:~> zmcontrol -v
    Release 8.0.5_GA_5839.SLES11_64_20130910123623 openSUSEUNKNOWN_64 FOSS edition.
    Zimbra is not supported on OpenSUSE, only on SUSE Linux Enterprise Server Service Pack 3 (for 8.0.5). You might be able to make it work on Tumbleweed but your best bet would be to move to a supported operating system.

    Hope that helps
    Mark

  7. #7
    bootboy1 is offline Starter Member
    Join Date
    Apr 2014
    Posts
    2
    Rep Power
    1

    Default Got the same troubles now with actual Zimbra release and SuSe Enterprise Server

    Quote Originally Posted by LMStone View Post
    Zimbra is not supported on OpenSUSE, only on SUSE Linux Enterprise Server Service Pack 3 (for 8.0.5). You might be able to make it work on Tumbleweed but your best bet would be to move to a supported operating system.

    Hope that helps
    Mark
    Here is my error message + SuSe Version and zcs version ! Upgraded cause ofe the Openssl patch from 8.02 to 8.07 maybe anyone can help me out ?

    Starting apache...httpd: Syntax error on line 148 of /opt/zimbra/conf/httpd.conf: Cannot load modules/libphp5.so into server: /opt/zimbra/httpd/modules/libphp5.so: symbol gzopen64, version ZLIB_1.2.3.3 not defined in file libz.so.1 with link time reference
    failed.


    Starting mta...Done.
    Starting stats...Done.
    zimbra@mail:~/bin> exit
    exit
    mail:/ # cat /etc/SuSE-release
    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 1
    mail:/ # vi /opt/zimbra/conf/httpd.conf
    mail:/ # su zimbra
    zimbra@mail:/> zmc
    zmcaldebug zmcbpolicydctl zmcertmgr zmclamdctl zmcleaniplanetics zmconfigdctl zmcontrol zmconvertctl
    zimbra@mail:/> zmc
    zmcaldebug zmcbpolicydctl zmcertmgr zmclamdctl zmcleaniplanetics zmconfigdctl zmcontrol zmconvertctl
    zimbra@mail:/> zmcontrol -v
    Release 8.0.7_GA_6020.SLES11_64_20140321160620 SLES11_64 NETWORK edition.
    zimbra@mail:/>

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    Quote Originally Posted by bootboy1 View Post
    Here is my error message + SuSe Version and zcs version ! Upgraded cause ofe the Openssl patch from 8.02 to 8.07 maybe anyone can help me out ?
    Did you read the Release Notes or the post that you've quoted? You are required to have SP3 installed, do you have that? If you don't then you need to install it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,367
    Rep Power
    10

    Default

    Quote Originally Posted by bootboy1 View Post
    Here is my error message + SuSe Version and zcs version ! Upgraded cause ofe the Openssl patch from 8.02 to 8.07 maybe anyone can help me out ?

    Starting apache...httpd: Syntax error on line 148 of /opt/zimbra/conf/httpd.conf: Cannot load modules/libphp5.so into server: /opt/zimbra/httpd/modules/libphp5.so: symbol gzopen64, version ZLIB_1.2.3.3 not defined in file libz.so.1 with link time reference
    failed.


    Starting mta...Done.
    Starting stats...Done.
    zimbra@mail:~/bin> exit
    exit
    mail:/ # cat /etc/SuSE-release
    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 1
    mail:/ # vi /opt/zimbra/conf/httpd.conf
    mail:/ # su zimbra
    zimbra@mail:/> zmc
    zmcaldebug zmcbpolicydctl zmcertmgr zmclamdctl zmcleaniplanetics zmconfigdctl zmcontrol zmconvertctl
    zimbra@mail:/> zmc
    zmcaldebug zmcbpolicydctl zmcertmgr zmclamdctl zmcleaniplanetics zmconfigdctl zmcontrol zmconvertctl
    zimbra@mail:/> zmcontrol -v
    Release 8.0.7_GA_6020.SLES11_64_20140321160620 SLES11_64 NETWORK edition.
    zimbra@mail:/>
    Upgrade SLES to Service Pack 2, then to Service Pack 3 and then run the Zimbra installer again. Your SLES 11 is at Service Pack 1; won't work!

    Hope that helps,
    Mark

  10. #10
    bootboy1 is offline Starter Member
    Join Date
    Apr 2014
    Posts
    2
    Rep Power
    1

    Default

    Quote Originally Posted by LMStone View Post
    Upgrade SLES to Service Pack 2, then to Service Pack 3 and then run the Zimbra installer again. Your SLES 11 is at Service Pack 1; won't work!

    Hope that helps,
    Mark
    Thank you very much for help, I did upgrades on various Linux Distributions yesterday , till I came across this SLES , I managed to upgrade to SP2 but then as I expected I get a whole lot of errors , regarding the Repository Links to SP3 are not valid ..... and so on , so I will give it a try again after office hours because itīs a production server. Zimbra works except the webmail of course .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmapachectl is not running since i reboot my server
    By amenophis in forum Installation
    Replies: 2
    Last Post: 07-05-2009, 10:24 AM
  2. Problem with a SUSE Server and Zimbra Server
    By darkshadowmaster in forum Installation
    Replies: 2
    Last Post: 02-04-2008, 03:19 PM
  3. Replies: 5
    Last Post: 10-15-2007, 07:20 AM
  4. dns issue with suse 10.2 and issue with bind
    By zjustin in forum Installation
    Replies: 11
    Last Post: 05-06-2007, 11:18 AM
  5. Replies: 2
    Last Post: 01-30-2007, 01:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •