Results 1 to 9 of 9

Thread: Memory Issues

  1. #1
    glennbtn is offline Loyal Member
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default Memory Issues

    Hi All

    1 of my customers has a dying server so I have restored their ZImbra for now on a kvm. The issue now is the server needs rebooting everyday due to java using all the memory. Now I know there is a setting somewhere to change to stop this but not sure of the commands to check the current size and how to change it.

    Any info would be great

    Thanks

    Glenn

  2. #2
    Brad_C is offline Special Member
    Join Date
    Apr 2012
    Posts
    100
    Rep Power
    3

    Default

    G'day Glenn,

    We really need a bit more info.

    Stuff like :
    - Zimbra Version
    - Resources allocated to the KVM
    - Number of users

    For example, I have a 7.2.4 instance running under kvm. The guest OS is Ubuntu 10.04-64 and I have 2.5G of ram and 2 CPU's allocated to the VM, however I only have about 8 users.

    When you say "java using all the memory", are you referring to it pushing everything else out to swap and therefore the VM grinding to a halt, or are you referring to it running away and consuming all available resources (both RAM and swap) ?

  3. #3
    glennbtn is offline Loyal Member
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default

    HI Brad

    This is Ubuntu 12.04 running Zimbra 8.0.4 with 4gb of ram and 2 cpu's with around 12 users.

    Basically it's a temp solution whilst we order a new server. The vm is using all available memory so we need to restart the services to reduce this down again. I have read somewhere you can adjust the system to how much memory etc you will allow java to use.

    Thanks

    Glenn

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    su - zimbra
    zmlocalconfig -e mailboxd_java_heap_new_size_percent=20
    zmmailboxdctl restart
    The Java process will not consume twenty percent of the guest memory. If you need to reduce the memory more then you can tune the MySQL database as-well.

  5. #5
    glennbtn is offline Loyal Member
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default

    Thanks fantastic thanks.

    What would the command be for the MySQL side for reference

    Many thanks

    Glenn

  6. #6
    federico.bertola's Avatar
    federico.bertola is online now Special Member
    Join Date
    Jul 2006
    Location
    Verona, Italy
    Posts
    153
    Rep Power
    9

    Default

    Hi all!

    I suggest to check the bible about all memory issues:
    mailboxd_java_heap_memory_percent: (Deprecated in ZCS 7.0. See mailboxd_java_heap_size below.) This variable determines the percentage of system memory that should be used for Java heap (ie, -Xms and -Xmx JVM option values are derived from this local config variable). The default value is 30% - if you have 8GB of RAM, you will end up with a 2.4GB heap size. It is important to know that the Java process size will be much bigger than the heap size you configure here - the JVM uses memory for other purposes as well, eg, see note about thread stack size above....

    My 2 cents!
    Federico Bertola
    CTO @ StudioStorti

  7. #7
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    su - zimbra
    zmlocalconfig -e mysql_memory_percent=10
    be careful on changing the values though and do them through a slow reduction

  8. #8
    glennbtn is offline Loyal Member
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default

    Many thanks

  9. #9
    federico.bertola's Avatar
    federico.bertola is online now Special Member
    Join Date
    Jul 2006
    Location
    Verona, Italy
    Posts
    153
    Rep Power
    9

    Default

    Quote Originally Posted by uxbod View Post
    zmlocalconfig -e mysql_memory_percent=10
    Sorry Uxbod but I have another notice from Ajcody-Mysql-Topics:
    Looks like there's an issue with the command/variable (zmlocalconfig -e mysql_memory_percent=##) in regards to MySQL though.
    "There is a local config variable [mysql_memory_percent] for mysql memory percent, but today my.cnf doesn't get rewritten after install, so you have to edit my.cnf for this setting if you want to change it."
    In summary, this variable [ mysql_memory_percent ] for MySQL is basically not working.
    My other 2 cents.
    Federico Bertola
    CTO @ StudioStorti

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ZCS 7.1.3 consumed a lot of memory (all system memory)
    By soba@ukw.edu.pl in forum Administrators
    Replies: 9
    Last Post: 12-07-2011, 05:23 PM
  2. Memory issues after installation
    By stormrider in forum Administrators
    Replies: 1
    Last Post: 06-07-2011, 11:20 AM
  3. Memory issues after installation
    By stormrider in forum Installation
    Replies: 0
    Last Post: 06-06-2011, 04:57 PM
  4. CPU/Memory Issues Ubuntu 8.0.4
    By uushaggy in forum Administrators
    Replies: 6
    Last Post: 07-20-2009, 10:01 AM
  5. memory
    By rdavisids in forum Administrators
    Replies: 1
    Last Post: 02-02-2006, 01:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •