Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: zcs community 8.04 - mta will not start

  1. #1
    dwfallin is offline Active Member
    Join Date
    Mar 2009
    Location
    Memphis
    Posts
    30
    Rep Power
    6

    Default zcs community 8.04 - mta will not start - SOLVED

    ubuntu 12.04 64bit, up do date; zimbra 8.04 community edition has been up and running for a couple months.
    clean shutdown last night and (i thought) restart, cpl complaints this am and login, admin interface says everything is up, as does "zmcontrol status", but "zmmtactl stop" says its not running. sure enough, "zmmtactl start" doesn't give errors, but telnet to port 25 says connection refused.
    no changes were made, its possible some patches (from os) were applied, i did to an apt-get upgrade on it.

    zimbra@zcss:/var/log$ tail mail.log
    Aug 12 11:27:07 zcss postfix/postqueue[9549]: fatal: Queue report unavailable - mail system is down
    Aug 12 11:27:37 zcss postfix/postqueue[9865]: fatal: Queue report unavailable - mail system is down

    zimbra@zcss:/var/log$ tail mail.err
    Aug 12 11:28:07 zcss postfix/postqueue[10111]: fatal: Queue report unavailable - mail system is down
    Aug 12 11:28:37 zcss postfix/postqueue[10485]: fatal: Queue report unavailable - mail system is down

    zimbra@zcss:/var/log$ tail zimbra.log
    Aug 12 11:31:18 zcss zmconfigd[2011]: All rewrite threads completed in 0.00 sec
    Aug 12 11:31:18 zcss zmconfigd[2011]: All restarts completed in 0.00 sec
    Aug 12 11:31:37 zcss postfix/postqueue[11726]: fatal: Queue report unavailable - mail system is down
    Aug 12 11:32:07 zcss postfix/postqueue[12020]: fatal: Queue report unavailable - mail system is down
    Aug 12 11:32:18 zcss zmconfigd[2011]: Fetching All configs
    Aug 12 11:32:18 zcss zmconfigd[2011]: All configs fetched in 0.07 seconds
    Aug 12 11:32:20 zcss zmconfigd[2011]: Watchdog: service antivirus status is OK.
    Aug 12 11:32:20 zcss zmconfigd[2011]: All rewrite threads completed in 0.00 sec
    Aug 12 11:32:20 zcss zmconfigd[2011]: All restarts completed in 0.00 sec
    Aug 12 11:32:37 zcss postfix/postqueue[12346]: fatal: Queue report unavailable - mail system is down

    any suggestions? i guess i'll bump up the debug logging for postfix and try to restart it?
    thanks
    Last edited by dwfallin; 08-12-2013 at 07:31 PM. Reason: SOLVED!

  2. #2
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Sometimes postfix leaves a "ghost" process behind. Do an zmcontrol stop, and then see if any postfix processes are still running.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    dwfallin is offline Active Member
    Join Date
    Mar 2009
    Location
    Memphis
    Posts
    30
    Rep Power
    6

    Default

    there's no postfix processes after i do a zmcontrol start!!

    zimbra@zcss:~$ zmcontrol status
    Host zcss.aktagroup.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    opendkim Running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running
    zimbra@zcss:~$ ps -ef | grep post
    zimbra 24990 24330 0 13:11 pts/1 00:00:00 grep post
    zimbra@zcss:~$

  4. #4
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    As Zimbra, run "postfix start" and see what it outputs.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #5
    dwfallin is offline Active Member
    Join Date
    Mar 2009
    Location
    Memphis
    Posts
    30
    Rep Power
    6

    Default

    hmmm... not very helpful (to me):

    zimbra@zcss:~$ postfix start
    zimbra@zcss:~$

  6. #6
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    ps -eaf | grep postfix

    examine /var/log/zimbra.log and see what postfix reports.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #7
    dwfallin is offline Active Member
    Join Date
    Mar 2009
    Location
    Memphis
    Posts
    30
    Rep Power
    6

    Default

    zimbra@zcss:~$ ps -eaf | grep postfix
    zimbra 9055 8363 0 13:47 pts/1 00:00:00 grep postfix

    zimbra@zcss:/var/log$ tail zimbra.log
    Aug 12 13:46:59 zcss zmconfigd[2011]: Watchdog: service antivirus status is OK.
    Aug 12 13:46:59 zcss zmconfigd[2011]: All rewrite threads completed in 0.00 sec
    Aug 12 13:46:59 zcss zmconfigd[2011]: All restarts completed in 0.00 sec
    Aug 12 13:47:14 zcss postfix/postqueue[9058]: fatal: Queue report unavailable - mail system is down
    Aug 12 13:47:44 zcss postfix/postqueue[9075]: fatal: Queue report unavailable - mail system is down
    Aug 12 13:47:59 zcss zmconfigd[2011]: Fetching All configs
    Aug 12 13:47:59 zcss zmconfigd[2011]: All configs fetched in 0.06 seconds
    Aug 12 13:48:01 zcss zmconfigd[2011]: Watchdog: service antivirus status is OK.
    Aug 12 13:48:01 zcss zmconfigd[2011]: All rewrite threads completed in 0.00 sec
    Aug 12 13:48:01 zcss zmconfigd[2011]: All restarts completed in 0.00 sec

    pretty much the same set of messages since i restarted the box around midnight. i dont see any other message that postfix has logged to zimbra.log (since midnight). when i booted it last night, this was the first/only message i got from postfix (in zimbra.log):
    Aug 12 00:29:48 zcss zmmailboxdmgr[2260]: manager started mailboxd/JVM with pid 2261
    Aug 12 00:29:48 zcss zmmailboxdmgr[2261]: wrote java pid 2261 to /opt/zimbra/log/zmmailboxd_java.pid
    Aug 12 00:29:58 zcss zimbramon[942]: 942:info: Starting antispam via zmcontrol
    Aug 12 00:30:02 zcss postfix/postqueue[2473]: fatal: Queue report unavailable - mail system is down
    Aug 12 00:30:02 zcss zimbramon[2444]: 2444:info: 2013-08-12 00:30:01, QUEUE: 0 0

    i dont see any other messages that look disturbing. its not a busy server, but it has been in service for several weeks without issue.

    (thanks for helping with this)

  8. #8
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Utterly bizarre... postfix should be logging why it won't start to the screen when you run postfix start, and it should be logging out to /var/log/zimbra.log as well, and it doesn't seem to be doing either. Have you made any type of changes recently to the configuration?

    Alternatively, is something else already listening to the MTA ports, like sendmail or exim?
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  9. #9
    dwfallin is offline Active Member
    Join Date
    Mar 2009
    Location
    Memphis
    Posts
    30
    Rep Power
    6

    Default

    nothing on purpose! all i've done are apt-get updates (to os). something else already grabbing the port was the first thing i looked for, and didn't see anything:

    zimbra@zcss:~$ netstat -a | grep tcp| grep smtp
    zimbra@zcss:~$ netstat -a | grep tcp | grep 25
    tcp 0 0 *:7025 *:* LISTEN
    zimbra@zcss:~$ telnet 127.0.0.1
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused
    zimbra@zcss:~$

    bizarre indeed! is there anyway to bump the logging/debug level of postfix? hmmm.. why would an apt-get update could break/disable postfix? what about selinux or some kind of security daemon/setting?

    i'm at a loss... i've got another zimbra server that i've not upgraded to ubuntu 12.04 yet (still 10.04), guess i'll leave it where it lies for now!

  10. #10
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    netstat -an will convert everything to numbers.

    Postfix listens on a number of ports besides 25. 587 and 465 come to mind as well. I'm not sure what else you can do other than increase logging.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 10-10-2012, 05:43 AM
  2. Replies: 9
    Last Post: 10-11-2011, 05:43 AM
  3. ZCS 5.0.7 + ubuntu (community pkg)
    By ralph in forum Installation
    Replies: 5
    Last Post: 07-09-2008, 02:26 AM
  4. Thank you developers & Community!
    By OverZealous in forum Installation
    Replies: 1
    Last Post: 04-29-2007, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •