Results 1 to 4 of 4

Thread: zmsetservername went wrong

  1. #1
    Narev is offline Active Member
    Join Date
    Sep 2010
    Location
    Enschede Netherlands
    Posts
    47
    Rep Power
    4

    Default zmsetservername went wrong

    While reading through the many threads about this subject i still have not managed to find my solution. So i hope on some help here.

    What we did was we created an exact copy of our production machine and renamed this test machine. However as communications weren't halted as suggested in the wiki help it resulted in a change in the production server.

    Now we are left with a broken production server on which the ldap server cannot start, because:

    FATAL [main] [] system - Could not find an LDAP entry for server 'zimbra.capegroep.nl'
    another thing i noticed is that it states the following in zimbra.log:

    Aug 7 08:44:10 zimbra postfix/lmtp[24600]: 935D9AD547: to=<anemailadress@capegroep.nl>
    , relay=none, delay=0.02, delays=0.02/0/0/0, dsn=5.4.4, status=bounced (Host or
    domain name not found. Name service error for name=testcapegroep.nl type=A: Host
    not found)
    running the standard drill returns the following:

    zimbra@zimbra:/home/capegroep$ cat /etc/hosts
    127.0.0.1 localhost localhost.localdomain
    127.0.1.1 www.kantoor.echelon.nl www
    217.119.234.228 zimbra.capegroep.nl zimbra

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    zimbra@zimbra:/home/capegroep$ cat /etc/resolv.conf
    search capegroep.nl
    nameserver 217.119.226.67
    nameserver 217.119.226.68
    zimbra@zimbra:/home/capegroep$ dig capegroep.nl mx

    ; <<>> DiG 9.4.2-P2.1 <<>> capegroep.nl mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4646
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;capegroep.nl. IN MX

    ;; ANSWER SECTION:
    capegroep.nl. 300 IN MX 10 zimbra.capegroep.nl.

    ;; AUTHORITY SECTION:
    capegroep.nl. 267 IN NS ns1.dn-s.nl.
    capegroep.nl. 267 IN NS ns2.dn-s.nl.

    ;; ADDITIONAL SECTION:
    zimbra.capegroep.nl. 300 IN A 217.119.234.228

    ;; Query time: 6 msec
    ;; SERVER: 217.119.226.67#53(217.119.226.67)
    ;; WHEN: Tue Aug 6 22:36:31 2013
    ;; MSG SIZE rcvd: 110
    zimbra@zimbra:/home/capegroep$ dig capegroep.nl any

    ; <<>> DiG 9.4.2-P2.1 <<>> capegroep.nl any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37466
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 2, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;capegroep.nl. IN ANY

    ;; ANSWER SECTION:
    capegroep.nl. 267 IN MX 10 zimbra.capegroep.nl.
    capegroep.nl. 234 IN NS ns2.dn-s.nl.
    capegroep.nl. 234 IN NS ns1.dn-s.nl.

    ;; AUTHORITY SECTION:
    capegroep.nl. 234 IN NS ns2.dn-s.nl.
    capegroep.nl. 234 IN NS ns1.dn-s.nl.

    ;; ADDITIONAL SECTION:
    zimbra.capegroep.nl. 267 IN A 217.119.234.228

    ;; Query time: 0 msec
    ;; SERVER: 217.119.226.67#53(217.119.226.67)
    ;; WHEN: Tue Aug 6 22:37:04 2013
    ;; MSG SIZE rcvd: 138
    zimbra@zimbra:/home/capegroep$ host `hostname`
    zimbra.capegroep.nl has address 217.119.234.228
    Any idea on what i can do to restore our production server
    Last edited by Narev; 08-06-2013 at 11:53 PM.

  2. #2
    Narev is offline Active Member
    Join Date
    Sep 2010
    Location
    Enschede Netherlands
    Posts
    47
    Rep Power
    4

    Default

    We solved this by setting back the server name of the production machine using once again zmsetservername in combination with the --oldServerName testcapegroep.nl. Apparently the default was set back to zimbra.capegroep.nl thus resulting in an incomplete change. By explicitly stating the old servername it found the corrupt ldap entries and fixed those to our normal servername.

  3. #3
    prashant's Avatar
    prashant is offline Zimbra Employee
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    8

    Default

    Good All the best.
    ~=Prashant=~

  4. #4
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    10

    Default

    Quote Originally Posted by Narev View Post
    We solved this by setting back the server name of the production machine using once again zmsetservername in combination with the --oldServerName testcapegroep.nl. Apparently the default was set back to zimbra.capegroep.nl thus resulting in an incomplete change. By explicitly stating the old servername it found the corrupt ldap entries and fixed those to our normal servername.
    One other thing is that your /etc/hosts file should correct the line as follows:

    Code:
    127.0.0.1 localhost.localdomain localhost
    Hope that helps,
    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to change ZmSetServerName zimbra 8
    By anatifaana in forum Administrators
    Replies: 2
    Last Post: 11-13-2012, 12:14 PM
  2. Error Zmsetservername
    By gustavocearasc in forum Administrators
    Replies: 0
    Last Post: 11-23-2011, 06:02 PM
  3. ZmsetServerName in 5.0.16 urgent
    By brahmanand in forum Administrators
    Replies: 1
    Last Post: 02-10-2011, 01:46 AM
  4. ZMSetServername and various problems
    By rcaudill in forum Administrators
    Replies: 10
    Last Post: 07-30-2010, 07:33 AM
  5. zmsetservername command
    By tiger2000 in forum Administrators
    Replies: 1
    Last Post: 11-23-2008, 11:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •