Results 1 to 8 of 8

Thread: Out of office sends from localhost.localdomain

  1. #1
    GlobalAdvisorsIT is offline Junior Member
    Join Date
    Aug 2013
    Posts
    8
    Rep Power
    1

    Default Out of office sends from localhost.localdomain

    Hello

    I cannot find the answer to this.

    Out-of-office emails are sent with the following parameters:

    From host: localhost.localdomain
    From domain:
    From IP: 127.0.0.1


    This is rejected by our smart host.

    As far as I can tell, this started happening after our last upgrade. It definitely worked after install.

    The logs show:

    2013-08-05 12:26:42,236 INFO [LmtpServer-6] [ip=192.168.0.66;] lmtp - Delivering message: size=2709 bytes, nrcpts=1, sender=outsidesender@gmail.com, msgid=<CAAPSV0UHwR_HvZ=aCnd9-r6DfW38m8nwJyiLo19aT9i8128RjA@mail.gmail.com>
    2013-08-05 12:26:42,259 INFO [LmtpServer-6] [name=ipad@mydomain;mid=21;ip=192.168.0.66;] mailop - Adding Message: id=420, Message-ID=<CAAPSV0UHwR_HvZ=aCnd9-r6DfW38m8nwJyiLo19aT9i8128RjA@mail.gmail.com>, parentId=-1, folderId=2, folderName=Inbox.
    2013-08-05 12:26:42,717 INFO [LmtpServer-6] [name=ipad@mydomain;mid=21;ip=192.168.0.66;] smtp - Sending message to MTA at mysrv6i1.mydomain: Message-ID=<724060095.17.1375698402485.JavaMail.zimbra@mys rv6i1.mydomain>
    2013-08-05 12:26:42,830 INFO [LmtpServer-6] [name=ipad@mydomain;mid=21;ip=192.168.0.66;] mailbox - outofoffice sent dest='outsidesender@gmail.com' rcpt='ipad@mydomain' mid=420
    2013-08-05 12:26:42,836 INFO [LmtpServer-6] [] lmtp - Handler exiting normally



    The answers to the DNS and hosts questions I have seen asked are as follows:

    /etc/hosts

    127.0.0.1 localhost.localdomain localhost
    127.0.1.1 localhost.localdomain localhost
    192.168.0.66 mysrv6i1.mydomain mysrv6i1
    192.168.0.66 mail.mydomain mail
    192.168.0.66 mailhost.mydomain mailhost

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters


    nslookup mx

    > set type=mx
    > mydomain
    Server: 192.168.0.65
    Address: 192.168.0.65#53

    mydomain mail exchanger = 10 mysrv6i1.mydomain.

    > set type=any
    > mysrv6i1.mydomain
    Server: 192.168.0.65
    Address: 192.168.0.65#53

    Name: mysrv6i1.mydomain
    Address: 192.168.0.66


    host `hostname`

    mysrv6i1.mydomain has address 192.168.0.66

    host -v mysrv6i1.mydomain
    Trying "mysrv6i1.mydomain"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58498
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;mysrv6i1.mydomain. IN A

    ;; ANSWER SECTION:
    mysrv6i1.mydomain. 0 IN A 192.168.0.66

    ;; AUTHORITY SECTION:
    mydomain. 900 IN NS mysrv5i1.mydomain.

    ;; ADDITIONAL SECTION:
    mysrv5i1.mydomain. 900 IN A 192.168.0.65

    Received 104 bytes from 192.168.0.65#53 in 10 ms
    Trying "mysrv6i1.mydomain"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53364
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mysrv6i1.mydomain. IN AAAA

    ;; AUTHORITY SECTION:
    mydomain. 0 IN SOA mysrv5i1.mydomain. hostmaster.mydomain. 59 900 600 86400 0

    Received 105 bytes from 192.168.0.65#53 in 7 ms
    Trying "mysrv6i1.mydomain"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28695
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mysrv6i1.mydomain. IN MX

    ;; AUTHORITY SECTION:
    mydomain. 0 IN SOA mysrv5i1.mydomain. hostmaster.mydomain. 59 900 600 86400 0

    Received 105 bytes from 192.168.0.65#53 in 8 ms

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    Your hosts file is incorrect, your LAN DNS records are also incorrect (as are the configuration of your public DNS records) as you have no MX record. Go to the Split DNS wiki and check the required format for the hosts file and the DNS records - the DNS records format also applies to your public records with the obvious use of the Public IP. You've also given no details of which version & release of Zimbra is in use nor from which version you upgraded.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    GlobalAdvisorsIT is offline Junior Member
    Join Date
    Aug 2013
    Posts
    8
    Rep Power
    1

    Default

    Bill

    Thanks for the help.

    Apologies - I should have restated the version from my profile - it is 8.0.4.GA.5737.UBUNTU12.64 UBUNTU12_64 FOSS edition.

    This was a dot upgrade - I believe from 8.0.2

    My hosts file is exactly as per the split-DNS wiki except that it contains an entry for 127.0.1.1 and after the host name, alias names. Is this incorrect?

    I do not understand why you believe I do not have an MX entry. I have shown the output from the MX query resolving to my Zimbra host.

    In case of any confusion, "mydomain" above and below is our disguised FQDN.

    Our public DNS shows MX entries to A records:

    nslookup
    > server 8.8.8.8
    Default server: 8.8.8.8
    Address: 8.8.8.8#53
    > set type=MX
    > mydomain
    Server: 8.8.8.8
    Address: 8.8.8.8#53

    Non-authoritative answer:
    mydomain mail exchanger = 10 mydomain.
    mydomain mail exchanger = 20 mx2.mailhop.org.

    Authoritative answers can be found from:
    > set type=any
    > mydomain
    Server: 8.8.8.8
    Address: 8.8.8.8#53

    Non-authoritative answer:
    mydomain
    origin = ns1.mydyndns.org
    mail addr = zone-admin.dyndns.com
    serial = 2011121737
    refresh = 10800
    retry = 1800
    expire = 604800
    minimum = 1800
    mydomain nameserver = ns4174.dns.dyn.com.
    mydomain nameserver = ns2149.dns.dyn.com.
    mydomain nameserver = ns3160.dns.dyn.com.
    mydomain nameserver = ns1177.dns.dyn.com.
    Name: mydomain
    Address: 105.236.138.20
    mydomain mail exchanger = 20 mx2.mailhop.org.
    mydomain mail exchanger = 10 mydomain.
    mydomain text = "v=spf1 include:dyndns.com ~all"

    Authoritative answers can be found from:

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    Quote Originally Posted by GlobalAdvisorsIT View Post
    My hosts file is exactly as per the split-DNS wiki except that it contains an entry for 127.0.1.1 and after the host name, alias names. Is this incorrect?
    The hosts file doesn't look like the wiki article, you have multiple entries for the LAN IP when you should only have one.

    Quote Originally Posted by GlobalAdvisorsIT View Post
    I do not understand why you believe I do not have an MX entry. I have shown the output from the MX query resolving to my Zimbra host.
    For the simple reason that you don't have an entry, the output of the command you've posted is for the wrong IP address.

    Quote Originally Posted by GlobalAdvisorsIT View Post
    In case of any confusion, "mydomain" above and below is our disguised FQDN.
    If your domain name is the one you use in your user profile email address then the public records do not use the FQDN of your server - they just show the domain name and they should use the fqdn of your server.

    You should also use the dig command as nslookup is deprecated and may possibly return incorrect information.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    GlobalAdvisorsIT is offline Junior Member
    Join Date
    Aug 2013
    Posts
    8
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    The hosts file doesn't look like the wiki article, you have multiple entries for the LAN IP when you should only have one.
    I have removed the aliases.

    Quote Originally Posted by phoenix View Post
    For the simple reason that you don't have an entry, the output of the command you've posted is for the wrong IP address.
    Thanks for doing the homework - we're on a dynamic IP which changed between the messages. That was the IP at the time - the DNS has updated to reflect the current. Both were / are correct at time of message.

    Quote Originally Posted by phoenix View Post
    If your domain name is the one you use in your user profile email address then the public records do not use the FQDN of your server - they just show the domain name and they should use the fqdn of your server.
    I did a search and replace for the entire FQDN with mydomain. Perhaps I should have indicated this with foo.bar

    Quote Originally Posted by phoenix View Post
    You should also use the dig command as nslookup is deprecated and may possibly return incorrect information.
    Here is the internal dig info:

    ; <<>> DiG 9.8.1-P1 <<>> foo.bar mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41308
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;foo.bar. IN MX

    ;; ANSWER SECTION:
    foo.bar. 0 IN MX 10 mysrv6i1.foo.bar.

    ;; AUTHORITY SECTION:
    foo.bar. 900 IN NS mysrv5i1.foo.bar.

    ;; ADDITIONAL SECTION:
    mysrv6i1.foo.bar. 0 IN A 192.168.0.66
    mysrv5i1.foo.bar. 900 IN A 192.168.0.65

    ;; Query time: 10 msec
    ;; SERVER: 192.168.0.65#53(192.168.0.65)
    ;; WHEN: Mon Aug 5 20:00:52 2013
    ;; MSG SIZE rcvd: 120


    Here is the external dig info:

    ; <<>> DiG 9.8.1-P1 <<>> @8.8.8.8 foo.bar mx
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51421
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;foo.bar. IN MX

    ;; ANSWER SECTION:
    foo.bar. 3600 IN MX 10 foo.bar.
    foo.bar. 3600 IN MX 20 mx2.mailhop.org.

    ;; Query time: 217 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Mon Aug 5 20:03:14 2013
    ;; MSG SIZE rcvd: 83


    ____

    ; <<>> DiG 9.8.1-P1 <<>> @8.8.8.8 foo.bar
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17503
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;foo.bar. IN A

    ;; ANSWER SECTION:
    foo.bar. 60 IN A 105.236.17.26

    ;; Query time: 210 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Mon Aug 5 20:03:59 2013
    ;; MSG SIZE rcvd: 52

  6. #6
    GlobalAdvisorsIT is offline Junior Member
    Join Date
    Aug 2013
    Posts
    8
    Rep Power
    1

    Default

    Ah. I think I see why you believe the public record uses only the domain name.

    The foo.bar is a host and domain. All traffic to foo.bar is routed based on port translation.

    You will see that the foo.bar is an A record.

  7. #7
    GlobalAdvisorsIT is offline Junior Member
    Join Date
    Aug 2013
    Posts
    8
    Rep Power
    1

    Default

    Thanks for the help so far.

    Despite changes logged above, the issue remains.

    Any help?

  8. #8
    GlobalAdvisorsIT is offline Junior Member
    Join Date
    Aug 2013
    Posts
    8
    Rep Power
    1

    Default

    Thanks for the help so far.

    Despite changes logged above, the issue remains.

    Any help?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 44
    Last Post: 04-08-2014, 08:37 AM
  2. from localhost (localhost.localdomain [127.0.0.1])
    By Shrewd in forum Installation
    Replies: 5
    Last Post: 02-03-2013, 09:02 AM
  3. Replies: 8
    Last Post: 06-20-2008, 05:10 AM
  4. Why does origin say localhost.localdomain?
    By sunshineknox in forum Administrators
    Replies: 4
    Last Post: 04-16-2007, 09:56 AM
  5. email from zimbra@localhost.localdomain
    By tstrimp in forum Administrators
    Replies: 14
    Last Post: 02-17-2007, 10:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •