Results 1 to 7 of 7

Thread: Zimbra 8.0.4 on port 443 only: cannot start Apache

  1. #1
    bmunger is offline Senior Member
    Join Date
    Apr 2010
    Posts
    50
    Rep Power
    5

    Default Zimbra 8.0.4 on port 443 only: cannot start Apache

    Hello,

    I'm trying to configure my Zimbra box to have a website on top of Zimbra.

    I've tried many things in the past, read some wikis and never got this right.

    I'm trying again (the Nth time) and I'm trying to make things more simple: Zimbra on 443 (https) and Apache2 on 80 (http).

    I've configured Zimbra to listen only to port 443 with the help of documentation here. Here is how I've done it:
    Code:
    zmtlsctl https
    I've tried to configure Apache to only listen on port 80 by changing the /etc/apache2/ports.conf file and commenting out the 443 port configs:
    Code:
    # If you just change the port or add more ports here, you will likely also
    # have to change the VirtualHost statement in
    # /etc/apache2/sites-enabled/000-default
    # This is also true if you have upgraded from before 2.2.9-3 (i.e. from
    # Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
    # README.Debian.gz
    
    NameVirtualHost *:80
    Listen 80
    
    #<IfModule mod_ssl.c>
        # If you add NameVirtualHost *:443 here, you will also have to change
        # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
        # to <VirtualHost *:443>
        # Server Name Indication for SSL named virtual hosts is currently not
        # supported by MSIE on Windows XP.
    #    Listen 443
    #</IfModule>
    
    #<IfModule mod_gnutls.c>
    #    Listen 443
    #</IfModule>
    When my machine rebooted from those changes, my Apache server was working but my mta service in Zimbra failed to start.

    I stopped Apache and started Zimbra... and it works fine on port 443 only (though I cannot confirm nothing is on port 80, i'm not sure how to really check this... lsof output is gibberish)

    Now I can't start Apache while Zimbra is running, I get this error message:

    Code:
     * Starting web server apache2                                                                                                                   
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
                                                                                                                                              [fail]

    So it's still not functional..

    Can you help?

  2. #2
    bmunger is offline Senior Member
    Join Date
    Apr 2010
    Posts
    50
    Rep Power
    5

    Default

    OK, I've checked port 80 with netstat and here is what I get:


    netstat -lpn | grep :80
    tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN 26456/java
    So java (I guess a portion of Zimbra somewhere) is still listening to port 80...

    Which service did I forget to redirect towards the https port 443 ?

  3. #3
    bmunger is offline Senior Member
    Join Date
    Apr 2010
    Posts
    50
    Rep Power
    5

    Default

    Solved!

    I did this:
    Code:
    zmprov ms [the.server.name.tld] zimbraMailPort 81
    and now my apache server started fine...
    Code:
    /etc/init.d/apache2 start
    * Starting web server apache2                                                                                                            [ OK ]
    Problem solved! I can continue my setup!

  4. #4
    guadag is offline Starter Member
    Join Date
    Dec 2013
    Posts
    2
    Rep Power
    1

    Default

    hello, it's all you have done? or there's something else?

  5. #5
    guadag is offline Starter Member
    Join Date
    Dec 2013
    Posts
    2
    Rep Power
    1

    Default

    now it works too, thanks

  6. #6
    bmunger is offline Senior Member
    Join Date
    Apr 2010
    Posts
    50
    Rep Power
    5

    Default

    Quote Originally Posted by guadag View Post
    hello, it's all you have done? or there's something else?
    In my case, it's all I needed to do. I only wanted the Zimbra system to listen to 81 instead of 80

    On my router I did the job of re-routing 81 externally... and I'm listening to the ssl port for Zimbra and exposing it externally... so I effectively can use my Apache server to have my own web site (which is still an unfinished job...)

  7. #7
    bmunger is offline Senior Member
    Join Date
    Apr 2010
    Posts
    50
    Rep Power
    5

    Default

    Quote Originally Posted by guadag View Post
    now it works too, thanks
    I'm glad it worked for you too!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 09-09-2009, 02:07 PM
  2. Access Zimbra on port 443 via apache
    By CatiaL in forum Administrators
    Replies: 1
    Last Post: 06-15-2007, 02:11 AM
  3. www Port Conflict/Changing Zimbra Apache Setting
    By macguru in forum Administrators
    Replies: 15
    Last Post: 04-16-2006, 09:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •