Results 1 to 5 of 5

Thread: Centos install on VMware Player. Works on local computer, but not on lan.

  1. #1
    FloppyDrive is offline New Member
    Join Date
    Jul 2013
    Posts
    4
    Rep Power
    2

    Unhappy Centos install on VMware Player. Works on local computer, but not on lan.

    Hi!
    I've installed Zimbra on a virtual instance of Centos 6.4. I am able to log onto https://mail/zimbraAdmin and https://mail works as expected on the local computer on which it's installed.
    But I cannot access the sites from any other computer on the LAN.

    I added permissions for the ports that Zimbra uses;
    [root@mail zimbra]# iptables -L -n
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT all -- 0.0.0.0/0 0.0.0.0/0 state RELATED,ESTABLISHED
    ACCEPT icmp -- 0.0.0.0/0 0.0.0.0/0
    ACCEPT all -- 0.0.0.0/0 0.0.0.0/0
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:22
    REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:80
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:7071
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:443

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination
    REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    The NIC setting on the VMplayer is set to "bridged", and I can confirm that the Zimbra server is getting a LAN ip address. I am also getting an internet connection on the Zimbra server, and I can ping to the Zimbra server from other computers on the LAN.

    Um. I set up the DNS settings and MX settings on the DNS server and the Zimbra server. I can provide whatever information you need. It's probably something simple but I'm not seeing it..

    Thanks.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,486
    Rep Power
    56

    Default

    You should disable the firewall on the Zimbra server and disable SElinux, if that machine is on a LAN then a firewall is of little use. Post the output of all the commands from the 'Verify...' section of the Split DNS wiki article. You should be aware that VMplayer is not a supported platform for ZCS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    FloppyDrive is offline New Member
    Join Date
    Jul 2013
    Posts
    4
    Rep Power
    2

    Default

    dig mail.test.com mx

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> mail.test.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2129
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;mail.test.com. IN MX

    ;; ANSWER SECTION:
    mail.test.com. 3600 IN MX 10 mail.test.com.

    ;; ADDITIONAL SECTION:
    mail.test.com. 3600 IN A 192.168.31.232

    ;; Query time: 144 msec
    ;; SERVER: 192.168.31.45#53(192.168.31.45)
    ;; WHEN: Thu Jul 25 11:44:30 2013
    ;; MSG SIZE rcvd: 64

    dig mail.test.com any

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> mail.test.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14252
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;mail.test.com. IN ANY

    ;; ANSWER SECTION:
    mail.test.com. 3600 IN A 192.168.31.232
    mail.test.com. 3600 IN MX 10 mail.test.com.

    ;; ADDITIONAL SECTION:
    mail.test.com. 3600 IN A 192.168.31.232

    ;; Query time: 2 msec
    ;; SERVER: 192.168.31.45#53(192.168.31.45)
    ;; WHEN: Thu Jul 25 11:46:19 2013
    ;; MSG SIZE rcvd: 80

    mail.test.com has address 192.168.31.232
    mail.test.com mail is handled by 10 mail.test.com

    My hosts file looks like this:
    127.0.0.1 localhost.localdomain localhost
    192.168.31.232 mail.test.com mail

  4. #4
    FloppyDrive is offline New Member
    Join Date
    Jul 2013
    Posts
    4
    Rep Power
    2

    Default

    I'm not sure if my other post went through...
    Everything looks to be working now. I think it was SElinux that was causing the problem, as I'm sure I tried disabling the firewall already.

    Https://mail and https://mail:7071/zimbraAdmin is working appropriately, but http://mail is not.
    I did do "zmtlsctl both".

  5. #5
    FloppyDrive is offline New Member
    Join Date
    Jul 2013
    Posts
    4
    Rep Power
    2

    Default

    Well everything was working last night, and then nothing was working this morning. I restarted the Zimbra services and now everything is working again (including http://mail).
    So... Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 03-05-2010, 05:06 PM
  2. Exporting Local Folder to other computer.
    By psalomaolx in forum Migration
    Replies: 1
    Last Post: 10-26-2009, 05:16 AM
  3. Replies: 1
    Last Post: 02-22-2008, 12:36 AM
  4. new install on vmware player but no mail received
    By kiwicmc in forum Installation
    Replies: 6
    Last Post: 03-06-2006, 07:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •