Hi everyone,

I've deployed ASSP to enhance Anti-Spam feature for our Zimbra mail systems. I had a problem related to smtp connection between ASSP and Zimbra Postfix. After receiving EHLO command from ASSP, Zimbra Postfix cannot connect to ASSP to get more smtp commands.

Here is our lab topology:
Internet mails -> ASSP -> Zimbra -> User's mailbox

I researched another cases to test smtp connection between ASSP and Postfix/Sendmail, they worked perfectly.

Here is /var/log/zimbra.log:
Jun 28 09:55:33 mail postfix/smtpd[19834]: smtp_get: timeout
Jun 28 09:55:33 mail postfix/smtpd[19834]: > unknown[192.168.100.11]: 421 4.4.2 mail.test.com Error: timeout exceeded
Jun 28 09:55:33 mail postfix/smtpd[19834]: match_hostname: unknown ~? 127.0.0.0/8
Jun 28 09:55:33 mail postfix/smtpd[19834]: match_hostaddr: 192.168.100.11 ~? 127.0.0.0/8
Jun 28 09:55:33 mail postfix/smtpd[19834]: match_hostname: unknown ~? 192.168.100.0/24
Jun 28 09:55:33 mail postfix/smtpd[19834]: match_hostaddr: 192.168.100.11 ~? 192.168.100.0/24
Jun 28 09:55:33 mail postfix/smtpd[19834]: timeout after EHLO from unknown[192.168.100.11]
Jun 28 09:55:33 mail postfix/smtpd[19834]: abort all milters
Jun 28 09:55:33 mail postfix/smtpd[19834]: milter8_abort: abort milter inet:127.0.0.1:8092
Jun 28 09:55:33 mail postfix/smtpd[19834]: disconnect event to all milters
Jun 28 09:55:33 mail postfix/smtpd[19834]: milter8_disc_event: quit milter inet:127.0.0.1:8092
Jun 28 09:55:33 mail postfix/smtpd[19834]: disconnect from unknown[192.168.100.11]
Thanks for your help!