Results 1 to 5 of 5

Thread: Question about zimbra proxy and multiserver setup

  1. #1
    anonymous0 is offline Member
    Join Date
    Oct 2012
    Posts
    13
    Rep Power
    2

    Default Question about zimbra proxy and multiserver setup

    Hello all.

    We had single server setup now and planning for migration to multi server. I think we needs to enable full proxy mode (imap+pop+http). I read the documentation and found that zimbra proxy may operates as full http proxy, throws session traffic through itself between the client and mailbox server. So the client operates with proxy as he operates with mailbox server directly. I installed two mailbox servers and proxy+ldap+mta server. Then on all 3 servers run this command:

    /opt/zimbra/libexec/zmproxyconfig -e -m -w -H mail-test-proxyldap.zm.bsu.edu.ru
    zmcontrol restart


    I assumed this command must turn on web and mail proxying functionality (right?). Now in web browser HTTP access on proxy is not working (port 80 closed). HTTPS access is works and show standart zimbra login page but when I type username and password it redirects me to one of mailbox server after login. But I thought that I must work with mailbox server through proxy all time. May be I'm misunderstood something or make incorrect configuration ? Need your help.

    P.S. Release 8.0.4_GA_5737.RHEL6_64_20130524120036 RHEL6_64 FOSS edition on CentoS 6.4 x86_64

  2. #2
    anonymous0 is offline Member
    Join Date
    Oct 2012
    Posts
    13
    Rep Power
    2

    Default

    For now I do some checks and found that this proxyconfig command do not works for me. Inaccurate command or some broken installation/misconfiguration ?

    On all servers I see this:

    zmprov gs `zmhostname` | grep -i mailport
    zimbraMailReferMode: wronghost

    Then I manually apply reverse-proxied configuration to this attribute. Looks like HTTPS full proxy works fine now.

    Can you get me link that describes all zimbra 8 default values (zimbraMailReferMode etc.) on multi-server environment for mailbox and proxy servers if http proxy is enabled ?

  3. #3
    prashant's Avatar
    prashant is offline Zimbra Employee
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    7

    Default

    The problem is been discussed in following links and is been solved.


    IT Mission Linux Tips, Hacks, Tutorials, Howtos - Itmission.org | Main / Zimbra-zmproxyconfig-command
    [SOLVED] Ngnix Help
    reverse proxy not working


    Can you get me link that describes all zimbra 8 default values (zimbraMailReferMode etc.) on multi-server environment for mailbox and proxy servers if http proxy is enabled ?

    If you want the default value on version 8 then execute "zmprov -l gs `zmhostname` | egrep -i zimbramail" on proxy and mailhost.
    ~=Prashant=~

  4. #4
    anonymous0 is offline Member
    Join Date
    Oct 2012
    Posts
    13
    Rep Power
    2

    Default

    Ok, thanks for the reply. I successfully setup zimbra proxy after following this links. The cause of the problems are my installation. First I installed servers without proxy and after installing proxy in update mode some ports settings was incorrect. And one more question. I cannot find any info about CASifying Zimbra proxy server. The article "CASifying Zimbra" from documentation describes only single server mode with jetty and all activity related to cas-client are jetty-specific. How should I enable CAS client for zimbra nginx?

  5. #5
    anonymous0 is offline Member
    Join Date
    Oct 2012
    Posts
    13
    Rep Power
    2

    Default

    Does anybody know details of this setup? For the time I think in this way: needs to develop custom PHP CAS extension and links it with zimbra nginx in someway. So, the configuration of the zimbra nginx required heavy modification to support this. Is this the correct way?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spilt domain in Multiserver setup
    By indunil75 in forum Administrators
    Replies: 1
    Last Post: 06-19-2012, 10:50 PM
  2. multiserver stup http proxy: 502 bad gateway nginx
    By sangamc in forum Administrators
    Replies: 1
    Last Post: 05-07-2012, 09:02 PM
  3. Converting single machine setup to multiserver setup
    By n.bochev in forum Installation
    Replies: 1
    Last Post: 10-13-2009, 09:30 PM
  4. [SOLVED] Help with Zimbra proxy setup
    By Lewisvee in forum Administrators
    Replies: 7
    Last Post: 10-11-2009, 10:23 PM
  5. Proxy IMAP and POP Setup question
    By drhughes in forum Installation
    Replies: 0
    Last Post: 03-25-2008, 12:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •