Results 1 to 4 of 4

Thread: Cannot send to outside addresses

  1. #1
    stefaug is offline Member
    Join Date
    Jun 2012
    Location
    Windhoek, Namibia
    Posts
    14
    Rep Power
    3

    Default Cannot send to outside addresses

    Good day to all the Fundi's, Gurus and other knowlegable & clever people,

    I installed ZCS 8.0.4 on SLES11 and uses fetcmail to collect external mail from a drop box. (Thanks again, Vavai!)
    MTA relays via the ISP.

    I can send and receive inernally.
    I receive external mail.
    Sending external mail gets returned with:
    Reporting-MTA: dns; arkmail.arktrading.com.na
    X-Postfix-Queue-ID: 1B5A01BC30A
    X-Postfix-Sender: rfc822; test@arktrading.com.na
    Arrival-Date: Tue, 25 Jun 2013 10:50:56 +0100 (WAT)

    Final-Recipient: rfc822; stefaug@iway.na
    Original-Recipient: rfc822;stefaug@iway.na
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; iway.na
    The DNS records:
    Code:
    zimbra@arkmail:~> zmcontrol -v
    Release 8.0.4_GA_5737.SLES11_64_20130524120036 SLES11_64 FOSS edition.
    
    zimbra@arkmail:~> dig arktrading.com.na mx
    
    ; <<>> DiG 9.6-ESV-R5-P1 <<>> arktrading.com.na mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41906
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;arktrading.com.na.             IN      MX
    
    ;; ANSWER SECTION:
    arktrading.com.na.      172800  IN      MX      10 arkmail.arktrading.com.na.
    
    ;; AUTHORITY SECTION:
    arktrading.com.na.      172800  IN      NS      ns1.arktrading.com.na.
    
    ;; ADDITIONAL SECTION:
    arkmail.arktrading.com.na. 172800 IN    A       192.168.10.251
    ns1.arktrading.com.na.  172800  IN      A       192.168.10.251
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Jun 25 11:03:21 2013
    ;; MSG SIZE  rcvd: 109
    
    zimbra@arkmail:~> nslookup ns1.arktrading.com.na
    Server:         127.0.0.1
    Address:        127.0.0.1#53
    
    Name:   ns1.arktrading.com.na
    Address: 192.168.10.251
    
    zimbra@arkmail:~> nslookup arkmail.arktrading.com.na
    Server:         127.0.0.1
    Address:        127.0.0.1#53
    
    Name:   arkmail.arktrading.com.na
    Address: 192.168.10.251
    
    zimbra@arkmail:~> cat /var/lib/named/master/arktrading.com.na
    $TTL 2D
    @               IN SOA          arkmail.arktrading.com.na.      root.arkmail.arktrading.com.na. (
                                    2013061701      ; serial
                                    3H              ; refresh
                                    1H              ; retry
                                    1W              ; expiry
                                    1D )            ; minimum
    
    arktrading.com.na.      IN MX           10 arkmail.arktrading.com.na.
    arktrading.com.na.      IN NS           ns1.arktrading.com.na.
    ns1             IN A            192.168.10.251
    arkmail         IN A            192.168.10.251
    zimbra@arkmail:~>
    I perused all 10 pages on searching for X-Postfix - could not find a solution.
    I installed the password security for the ISP SMTP server as per the WIKI - no avail.
    I tested if port 25 is open to the ISP:
    Code:
    zimbra@arkmail:~> nslookup
    > iway.na
    Server:         127.0.0.1
    Address:        127.0.0.1#53
    
    Non-authoritative answer:
    Name:   iway.na
    Address: 196.44.136.22
    >
    zimbra@arkmail:~> logout
    arkmail:~ # nslookup
    > iway.na
    Server:         127.0.0.1
    Address:        127.0.0.1#53
    
    Non-authoritative answer:
    Name:   iway.na
    Address: 196.44.136.22
    >
    arkmail:~ # su - zimbra
    zimbra@arkmail:~> telnet smtp.iway.na 25
    Trying 196.44.136.51...
    Connected to smtp.iway.na.
    Escape character is '^]'.
    220 mx2.iway.na NO UCE ESMTP Status=Connected
    ^]
    telnet> quit
    Connection closed.
    zimbra@arkmail:~>
    I cannot find anything significant in the logs.

    Please help.

  2. #2
    prashant's Avatar
    prashant is offline Zimbra Employee
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    8

  3. #3
    stefaug is offline Member
    Join Date
    Jun 2012
    Location
    Windhoek, Namibia
    Posts
    14
    Rep Power
    3

    Default

    FIXED! EUREKA

    All trat is left are messages in the deferred queue that were sent sent by a user that had the sender address wrong in the client setup: user.domain in stead of user@domain. Is there any way to either:
    > Correct the sender address on the server and re-queue them.
    > Move them to another address and resend them.

  4. #4
    stefaug is offline Member
    Join Date
    Jun 2012
    Location
    Windhoek, Namibia
    Posts
    14
    Rep Power
    3

    Default

    All solved THANKS!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 10-15-2013, 02:32 PM
  2. Multiple Email Addresses Can't Send From Two
    By FatalGlory in forum General Questions
    Replies: 0
    Last Post: 09-10-2012, 07:23 AM
  3. Can't send mail to some external addresses...
    By glang in forum Installation
    Replies: 2
    Last Post: 08-14-2009, 11:11 AM
  4. Replies: 1
    Last Post: 02-20-2008, 10:19 AM
  5. Replies: 1
    Last Post: 11-22-2006, 06:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •