Results 1 to 8 of 8

Thread: Getting bad gateway 502 error

  1. #1
    motang is offline Active Member
    Join Date
    Mar 2013
    Posts
    28
    Rep Power
    2

    Default Getting bad gateway 502 error

    When I go to the mail URL (ie https://mail.domain.com) I get a 502 Bad Gateway error, but if I go to https://mail.domain.com:8443 I get a log in prompt and am able to log to my email just fine. I can't seem to figure out how to fix this. Any suggestions?

    Thank you.

  2. #2
    motang is offline Active Member
    Join Date
    Mar 2013
    Posts
    28
    Rep Power
    2

    Default

    Well it seems that using https://mail.domain.com:443 doesn't work either.

    Any help would be much appreciated.
    Last edited by motang; 06-07-2013 at 06:59 AM.

  3. #3
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    sounds like you set it to be proxied
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #4
    motang is offline Active Member
    Join Date
    Mar 2013
    Posts
    28
    Rep Power
    2

    Default

    Quote Originally Posted by quanah View Post
    sounds like you set it to be proxied
    We do have other mail domains running on the single Zimbra install. I would like get back to the way it was.

    If I type in
    zmprov gacf | grep Port
    I get this print out:
    Code:
    zimbraAdminPort: 7071
    zimbraImapBindPort: 7143
    zimbraImapProxyBindPort: 143
    zimbraImapSSLBindPort: 7993
    zimbraImapSSLProxyBindPort: 993
    zimbraLmtpBindPort: 7025
    zimbraMailPort: 80
    zimbraMailProxyPort: 0
    zimbraMailSSLClientCertPort: 0
    zimbraMailSSLPort: 0
    zimbraMailSSLProxyClientCertPort: 0
    zimbraMailSSLProxyPort: 0
    zimbraMemcachedBindPort: 11211
    zimbraMilterBindPort: 7026
    zimbraNotifyBindPort: 7035
    zimbraNotifySSLBindPort: 7036
    zimbraPop3BindPort: 7110
    zimbraPop3ProxyBindPort: 110
    zimbraPop3SSLBindPort: 7995
    zimbraPop3SSLProxyBindPort: 995
    zimbraRemoteManagementPort: 22
    zimbraReverseProxyAdminPortAttribute: zimbraAdminPort
    zimbraReverseProxyHttpPortAttribute: zimbraMailPort
    zimbraReverseProxyImapPortAttribute: zimbraImapBindPort
    zimbraReverseProxyImapSSLPortAttribute: zimbraImapSSLBindPort
    zimbraReverseProxyPop3PortAttribute: zimbraPop3BindPort
    zimbraReverseProxyPop3SSLPortAttribute: zimbraPop3SSLBindPort
    zimbraReverseProxyPortQuery: (&(zimbraServiceHostname=${MAILHOST})(objectClass=zimbraServer))
    zimbraSmtpPort: 25

  5. #5
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    you want the output of zmprov gs <servername> | grep -i port

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  6. #6
    motang is offline Active Member
    Join Date
    Mar 2013
    Posts
    28
    Rep Power
    2

    Default

    Quote Originally Posted by quanah View Post
    you want the output of zmprov gs <servername> | grep -i port

    --Quanah
    Quanah, when I type in zmprov gs <servername> | grep -i port this is my output

    Code:
    zimbraAdminImapImportNumThreads: 20
    zimbraAdminPort: 7071
    zimbraBackupReportEmailSubjectPrefix: ZCS Backup Report
    zimbraImapBindPort: 7143
    zimbraImapProxyBindPort: 143
    zimbraImapSSLBindPort: 7993
    zimbraImapSSLProxyBindPort: 993
    zimbraLmtpBindPort: 7025
    zimbraMailPort: 81
    zimbraMailProxyPort: 80
    zimbraMailSSLClientCertPort: 0
    zimbraMailSSLPort: 8443
    zimbraMailSSLProxyClientCertPort: 0
    zimbraMailSSLProxyPort: 443
    zimbraMemcachedBindPort: 11211
    zimbraMilterBindPort: 7026
    zimbraNotifyBindPort: 7035
    zimbraNotifySSLBindPort: 7036
    zimbraPop3BindPort: 7110
    zimbraPop3ProxyBindPort: 110
    zimbraPop3SSLBindPort: 7900
    zimbraPop3SSLProxyBindPort: 900
    zimbraRemoteManagementPort: 22
    zimbraSmtpPort: 25
    Thanks.

  7. #7
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    So it is clearly configured to be connected to via a proxy server. If you don't want this server accessed via proxy, I would suggest you update its port settings.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  8. #8
    motang is offline Active Member
    Join Date
    Mar 2013
    Posts
    28
    Rep Power
    2

    Default

    Quote Originally Posted by quanah View Post
    So it is clearly configured to be connected to via a proxy server. If you don't want this server accessed via proxy, I would suggest you update its port settings.

    --Quanah
    Well that's where I am lost. I inherited this and am in the process of moving over to a new Zimbra server, and while I was trying get imapsync working the only change I made was to enable clear text login. After that this issue happened. So how would I change it?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 502 Bad Gateway - nginx
    By Protack in forum Administrators
    Replies: 30
    Last Post: 06-12-2013, 10:47 AM
  2. bad gateway/internal server error
    By emteeuu in forum Error Reports
    Replies: 1
    Last Post: 09-20-2011, 04:16 AM
  3. Change error page: 502 Bad Gateway
    By cadinor in forum Administrators
    Replies: 0
    Last Post: 11-09-2010, 02:52 AM
  4. One Last Gateway Question
    By hurstel in forum Administrators
    Replies: 0
    Last Post: 01-25-2008, 03:20 PM
  5. SMS Gateway With Zimbra
    By _Fantasy_ in forum Administrators
    Replies: 0
    Last Post: 10-29-2007, 06:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •