Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Admin console "Loading ..."

  1. #1
    Xiaclo is offline Junior Member
    Join Date
    May 2012
    Posts
    8
    Rep Power
    3

    Default Admin console "Loading ..."

    I'm not sure what information to provide, or how to even troubleshoot this issue.

    Whenever I open the admin console https://<domain>:7071/, after login it just says "Loading ..." and never actually loads. I have tried in every browser I have (Firefox, Chrome, Opera and IE9) with the same result. Looking at the page load in firebug, all the resources load fine, but nothing else happens. It seems to launch quite a few POST requests using AJAX though, I'm assuming this is normal. I can log into webmail with my admin user, and trying the admin console from there results in the same issue. IMAP/POP3/SMTP and webmail all work fine.

    I have restarted both Zimbra and the entire VM, there are no errors on startup.

    I am running ZCS 8.0.3 on CentOS 6.4 inside VMWare vSphere 5.1. The VM has 4 GB RAM, and only 1 domain and 2 Zimbra users. There doesn't seem to be anything meaningful in any of the logs, if there is a specific log that would be helpful, let me know.

    As far as network setup, the VM is behind a NAT, port 80 and 443 are passing through a load balancer before Zimbra, but 7071 is passed directly. I have set the external IP on the loopback interface, it seems to resolve strange NAT issues with email delivery.

    I have recently had issues with the server being an open relay, so the mail ports are currently firewalled until I can get into the admin interface. As a side note, why on earth would 0.0.0.0/0 appear in mynetworks in the postfix main.cf by default?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by Xiaclo View Post
    IAs far as network setup, the VM is behind a NAT, port 80 and 443 are passing through a load balancer before Zimbra, but 7071 is passed directly. I have set the external IP on the loopback interface, it seems to resolve strange NAT issues with email delivery.
    The public IP does not, and should not, be on the loopback line in the hosts file, if you need to do that then I'd gusee you have a DNS and/or configuration problem. Have you configured a Split DNS? If you (or even if you haven't) go to the article in the wiki (or read the many posts on this subject) and post the output of all the commands in the 'Verify...' section of that article.

    I'd advise against port 7071 being accessible from the internet, it's asking fro problems - use a VPN to get to it.

    Quote Originally Posted by Xiaclo View Post
    I have recently had issues with the server being an open relay, so the mail ports are currently firewalled until I can get into the admin interface. As a side note, why on earth would 0.0.0.0/0 appear in mynetworks in the postfix main.cf by default?
    That setting isn't normal and I'd guess it's the above mentioned configuration problem.

    Is this a new server or an upgrade?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Xiaclo is offline Junior Member
    Join Date
    May 2012
    Posts
    8
    Rep Power
    3

    Default

    This is a new server.

    You are misunderstand the loopback thing. I did not put the public IP in the hosts file, I added it to the loopback interface in linux like so:

    Code:
    ifconfig lo:0 public_ip/32
    This way, it can use the public DNS, but all traffic doesn't leave the box. I have included ip addr to better explain. My public IP has been replaced with "public_ip" and my domain with "mydomain.local" in the command output.

    Code:
    [root@mail01 ~]# ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
        inet public_ip/0 brd 255.255.255.255 scope global lo:0
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
        link/ether 00:0c:29:XX:XX:XX brd ff:ff:ff:ff:ff:ff
        inet 10.0.0.50/8 brd 10.255.255.255 scope global eth0
        inet6 fe80::20c:/64 scope link
           valid_lft forever preferred_lft forever
    Code:
    [root@mail01 ~]# dig mydomain.local mx
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> mydomain.local mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35715
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;mydomain.local.               IN      MX
    
    ;; ANSWER SECTION:
    mydomain.local.        2860    IN      MX      10 mail01.mydomain.local.
    
    ;; AUTHORITY SECTION:
    mydomain.local.        2856    IN      NS      ns02.mydomain.local.
    mydomain.local.        2856    IN      NS      ns01.mydomain.local.
    
    ;; ADDITIONAL SECTION:
    mail01.mydomain.local. 2860    IN      A       public_ip
    ns02.mydomain.local.   2856    IN      A       public_ip
    ns01.mydomain.local.   2856    IN      A       public_ip
    
    ;; Query time: 1 msec
    ;; SERVER: 10.0.0.16#53(10.0.0.16)
    ;; WHEN: Tue May 14 17:00:48 2013
    ;; MSG SIZE  rcvd: 142
    Code:
    [root@mail01 ~]# dig mydomain.local any
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> mydomain.local any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35923
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;mydomain.local.               IN      ANY
    
    ;; ANSWER SECTION:
    mydomain.local.        14400   IN      SOA     ns.mydomain.local. hostmaster.mydomain.local.mydomain.local. 2013050101 86400 28800 2419200 3600
    mydomain.local.        14400   IN      A       public_ip
    mydomain.local.        2826    IN      NS      ns02.mydomain.local.
    mydomain.local.        2826    IN      NS      ns01.mydomain.local.
    mydomain.local.        2830    IN      MX      10 mail01.mydomain.local.
    
    ;; ADDITIONAL SECTION:
    ns02.mydomain.local.   2826    IN      A       public_ip
    ns01.mydomain.local.   2826    IN      A       public_ip
    mail01.mydomain.local. 2830    IN      A       public_ip
    
    ;; Query time: 263 msec
    ;; SERVER: 10.0.0.16#53(10.0.0.16)
    ;; WHEN: Tue May 14 17:01:19 2013
    ;; MSG SIZE  rcvd: 224
    Code:
    [root@mail01 ~]# host $(hostname)
    mail01.syd.hosts.mydomain.local has address 10.0.0.50
    Code:
    [root@mail01 ~]# cat /etc/hosts
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    
    public_ip  mail01.mydomain.local
    10.0.0.50       mail01.syd.hosts.mydomain.local mail01
    Code:
    [root@mail01 ~]# cat /etc/resolv.conf
    search syd.hosts.mydomain.local syd.hosts.mydomain.local
    nameserver 10.0.0.16
    Last edited by Xiaclo; 05-14-2013 at 01:15 AM.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by Xiaclo View Post
    You are misunderstand the loopback thing. I did not put the public IP in the hosts file, I added it to the loopback interface in linux like so:
    That may be true but you actually do have the Public IP in the hosts file according to the output you posted and therein lies your problem. The public IP should not appear in any of the DNS output nor the relevant files you've listed here - go back to the Split DNS article and read what's necessary for ZCS behind a NAT router.

    BTW, it makes your output more legible if you wrap it in codes tags (teh # sign in the compose window).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Xiaclo is offline Junior Member
    Join Date
    May 2012
    Posts
    8
    Rep Power
    3

    Default

    That public IP was trying to fix another issue. The machine hostname is mail01.syd.hosts.my_domain.local, but the primary mail domain should be my_domain.local. Either way, my public_ip is a local IP as far as zimbra (or anything else on that VM) is concerned.

    Regardless though, I have removed the public IP from loopback, and added the local addresses to my internal DNS and restarted zimbra, still the same issue.

    Code:
    [root@mail01 ~]# dig my_domain.local mx
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> my_domain.local mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 548
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;my_domain.local.               IN      MX
    
    ;; ANSWER SECTION:
    my_domain.local.        14391   IN      MX      10 mail01.my_domain.local.
    
    ;; Query time: 1 msec
    ;; SERVER: 10.0.0.16#53(10.0.0.16)
    ;; WHEN: Tue May 14 18:07:03 2013
    ;; MSG SIZE  rcvd: 56
    Code:
    [root@mail01 ~]# dig mail01.my_domain.local
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> mail01.my_domain.local
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1171
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail01.my_domain.local.                IN      A
    
    ;; ANSWER SECTION:
    mail01.my_domain.local. 3600    IN      A       10.0.0.50
    
    ;; Query time: 2 msec
    ;; SERVER: 10.0.0.16#53(10.0.0.16)
    ;; WHEN: Tue May 14 18:07:34 2013
    ;; MSG SIZE  rcvd: 56
    Code:
    [root@mail01 ~]# dig my_domain.local any
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> my_domain.local any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38591
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;my_domain.local.               IN      ANY
    
    ;; ANSWER SECTION:
    my_domain.local.        14400   IN      SOA     ns.my_domain.local. hostmaster.my_domain.local.my_domain.local. 2013050101 86400 28800 2419200 3600
    my_domain.local.        14400   IN      A       public_ip
    my_domain.local.        14338   IN      NS      ns02.my_domain.local.
    my_domain.local.        14338   IN      NS      ns01.my_domain.local.
    my_domain.local.        14337   IN      MX      10 mail01.my_domain.local.
    
    ;; Query time: 4 msec
    ;; SERVER: 10.0.0.16#53(10.0.0.16)
    ;; WHEN: Tue May 14 18:07:57 2013
    ;; MSG SIZE  rcvd: 224
    Code:
    [root@mail01 ~]# host $(hostname)
    mail01.syd.hosts.my_domain.local has address 10.0.0.50
    Code:
    [root@mail01 ~]# cat /etc/hosts
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    
    10.0.0.50       mail01.my_domain.local
    10.0.0.50       mail01.syd.hosts.my_domain.local mail01
    Code:
    [root@mail01 ~]# cat /etc/resolv.conf
    search syd.hosts.my_domain.local syd.hosts.my_domain.local
    nameserver 10.0.0.16
    Last edited by Xiaclo; 05-14-2013 at 05:43 AM.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    You still don't have correct DNS records, there's no entry for in there an A record pointing to your Zimbra server and your host file has a superfluous line (the first entry for mail01) - it's not needed and you should remove it. I never really understand why people don't create the correct domain name on their Zimbra server that's in use in the real world, it would save a lot of effort and confusion if you had the correct domain name you wish to use - is there some particular reason you've configured it this way?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Xiaclo is offline Junior Member
    Join Date
    May 2012
    Posts
    8
    Rep Power
    3

    Default

    Yes, because that mail server is associated with that subdomain, which specifies a physical location, the mail domain is not bound to a physical location. As far as the "extra" record in the hosts file, it is a CNAME, and the reverse DNS for all those records resolve.

    Code:
    mail01.my_domain.local. 3600    IN      A       10.0.0.50
    Did I miss something? Do you mean that the base domain A record must be the Zimbra server? That seems like a strange and rather insane requirement.

    Removing the extra host entry didn't help. Regardless of how broken you think my DNS setup is, it was working last week like this. Is there any other reason it could not be working, or something I could look for?
    Last edited by Xiaclo; 05-14-2013 at 05:42 AM.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by Xiaclo View Post
    Yes, because that mail server is associated with that subdomain, which specifies a physical location, the mail domain is not bound to a physical location. As far as the "extra" record in the hosts file, it is a CNAME, and the reverse DNS for all those records resolve.
    You should not have that extra record in your host file, it will, and is, causing problems - you should remove it.

    From the output of these commands:

    Code:
    dig my_domain.local any
    dig my_domain.local mx
    From that output there is no A record shown and that's all that matters.

    Quote Originally Posted by Xiaclo View Post
    Do you mean that the base domain A record must be the Zimbra server? That seems like a strange and rather insane requirement.
    No, I don't mean that nor did I say or imply that.


    Quote Originally Posted by Xiaclo View Post
    Removing the extra host entry didn't help. Regardless of how broken you think my DNS setup is, it was working last week like this.
    It doesn't matter whether it was working or not, it will still cause you problems and eventually bite you in the rear. If you think that your settings were correct and worked the way you wanted then I'd suggest you revert to those settings and just ignore my comments.

    Quote Originally Posted by Xiaclo View Post
    Is there any other reason it could not be working, or something I could look for?
    At this stage, not really and I'd always suggest getting the DNS (and the relevant files) corrected before installing Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Xiaclo is offline Junior Member
    Join Date
    May 2012
    Posts
    8
    Rep Power
    3

    Default

    Quote Originally Posted by phoenix View Post
    Code:
    dig my_domain.local any
    dig my_domain.local mx
    From that output there is no A record shown and that's all that matters.

    No, I don't mean that nor did I say or imply that.
    That is exactly what it implies. That dig result only gives back A records for the top-level domain, which means my_domain.local would point to the Zimbra server, not the web server.

    For example, this is the same request done on google.com, notice how only the MX records are listed, not the A records for those servers.

    Code:
    [root@mail01 ~]# dig google.com any
    ;; Truncated, retrying in TCP mode.
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> google.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4938
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 23, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;google.com.                    IN      ANY
    
    ;; ANSWER SECTION:
    google.com.             297     IN      A       74.125.237.105
    google.com.             297     IN      A       74.125.237.97
    google.com.             297     IN      A       74.125.237.110
    google.com.             297     IN      A       74.125.237.103
    google.com.             297     IN      A       74.125.237.100
    google.com.             297     IN      A       74.125.237.96
    google.com.             297     IN      A       74.125.237.104
    google.com.             297     IN      A       74.125.237.98
    google.com.             297     IN      A       74.125.237.99
    google.com.             297     IN      A       74.125.237.101
    google.com.             297     IN      A       74.125.237.102
    google.com.             266     IN      AAAA    2404:6800:4006:803::1003
    google.com.             566     IN      MX      30 alt2.aspmx.l.google.com.
    google.com.             566     IN      MX      10 aspmx.l.google.com.
    google.com.             566     IN      MX      20 alt1.aspmx.l.google.com.
    google.com.             566     IN      MX      50 alt4.aspmx.l.google.com.
    google.com.             566     IN      MX      40 alt3.aspmx.l.google.com.
    google.com.             345566  IN      NS      ns4.google.com.
    google.com.             345566  IN      NS      ns1.google.com.
    google.com.             345566  IN      NS      ns3.google.com.
    google.com.             345566  IN      NS      ns2.google.com.
    google.com.             3566    IN      TXT     "v=spf1 include:_spf.google.com ip4:216.73.93.70/31 ip4:216.73.93.72/31 ~all"
    google.com.             86366   IN      SOA     ns1.google.com. dns-admin.google.com. 2013051000 7200 1800 1209600 300
    
    ;; Query time: 2 msec
    ;; SERVER: 10.0.0.16#53(10.0.0.16)
    ;; WHEN: Wed May 15 07:58:57 2013
    ;; MSG SIZE  rcvd: 546
    It is looking like I have to reinstall anyway to fix this admin issue, so I might as well fix up the DNS to the way Zimbra is expecting it, and change it after the install, it probably would solve some issues. I'm still not understanding how the DNS should be done though without pointing the root domain to the Zimbra server though, can you clarify?

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by Xiaclo View Post
    That is exactly what it implies.
    You're quite right I did and for misunderstanding your original comment about "base domain" I apologise.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "View Mail" from Admin console redirect to custom port
    By darius.ralys@artilux.lt in forum Installation
    Replies: 2
    Last Post: 10-20-2011, 10:15 PM
  2. Replies: 2
    Last Post: 05-31-2011, 06:49 AM
  3. Replies: 6
    Last Post: 03-30-2010, 07:40 AM
  4. Cannot log in to Admin Console "loading"
    By PS-Man in forum Installation
    Replies: 3
    Last Post: 05-19-2009, 09:56 PM
  5. Admin login stuck on "Loading..."
    By danfluidmind in forum Installation
    Replies: 9
    Last Post: 07-12-2007, 09:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •