Results 1 to 4 of 4

Thread: Zimbra 8 Auto Provisioning not work

  1. #1
    breno.sobral is offline New Member
    Join Date
    May 2013
    Posts
    4
    Rep Power
    1

    Default Zimbra 8 Auto Provisioning not work

    Hello,

    I'm trying to setup Eager Mode Auto-Provisioning to AD, but no account has been created. What's wrong in my configuration ?

    --> My AutoProvision settings:

    zimbra@zimbrasrv:~/log$ zmprov gd zimbrateste.com.br |grep AutoProv
    zimbraAutoProvAccountNameMap: samAccountName
    zimbraAutoProvAttrMap: sn=sn
    zimbraAutoProvAttrMap: description=description
    zimbraAutoProvBatchSize: 20
    zimbraAutoProvLastPolledTimestamp: 20130509184543Z
    zimbraAutoProvLdapAdminBindDn: cn=administrator,cn=users,dc=techlead,dc=local
    zimbraAutoProvLdapAdminBindPassword: xxxxxxxx
    zimbraAutoProvLdapBindDn: %u@%d
    zimbraAutoProvLdapSearchBase: cn=users,dc=techlead,dc=local
    zimbraAutoProvLdapSearchFilter: (&(objectClass=user)(mail=*zimbrateste.com.br))
    zimbraAutoProvLdapStartTlsEnabled: FALSE
    zimbraAutoProvLdapURL: ldap://tldsv01.techlead.local:3268
    zimbraAutoProvMode: EAGER
    zimbraAutoProvNotificationBody: Your account has been auto provisioned. Your email address is ${ACCOUNT_ADDRESS}.
    zimbraAutoProvNotificationSubject: New account auto provisioned


    zimbra@zimbrasrv:~/log$ zmprov gs zimbrasrv.zimbrateste.com.br |grep AutoProv
    zimbraAutoProvPollingInterval: 1m
    zimbraAutoProvScheduledDomains: zimbrateste.com.br



    --> I created a new user account "teste.email" in AD:

    zimbra@zimbrasrv:~/log$ ldapsearch -h tldsv01.techlead.local -D "cn=administrator,cn=users,dc=techlead,dc=loca l" -b "cn=users,dc=techlead,dc=local" -W -x "(&(objectClass=user)(mail=*zimbrateste.com.br ))"
    Enter LDAP Password:
    # extended LDIF
    #
    # LDAPv3
    # base <cn=users,dc=techlead,dc=local> with scope subtree
    # filter: (&(objectClass=user)(mail=*zimbrateste.com.br))
    # requesting: ALL
    #


    # Teste U. Email, Users, techlead.local
    dn: CN=Teste U. Email,CN=Users,DC=techlead,DC=local
    objectClass: top
    objectClass: person
    objectClass: organizationalPerson
    objectClass: user
    cn: Teste U. Email
    sn: Email
    description: Usuario teste de email
    givenName: Teste
    initials: U
    distinguishedName: CN=Teste U. Email,CN=Users,DC=techlead,DC=local
    instanceType: 4
    whenCreated: 20130509170225.0Z
    whenChanged: 20130509181404.0Z
    displayName: Teste U. Email
    uSNCreated: 183975
    uSNChanged: 184029
    name: Teste U. Email
    objectGUID:: DO7ED8HQTUWzUEUKCgBy+A==
    userAccountControl: 512
    badPwdCount: 0
    codePage: 0
    countryCode: 0
    badPasswordTime: 0
    lastLogoff: 0
    lastLogon: 0
    pwdLastSet: 0
    primaryGroupID: 513
    objectSid:: AQUAAAAAAAUVAAAADv5JqYJJOLlcQlq3YgQAAA==
    accountExpires: 9223372036854775807
    logonCount: 0
    sAMAccountName: teste.email
    sAMAccountType: 805306368
    userPrincipalName: teste.email@techlead.local
    objectCategory: CN=Person,CN=Schema,CN=Configuration,DC=techlead,D C=local
    dSCorePropagationData: 16010101000000.0Z
    mail: teste@zimbrateste.com.br


    --> Out mailbox.log:
    2013-05-09 15:56:43,123 INFO [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
    2013-05-09 15:56:43,123 INFO [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20130509185643Z
    2013-05-09 15:56:43,127 INFO [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.
    2013-05-09 15:57:43,129 INFO [AutoProvision] [] autoprov - Auto provisioning accounts on domain zimbrateste.com.br
    2013-05-09 15:57:43,132 INFO [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
    2013-05-09 15:57:43,132 INFO [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20130509185743Z
    2013-05-09 15:57:43,136 INFO [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.
    2013-05-09 15:58:43,138 INFO [AutoProvision] [] autoprov - Auto provisioning accounts on domain zimbrateste.com.br
    2013-05-09 15:58:43,141 INFO [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
    2013-05-09 15:58:43,147 INFO [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20130509185843Z
    2013-05-09 15:58:43,151 INFO [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.

  2. #2
    bdial's Avatar
    bdial is offline Moderator
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    10

    Default

    one thing. try changing your search base to CN=Users,DC=techlead,DC=local

    Might not be the issue but I seem to remember encountering a time once where for some reason not using caps for CN, DC caused problems

  3. #3
    breno.sobral is offline New Member
    Join Date
    May 2013
    Posts
    4
    Rep Power
    1

    Default

    bdial,

    I changed, but the problem continues:

    zimbra@zimbrasrv:~/log$ zmprov gd zimbrateste.com.br |grep AutoProv
    zimbraAutoProvAccountNameMap: samAccountName
    zimbraAutoProvAttrMap: sn=sn
    zimbraAutoProvAttrMap: description=description
    zimbraAutoProvBatchSize: 20
    zimbraAutoProvLastPolledTimestamp: 20130510101751Z
    zimbraAutoProvLdapAdminBindDn: cn=administrator,cn=users,dc=techlead,dc=local
    zimbraAutoProvLdapAdminBindPassword: Dqm90vnc
    zimbraAutoProvLdapBindDn: %u@zimbrateste.com.br
    zimbraAutoProvLdapSearchBase: CN=Users,DC=techlead,DC=local
    zimbraAutoProvLdapSearchFilter: (&(objectClass=user)(mail=*zimbrateste.com.br))
    zimbraAutoProvLdapStartTlsEnabled: FALSE
    zimbraAutoProvLdapURL: ldap://tldsv01.techlead.local:3268
    zimbraAutoProvMode: EAGER
    zimbraAutoProvNotificationBody: Your account has been auto provisioned. Your email address is ${ACCOUNT_ADDRESS}.
    zimbraAutoProvNotificationSubject: New account auto provisioned
    zimbra@zimbrasrv:~/log$ tail -f mailbox.log|grep AutoProvision
    2013-05-10 07:17:51,414 INFO [AutoProvision] [] autoprov - Auto provisioning accounts on domain zimbrateste.com.br
    2013-05-10 07:17:51,417 INFO [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
    2013-05-10 07:17:51,417 INFO [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20130510101751Z
    2013-05-10 07:17:51,420 INFO [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.
    2013-05-10 07:18:51,422 INFO [AutoProvision] [] autoprov - Auto provisioning accounts on domain zimbrateste.com.br
    2013-05-10 07:18:51,425 INFO [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
    2013-05-10 07:18:51,425 INFO [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20130510101851Z
    2013-05-10 07:18:51,430 INFO [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.
    2013-05-10 07:19:51,432 INFO [AutoProvision] [] autoprov - Auto provisioning accounts on domain zimbrateste.com.br
    2013-05-10 07:19:51,435 INFO [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
    2013-05-10 07:19:51,435 INFO [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20130510101951Z
    2013-05-10 07:19:51,440 INFO [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.


    Thanks,

    Breno

  4. #4
    bdial's Avatar
    bdial is offline Moderator
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    10

    Default

    have you treid using the standard ldap port instead of the global catalog port?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra 8 Auto Provisioning not work properly
    By gruzin in forum Administrators
    Replies: 25
    Last Post: 06-18-2013, 11:07 PM
  2. Zimbra 8.0 Auto Provisioning help
    By frankchavez in forum Administrators
    Replies: 5
    Last Post: 04-27-2013, 03:02 AM
  3. nedd help with zimbra 8.0 Configure Lazy Mode Auto-Provisioning
    By bahram741413 in forum Administrators
    Replies: 2
    Last Post: 04-01-2013, 01:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •