I've taken over an older zimbra installation for my company that occasionally has mail loops in /var/log/maillog. I've looked everyone on the forums for a possible solution, but most responses have links to search pages that no longer have relevant information.

I've gone through the Split Domain Wiki and numerous forum post fixes with no success. Normal email works perfectly fine, and has so for a few years. However. it seems somehow people send emails without a domain and it throws the loop.

The latest loop doesn't even have a message ID. Here's what I'm seeing in /var/log/maillog:

Code:
May  5 11:40:03 mail postfix/smtpd[18732]: NOQUEUE: reject: RCPT from mail.domain.com[172.24.0.4]: 404 4.5.2 <5558675309>: Recipient address rejected: need fully-qualified address; from=<realuser@domain.com> to=<5558675309> proto=ESMTP helo=<mail.domain.com>
May  5 11:40:03 mail postfix/smtpd[18759]: connect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18732]: disconnect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18759]: NOQUEUE: reject: RCPT from mail.domain.com[172.24.0.4]: 404 4.5.2 <5558675309>: Recipient address rejected: need fully-qualified address; from=<realuser@domain.com> to=<5558675309> proto=ESMTP helo=<mail.domain.com>
May  5 11:40:03 mail postfix/smtpd[18759]: disconnect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18752]: disconnect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18762]: connect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18732]: connect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18752]: connect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18752]: NOQUEUE: reject: RCPT from mail.domain.com[172.24.0.4]: 404 4.5.2 <5558675309>: Recipient address rejected: need fully-qualified address; from=<realuser@domain.com> to=<5558675309> proto=ESMTP helo=<mail.domain.com>
May  5 11:40:03 mail postfix/smtpd[18732]: NOQUEUE: reject: RCPT from mail.domain.com[172.24.0.4]: 404 4.5.2 <5558675309>: Recipient address rejected: need fully-qualified address; from=<realuser@domain.com> to=<5558675309> proto=ESMTP helo=<mail.domain.com>
May  5 11:40:03 mail postfix/smtpd[18732]: disconnect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18752]: disconnect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18732]: connect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18762]: NOQUEUE: reject: RCPT from mail.domain.com[172.24.0.4]: 404 4.5.2 <5558675309>: Recipient address rejected: need fully-qualified address; from=<realuser@domain.com> to=<5558675309> proto=ESMTP helo=<mail.domain.com>
May  5 11:40:03 mail postfix/smtpd[18752]: connect from mail.domain.com[172.24.0.4]
May  5 11:40:03 mail postfix/smtpd[18732]: NOQUEUE: reject: RCPT from mail.domain.com[172.24.0.4]: 404 4.5.2 <5558675309>: Recipient address rejected: need fully-qualified address; from=<realuser@domain.com> to=<5558675309> proto=ESMTP helo=<mail.domain.com>
May  5 11:40:03 mail postfix/smtpd[18762]: disconnect from mail.domain.com[172.24.0.4]
Normally a "postfix stop/start" as zimbra user works and breaks the loop. Other times a full "zmcontrol stop/start" needs to be deployed. This one keeps coming back. And /var/log/maillog gets so massive I have to rotate it or the /var partition wiill get filled. It actually stopped last night around 11:30pm server time, and restarted at about 11:30am server time.

I know I'll need to supply more information for anyone to help troubleshoot this issue, so please ask away for what you need. Any assistance would be greatly appreciated.