Results 1 to 3 of 3

Thread: Problem: Unable to reach the activation server, despite test URL is OK

  1. #1
    michelp's Avatar
    michelp is offline Intermediate Member
    Join Date
    Jan 2010
    Posts
    16
    Rep Power
    5

    Default Problem: Unable to reach the activation server, despite test URL is OK

    Hello,

    I'm trying to test the upgrade of a Zimbra NE :
    - from Zimbra NE 7.2.0 on Ubuntu 8.04 LTS (same as my real production server)
    - to Zimbra NE 8.x on Ubuntu 10.04 LTS
    This upgrade is a simulation on local VM, in order to test it.

    But I'm facing a weird problem :
    "ERROR: Unable to reach the Zimbra License Activation Server."
    with my trial licence on my test VM.

    Overview of the process :
    - Having a runing zimbra 7 / ubuntu 8 : works ok (verified)
    - Upgrading the OS : Ubuntu 8 -> Ubuntu 10.04 LTS
    (stopping zimbra + preventing it form starting at boot time, at first)
    reboot : ubuntu works ok (zimbra shut down)
    - Reinstalling Zimbra (same v7) for Ubuntu 10
    ... this is where all goes wrong

    - Upgrading running Zimbra v7 to last v8
    (not tested)

    What goes wrong on step "Reinstalling Zimbra (same v7) for Ubuntu 10" :

    Doing it as a "disaster recovery" :
    - moving /opt/zimbra/ to /opt/zimbra-original/ to preserve datas
    - doing a first "softwareonly" install
    ... this goes wrong, I stop here <------------

    (- moving new /opt/zimbra/ to /opt/zimbra-bad/)
    (- moving back /opt/zimbra-original/ to /opt/zimbra/ for preserved data)
    (- modifying permissions :
    $ chown -R zimbra:zimbra /opt/zimbra
    $ /opt/zimbra/libexec/zmfixperms --verbose --extended)
    (- doing real upgrade with new install for ubuntu 10 :
    ./install.sh --license /home/michel/ZCSLicense.xml)

    When trying to do a first "softwareonly" install :
    ---------------------
    root@xxxx:/tmp/zcs-NETWORK-7.2.0_GA_2669.UBUNTU10_64.20120410002323# ./install.sh -s --license /home/michel/ZCSLicense.xml

    Operations logged to /tmp/install.log.1208
    Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-7.2.0_GA_2669.UBUNTU8_64
    zimbra-logger...FOUND zimbra-logger-7.2.0_GA_2669.UBUNTU8_64
    zimbra-mta...FOUND zimbra-mta-7.2.0_GA_2669.UBUNTU8_64
    zimbra-snmp...FOUND zimbra-snmp-7.2.0_GA_2669.UBUNTU8_64
    zimbra-store...FOUND zimbra-store-7.2.0_GA_2669.UBUNTU8_64
    zimbra-apache...FOUND zimbra-apache-7.2.0_GA_2669.UBUNTU8_64
    zimbra-spell...FOUND zimbra-spell-7.2.0_GA_2669.UBUNTU8_64
    zimbra-convertd...FOUND zimbra-convertd-7.2.0_GA_2669.UBUNTU8_64
    zimbra-memcached...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-cluster...NOT FOUND
    zimbra-core...FOUND zimbra-core-7.2.0_GA_2669.UBUNTU8_64
    ZCS upgrade from 7.2.0 to 7.2.0 will be performed.
    ERROR: Unable to reach the Zimbra License Activation Server.

    License Activation is required when upgrading to ZCS 7 or later.

    The ZCS Network upgrade will automatically attempt to activate the
    current license as long as the activation server can be contacted.

    You can obtain a manual activation key and re-run the upgrade
    by specifying the -a activation.xml option.

    A manual license activation key can be obtained by either visiting
    the Zimbra support portal or contacting Zimbra support or sales.

    root@xxxx:/tmp/zcs-NETWORK-7.2.0_GA_2669.UBUNTU10_64.20120410002323#
    ---------------------

    ....

    Checking activation server :
    $ wget https://license.zimbra.com/zimbraLic...on?action=test
    it gives me :
    "You've reached Zimbra activation server successfully."
    which seems ok.

    I have requested a new trial licence key, and tried it, but with the same error.

    The weird thing is when I try to do the same softwareonly install on my "source" server (ubuntu 8, VM for tests),
    (simulating a reinstall of the same zimbra), this error does not reach and the process continues OK
    (I stop it before really modifying the system).

    Any idea why this do not work ?

    I have asked, the support but wating for them.

  2. #2
    lytledd is offline Elite Member
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    453
    Rep Power
    5

    Default

    Try install.sh with:

    --skip-activation-check --license yourtemplicensefilename

    Doug
    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

  3. #3
    michelp's Avatar
    michelp is offline Intermediate Member
    Join Date
    Jan 2010
    Posts
    16
    Rep Power
    5

    Default

    Thank you for your answer, but I find an other way to make it work (so I did not try your tip, sorry).

    What I have done :
    (Having a former non running zimbra 7 on an Ubuntu just upgraded from 8 LTS to 10)
    (HAving zimbra stopped + preventing it form starting at boot time, at first)
    - Doing it as a "disaster recovery" <--- this is a wrong idea !
    - moving /opt/zimbra/ to /opt/zimbra-original/ to preserve datas <--- No, leaving /opt/zimbra/ "as is"
    - doing a first "softwareonly" install <--- No, better doing a regular upgrade

    Doing a "regular" upgrade :
    $ tar -zxvf zcs-xxxxxx.tgz
    $ cd zcs-xxxxxx
    $ ./install.sh --license /home/michel/ZCSLicense.xml
    (no -s switch)

    And voila My Zimbra 7.x is back and running, upgraded from Ubuntu 8 to 10 LTS

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BES ZCB Install - Activation Problem
    By cook in forum Zimbra Connector for BlackBerry
    Replies: 1
    Last Post: 01-25-2011, 02:56 PM
  2. [SOLVED] BES Activation problem
    By cubit in forum Zimbra Connector for BlackBerry
    Replies: 20
    Last Post: 01-11-2011, 01:58 PM
  3. Yet another Device Activation Problem
    By mozg31337 in forum Zimbra Connector for BlackBerry
    Replies: 11
    Last Post: 08-05-2009, 05:56 AM
  4. activation problem
    By jproig in forum Zimbra Connector for BlackBerry
    Replies: 7
    Last Post: 03-19-2008, 08:23 AM
  5. Replies: 2
    Last Post: 06-22-2007, 03:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •