Results 1 to 4 of 4

Thread: how to send all incoming mail to zimbra server

  1. #1
    ben1967 is offline Senior Member
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default how to send all incoming mail to zimbra server

    Dear All,

    I have zimbra server running perfectly for quite some time

    i have recently implemented a sendmail server with antispam antivirus software and is working fine

    right now I am sending mail out throgh this sendmail server

    the mx record which was currently for the zimbra server i changed it to the sendmail server

    now the issue i have is the zimbra server cannot receive emails.

    let me explain

    i have gone through the post and related wikis but i could achieve what i want.

    I have tried using the mailer table but it does not help

    also i have tested with the routing rule compiled in sendmail but no avail

    the var/maillog log just say DSN: User unknown

    if I create a user on my sendmail server and in my /etc/aliases file i add

    username: username@mail.int

    the mail is routed to my zimbra server and works perfect

    now I have about 900 users on my zimbra server
    and guess it quite a pain to follow up the above for all the users individually

    what I would like is any mail received for my domain... domain name say test@domain.com
    should be just forwarded or routed by sendmail to my zimbra server

    in this case i do have to create any users on my sendmail server.

    I do hope this is possible or else what would be the best way to achieve this
    any link that would help

    i would really appreciate your kind help and advice


    thanks in advance

    regards

    simon

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Quote Originally Posted by ben1967 View Post
    now the issue i have is the zimbra server cannot receive emails.
    That's hardly surprising as you've removed the DNS MX record for the Zimbra server, it's a requirement that mentioned in the product documentation and many forum threads. Why do you feel the need to run another mail server in front of Zimbra? Did you look at any of the forum threads or wiki article that cover how to run multiple mail server in the same domain (i.e. Split Domain)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    ben1967 is offline Senior Member
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default

    Dear Bill ,

    Thanks for you reply. maybe I was not able to express myself clearly.. anyway I have solved the problem.
    let me explain again

    i had a zimbra server working fine

    now I did setup another server as a antivirus & antispam mail gateway where i want to run mailscanner & mailwatch with sendmail as a MTA I want every mail incoming and outgoing to go through this mail gateway.

    In the zimbra admin panel i changed the external relay as the ip of the mail gateway and and all outgoin mails were passed throgh my mail gateway server which i setup and was working perfect

    now for my incoming mail i did have to change the mx record to my mail gateway server.

    The problem I had as i did mention in my earlier post was that for incoming mails were coming to my mail gateway and were not sent to my zimbra server with a message in the var/maillog log just say DSN: User unknown.

    if i had to build the aliases with the username then it was working just perfect.

    Now as I mentioned earlier have huge no of zimbra users it was very tedious

    now what I did was just got all the usernames of all users using the

    zmaccts | grep "@" | awk '{print $1}' > accounts.txt

    and cut and paste in the alises file and build the db file on my mail gateway machine and everything is working perfect.

    I had used a mailer table to route any mail to my zimbra server but it seems not working

    infact i had seen a post where one guy had a similar issue but cant track that post.

    anyway the issue is solved now and i have everything working fine the way i wanted
    but just wondering how I could route or forward all mail on domain level with sendmail.

    cause now the only hitch is if i add a new user to zimbra than i have to add the same user also on my mail gateway server

    appreciate your advice and once again thanks for the reply


    regards

    simon

  4. #4
    ben1967 is offline Senior Member
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default

    Dear Guys,

    sorry for the late reply i had fixed the issue earlier but got busy with something I actually achieved what I really wanted . as in the above post i had fixed the issue I had by using an aliases file so every time i create a new user in zimbra i also had to update my aliases file

    what I found is i had 2 things that needed to be rectified

    1) in my mailertable i had

    mail.kilaw.edu.kw smtp:[192.168.100.31] i removed the square brackets

    2 I had entry in my localhost file which i removed

    when i did the above 2 things it worked like a charm and I dont need the aliases file


    The above for information hope it can help


    regards

    simon

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 11-20-2012, 05:55 AM
  2. Postfix not sending incoming queue. Unable to send mail.
    By xxthegonzxx in forum Administrators
    Replies: 3
    Last Post: 12-04-2011, 03:07 PM
  3. [SOLVED] Cannot receive incoming mail but can send.
    By windependence in forum Administrators
    Replies: 2
    Last Post: 03-23-2010, 02:43 AM
  4. [SOLVED] Zimbra Primary Server incoming mail issue
    By borngunners in forum Migration
    Replies: 2
    Last Post: 09-25-2009, 11:30 AM
  5. Replies: 4
    Last Post: 04-10-2007, 04:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •