I'm looking to test out a migration of an account from our old email system (mDaemon) into a test Zimbra install and running into Zimbra dropping the connection while migrating. I'm using the following command:


imapsync --noauthmd5 --buffersize 8192000 --host1 MDAEMON --user1 USER1 --password1 PASSWORD --host2 ZIMBRA --user2 USER2 --password2 PASSWORD --authmech2 PLAIN

I receive what looks like a successful login with this banner:

From imap server [192.168.40.8] port [143] user [USER1]
To imap server [192.168.40.210] port [143] user [USER2]
Banner: * OK SERVER1 IMAP4rev1 MDaemon 10.0.2 ready
Host 192.168.40.8 says it has CAPABILITY for AUTHENTICATE LOGIN
Success login on [192.168.40.8] with user [USER1] auth [LOGIN]
Banner: * OK SERVER2 Zimbra IMAP4rev1 server ready
Host 192.168.40.210 says it has CAPABILITY for AUTHENTICATE PLAIN
Success login on [192.168.40.210] with user [USER2] auth [PLAIN]
host1: state Authenticated
host2: state Authenticated

Zimbra goes through my "From server" and lists messages / folder counts as expected. Once it gets to the "To server" I get this:


To Folder [Archive] does not exist yet
To Folder [Catherine] does not exist yet
To Folder [Drafts] Size: 0 Messages: 0
To Folder [INBOX] Size: 0 Messages: 0
To Folder [Info] does not exist yet
To Folder [Info/Accounts] does not exist yet
To Folder [Info/Bills &- Invoices] does not exist yet
To Folder [Info/Contracts &- Official Docs] does not exist yet
To Folder [Info/General] does not exist yet
To Folder [Info/Licensing] does not exist yet
To Folder [Info/Maps] Trying command when NOT connected! at /usr/share/perl5/Mail/IMAPClient.pm line 95
Mail::IMAPClient::LastError('Mail::IMAPClient=HASH (0x1ff5de0)', 'NO not connected') called at /usr/share/perl5/Mail/IMAPClient.pm line 1437
Mail::IMAPClient::_send_line('Mail::IMAPClient=HAS H(0x1ff5de0)', '19 STATUS Info/Maps (MESSAGES)', 0) called at /usr/share/perl5/Mail/IMAPClient.pm line 1298
Mail::IMAPClient::_imap_command_do('Mail::IMAPClie nt=HASH(0x1ff5de0)', 'STATUS Info/Maps (MESSAGES)') called at /usr/share/perl5/Mail/IMAPClient.pm line 1210
Mail::IMAPClient::_imap_command('Mail::IMAPClient= HASH(0x1ff5de0)', 'STATUS Info/Maps (MESSAGES)') called at /usr/share/perl5/Mail/IMAPClient.pm line 2237
Mail::IMAPClient::status('Mail::IMAPClient=HASH(0x 1ff5de0)', 'Info/Maps') called at /usr/share/perl5/Mail/IMAPClient.pm line 1848
Mail::IMAPClient::exists('Mail::IMAPClient=HASH(0x 1ff5de0)', 'Info/Maps') called at /usr/bin/imapsync line 1137
main::foldersizes('To ', 'Mail::IMAPClient=HASH(0x1ff5de0)', 'ARRAY(0x1e88b40)') called at /usr/bin/imapsync line 1190
does not exist yet

At that point it fails to move messages and shoes the NOT connected message for all subfolders. Any ideas on how to resolve this?