Results 1 to 6 of 6

Thread: IMAP: "BAD parse error: illegal character in quoted string"

  1. #1
    MaffooClock's Avatar
    MaffooClock is offline Active Member
    Join Date
    Jan 2009
    Location
    Texas
    Posts
    36
    Rep Power
    6

    Default IMAP: "BAD parse error: illegal character in quoted string"

    Over the weekend, I upgraded my FOSS instance of Zimbra from 8.0.2 to 8.0.3. I've been using Zimbra for years on this one server, and it's worked great (sans a few mysterious issues, like the one I'm about to report).

    Anyway, after the upgrade (which went fine), I noticed that IMAP now has a problem. I'm not sure if it's all users, some users, or just me, but my Apple Mail client suddenly began prompting me for the password over and over and saying it could not connect to the IMAP server. I have enabled logging with zmprov addAccountLogger myuser@mydomain.tld zimbra.imap debug, and began watching the mailbox.log file for ImapServer entries.

    It seems that every time Apple Mail prompts me for my password and I enter it, I see this in the log immediately after:
    Code:
    2013-03-25 10:19:15,648 INFO  [ImapServer-6] [] imap - [172.16.144.13] connected
    2013-03-25 10:19:15,649 WARN  [ImapServer-6] [] imap - BAD parse error: illegal character '' in quoted string
    2013-03-25 10:19:15,650 INFO  [ImapServer-6] [] imap - Handler exiting normally
    2013-03-25 10:39:15,518 INFO  [ImapServer-13] [] imap - [172.16.144.13] connected
    2013-03-25 10:39:15,519 WARN  [ImapServer-13] [] imap - BAD parse error: illegal character '' in quoted string
    2013-03-25 10:39:15,520 INFO  [ImapServer-13] [] imap - Handler exiting normally
    2013-03-25 10:39:15,626 INFO  [ImapServer-13] [] imap - [172.16.144.13] connected
    2013-03-25 10:39:15,628 WARN  [ImapServer-13] [] imap - BAD parse error: illegal character '' in quoted string
    2013-03-25 10:39:15,629 INFO  [ImapServer-13] [] imap - Handler exiting normally
    Note: The illegal character in question varies.

    During my several hours of troubleshooting, I decided to disable the Zimbra proxy and set the IMAP and POP3 services back to their normal ports. This caused the error to go away. Upon re-enabling the proxy, the problem is back. Does Nginx have its panties in a wad?

    I also stumbled upon another thread here where setting zmlocalconfig -e nio_imap_enabled=false seemed to help a particular IMAP client, so I thought I'd try it. It worked, although Apple Mail continues to prompt me for my password at least mail was being read from the server. To verify, I set the property back to true, and the problem returned. So, I set the property back to false, but the problem remains, so apparently NIO doesn't have anything to do with it.

    After two days of troubleshooting, I think I'm officially stumped. Ideas?
    Last edited by MaffooClock; 03-25-2013 at 08:50 AM.

  2. #2
    MaffooClock's Avatar
    MaffooClock is offline Active Member
    Join Date
    Jan 2009
    Location
    Texas
    Posts
    36
    Rep Power
    6

    Default

    Wow, three days go by and this already sunk to page three! Bump.

  3. #3
    MaffooClock's Avatar
    MaffooClock is offline Active Member
    Join Date
    Jan 2009
    Location
    Texas
    Posts
    36
    Rep Power
    6

    Default

    I found this, which likely has nothing to do with my problem at all:
    NGINX Configuration Directive Reference - Zimbra :: Wiki

    It seems the default setting for the Nginx proxy is to use literal strings during authentication instead of quoted string. But why do the log entries claim quoted strings? Is that Nginx complaining or is that the IMAP service itself?

  4. #4
    MaffooClock's Avatar
    MaffooClock is offline Active Member
    Join Date
    Jan 2009
    Location
    Texas
    Posts
    36
    Rep Power
    6

    Default

    I've dead-ended on this. No one has a clue?

    The only workaround I've come up with is to disable the proxy altogether ([SOLVED] How to get rid of zimbra-proxy?).
    Last edited by MaffooClock; 04-06-2013 at 10:33 AM.

  5. #5
    vavai's Avatar
    vavai is offline Special Member
    Join Date
    May 2007
    Location
    Indonesia
    Posts
    149
    Rep Power
    8

    Default

    Hi,

    I've similar problem and temporary fixed by setting different DNS records to by pass proxy for some users. Would better to fill in a bugzilla.
    Best Regards
    ---
    Masim "Vavai" Sugianto
    Zimbra Tutorial
    Personal Blog [ID]

    Release 8.0.6_GA_5922.SLES11_64_20131203103702 SLES11_64 FOSS edition.

  6. #6
    jmorby is offline New Member
    Join Date
    Jun 2008
    Location
    London
    Posts
    3
    Rep Power
    7

    Default

    We had the same problem .. it turned out to be because we had Proxy mode set to Both instead of just IPv4

    There is a bug raised with Zimbra on this one .. hopefully a fix will be forthcoming soon

    Bug 81076 – Nginx is not working correctly with IMAP ID command when zimbraIPMode = both

    In the mean time, if you have proxymode set to both ... change it to ipv4 and the problem should go away (hopefully)

    Jon Morby
    FidoNet - the internet made simple!
    FidoNet | Quality Web Hosting since 1995 - We provide solid web hosting & domain registration services! / FidoNet - Business Broadband, Web Hosting & Domain Names

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 06-06-2012, 12:33 PM
  2. Replies: 1
    Last Post: 02-14-2011, 10:07 PM
  3. Replies: 0
    Last Post: 07-27-2009, 02:01 PM
  4. Error message : "unable to parse the search query"
    By Giulia in forum Error Reports
    Replies: 0
    Last Post: 06-17-2009, 09:38 AM
  5. parse error: illegal character 'ƒ' in quoted string
    By davidfsmith in forum Administrators
    Replies: 2
    Last Post: 01-08-2008, 03:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •