Results 1 to 8 of 8

Thread: postfix error : transport unavailable after upgrade to 7.2.3 on Centos 6.4

  1. #1
    matnor is offline Special Member
    Join Date
    Apr 2007
    Location
    Kajang, Selangor, Malaysia
    Posts
    122
    Rep Power
    8

    Default postfix error : transport unavailable after upgrade to 7.2.3 on Centos 6.4

    Dear All;

    I upgraded my box from Zimbra 7.2.2 on Centos 6.4 to Zimbra 7.2.3 ..but after upgrade emails can't be sent within the local domain or to external domain..it was working fine on 7.2.2..any help is much appreciated...browsed the forum but can't find the right solution..everything is running when I checked the status..

    [zimbra@webmail ~]$ zmcontrol status
    Host webmail.x.z.y
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running
    [zimbra@webmail ~]$

    zimbra log:
    ar 20 17:23:00 webmail postfix/error[1393]: 7CA203941671: to=<name@x.z.y>, relay=none, delay=0.19, delays=0.08/0/0/0.11, dsn=4.3.0, status=deferred (mail transport unavailable)


    I did the same upgrade for the other box and it is running fine...I dont know where to look for anymore..pls help..
    Rgds;
    Matnor

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by matnor View Post
    ...I dont know where to look for anymore..pls help..
    How about a search of the forums? BTW, posting a single out-of-context line from the logs isn't much use and you should post more than that from either side of the error just in case they're relevant.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    matnor is offline Special Member
    Join Date
    Apr 2007
    Location
    Kajang, Selangor, Malaysia
    Posts
    122
    Rep Power
    8

    Default

    I did look at all the similar treads but not working for me.. I re-run the install again but still the same ..all services running but got that error in the zimbra.log
    Rgds;
    Matnor

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by matnor View Post
    I did look at all the similar treads but not working for me..
    You're going to have to give us more information than 'it doesn't work', which of those solutions did you try and what were the results? Did you actually make any modifications to Zimbra before this problem?

    Quote Originally Posted by matnor View Post
    I re-run the install again but still the same ..all services running but got that error in the zimbra.log
    Running the upgrade again is a waste of time, it will not fix pre-existing problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    matnor is offline Special Member
    Join Date
    Apr 2007
    Location
    Kajang, Selangor, Malaysia
    Posts
    122
    Rep Power
    8

    Default

    Summary of steps that I;ve done:

    1. Upgrade the zimbra from 7.2.2 to 7.2.3 after the first box upgrade was successful..
    2. I rebooted the server after I checked status all were running and I could send out to internal and external.
    3. Then I can't send emails ...I found out postfix was not running..looked at few threads in forum..checked my host file , dns etc..no luck..still the same..
    4. The I copy dir posfix from the working server and change the main.cf to reflect the server name..then restart service..postfix/mta is working but server does not send out the emails..postfix/smtp error..transport unavailable..
    5. I re-run the upgrade..still the same..
    6. User can login and compose emails..but the server does not send out the emails..through gui admin..can see "all mails are deferred" reason "mail transport unavailable"
    Last edited by matnor; 03-20-2013 at 06:28 AM. Reason: more info
    Rgds;
    Matnor

  6. #6
    matnor is offline Special Member
    Join Date
    Apr 2007
    Location
    Kajang, Selangor, Malaysia
    Posts
    122
    Rep Power
    8

    Default

    zimbra@mail ~]$ zmcontrol status
    Host mail.x.x.y
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running

    [zimbra@mail ~]$ zmcontrol version
    Release 7.2.3_GA_2872.RHEL6_64_20130304144847 CentOS6_64 FOSS edition.
    /opt/zimbra/bin/zmcontrol [-v -h -H <host>] command [args]

    zimbra.log file :
    Mar 20 21:30:48 mail postfix/qmgr[26017]: 1BC4F39417CD: from=<bounces+arina=x.x.y@skillpages-mailer.com>, size=16638, nrcpt=2 (queue active)
    Mar 20 21:30:48 mail postfix/qmgr[26017]: warning: connect to transport private/smtp-amavis: Connection refused
    ..
    Mar 20 21:30:48 mail postfix/error[30742]: 193A539417DC: to=<matnor@x.x.y>, relay=none, delay=521, delays=521/0.01/0/0.02, dsn=4.3.0, status=deferred (mail transport unavailable)
    Rgds;
    Matnor

  7. #7
    matnor is offline Special Member
    Join Date
    Apr 2007
    Location
    Kajang, Selangor, Malaysia
    Posts
    122
    Rep Power
    8

    Default

    restored back backup and run on old 7.2.2..will do the upgrade later to trace back what really happen..thanks
    Rgds;
    Matnor

  8. #8
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,185
    Rep Power
    9

    Default

    Looks like amavis wasn't running?

    Mar 20 21:30:48 mail postfix/qmgr[26017]: warning: connect to transport private/smtp-amavis: Connection refused
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Deferred, mail transport unavailable
    By St.John in forum Administrators
    Replies: 27
    Last Post: 03-04-2013, 10:47 AM
  2. mail transport unavailable
    By venugopalr in forum Administrators
    Replies: 11
    Last Post: 03-15-2011, 07:25 AM
  3. Strange Mail Transport Unavailable error on reboot
    By zwvpadmin in forum Administrators
    Replies: 9
    Last Post: 02-23-2010, 03:00 PM
  4. mail transport unavailable error
    By newbie79 in forum Administrators
    Replies: 21
    Last Post: 09-11-2009, 01:05 AM
  5. transport unavailable
    By rickvv in forum Administrators
    Replies: 9
    Last Post: 04-17-2008, 12:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •