Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: zimbra/thunderbird with lightning 0.3 problem

  1. #1
    urban@abak is offline Active Member
    Join Date
    Dec 2006
    Posts
    43
    Rep Power
    8

    Default zimbra/thunderbird with lightning 0.3 problem

    hello again...

    we have a certain problem about creating/exporting appointments in zimbra. the thing is that we create the appointment and after the invitation is sent and the invited user (who is using thunderbird + lightning 0.3) the date and time of the appointment is simply not correct. it's always january 1st 1970 1:00:00... if we open the file in notepad it looks sth like this:

    Code:
    BEGIN:VCALENDAR
    PRODID:Zimbra-Calendar-Provider
    VERSION:2.0
    METHOD:REQUEST
    BEGIN:VTIMEZONE
    TZID:(GMT-08.00) Pacific Time (US & Canada) / Tijuana
    BEGIN:STANDARD
    DTSTART:16010101T020000
    TZOFFSETTO:-0800
    TZOFFSETFROM:-0700
    RRULE:FREQ=3DYEARLY;WKST=3DMO;INTERVAL=3D1;BYMONTH=3D10;BYDAY=3D-1SU
    END:STANDARD
    BEGIN:DAYLIGHT
    DTSTART:16010101T020000
    TZOFFSETTO:-0700
    TZOFFSETFROM:-0800
    RRULE:FREQ=3DYEARLY;WKST=3DMO;INTERVAL=3D1;BYMONTH=3D4;BYDAY=3D1SU
    END:DAYLIGHT
    END:VTIMEZONE
    BEGIN:VTIMEZONE
    TZID:(GMT+01.00) Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
    BEGIN:STANDARD
    DTSTART:16010101T030000
    TZOFFSETTO:+0100
    TZOFFSETFROM:+0200
    RRULE:FREQ=3DYEARLY;WKST=3DMO;INTERVAL=3D1;BYMONTH=3D10;BYDAY=3D-1SU
    END:STANDARD
    BEGIN:DAYLIGHT
    DTSTART:16010101T020000
    TZOFFSETTO:+0200
    TZOFFSETFROM:+0100
    RRULE:FREQ=3DYEARLY;WKST=3DMO;INTERVAL=3D1;BYMONTH=3D3;BYDAY=3D-1SU
    END:DAYLIGHT
    END:VTIMEZONE
    BEGIN:VEVENT
    UID:338764a9-8f50-479a-9ef4-4021cf45d222
    ORGANIZER:MAILTO:mail1@domain1.com
    SUMMARY:Testr56
    DTSTART;TZID=3D"(GMT+01.00) Amsterdam / Berlin / Bern / Rome / Stockholm / =
    Vie
     nna":20070117T133000
    DTEND;TZID=3D"(GMT+01.00) Amsterdam / Berlin / Bern / Rome / Stockholm / Vi=
    enn
     a":20070117T143000
    LOCATION:
    STATUS:CONFIRMED
    X-MICROSOFT-CDO-BUSYSTATUS:BUSY
    X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
    TRANSP:OPAQUE
    ATTENDEE;CN=3Atendee;PARTSTAT=3DNEEDS-ACTION;RSVP=3DTRUE;ROLE=3DRE=
    Q-PARTICI
     PANT:MAILTO:mail2@domain2DTSTAMP:20070108T120655Z
    SEQUENCE:0
    DESCRIPTION:Sledi zahteva po novem sre=C4=8Danju:\n\nZadeva: Testr56 \nOrga=
    nizato
     r:: Organizer <mail1@domain1.com> \n\nTermin: Sreda\, 17 januar 2007\,=
     1
     3:30:00 - 14:30:00\n \nPovabljeni: Atendee <mail2@domain2.com=
    >=20
     \n\n*~*~*~*~*~*~*~*~*~*\n\n
    END:VEVENT
    END:VCALENDAR
    i guess the problem is that time is not UTC format or sth. is there a way to solve this at all? also i'm guessing this is a zimbra problem because it works all other ways, for example outlook to zimbra, outlook to thunderbird...

    any help would be kindly appreciated. thanks.
    Last edited by urban@abak; 01-08-2007 at 11:52 PM.

  2. #2
    jhahm is offline Zimbra Employee
    Join Date
    Sep 2005
    Posts
    57
    Rep Power
    9

    Default

    Hi, that .ics file looks just fine. There's an extra VTIMEZONE block for US/Pacific, but that shouldn't be a problem.

    I suspect Lightning has a bug in timezone handling. You mentioned Outlook to Zimbra or Lightning works fine, and that's probably because Outlook is using UTC times and both Zimbra and Lightning handle that case correctly. Zimbra to Outlook should work too because Outlook handles non-UTC timezones. But it sounds like Lightning has some trouble.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    urban@abak is offline Active Member
    Join Date
    Dec 2006
    Posts
    43
    Rep Power
    8

    Default

    yes, your description sounds just right. i also thought first that it is a lightning problem. so i guess, if zimbra could export/send in UTC time format, lightning would work too? is there a way to change that in zimbra?

  4. #4
    jhahm is offline Zimbra Employee
    Join Date
    Sep 2005
    Posts
    57
    Rep Power
    9

    Default

    No. And in general you can't express everything in UTC, for example a recurring appointment in a timezone that uses daylight savings. Let's hope Lightning fixes the bug...
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    pacsteel is offline Active Member
    Join Date
    Oct 2006
    Location
    Montana
    Posts
    38
    Rep Power
    8

    Default

    Quote Originally Posted by urban@abak View Post
    we have a certain problem about creating/exporting appointments in zimbra. the thing is that we create the appointment and after the invitation is sent and the invited user (who is using thunderbird + lightning 0.3) the date and time of the appointment is simply not correct. it's always january 1st 1970 1:00:00...


    urban@abak, If this is a Tbird/Lightning bug (as it appears to be) then try upgrading to a newer version of lightning than 0.3. I'm running Lightning 0.4a1 (build 2006112111) with tbird 1.5.0.9, and I could not reproduce your issue. My appointment's date and time were entered into Lightning correctly.

  6. #6
    urban@abak is offline Active Member
    Join Date
    Dec 2006
    Posts
    43
    Rep Power
    8

    Default

    Quote Originally Posted by pacsteel View Post
    urban@abak, If this is a Tbird/Lightning bug (as it appears to be) then try upgrading to a newer version of lightning than 0.3. I'm running Lightning 0.4a1 (build 2006112111) with tbird 1.5.0.9, and I could not reproduce your issue. My appointment's date and time were entered into Lightning correctly.
    hm... where did you get this?

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Quote Originally Posted by urban@abak View Post
    hm... where did you get this?
    Nightly build on the Lightning site.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    pacsteel is offline Active Member
    Join Date
    Oct 2006
    Location
    Montana
    Posts
    38
    Rep Power
    8

    Default

    Quote Originally Posted by urban@abak View Post
    hm... where did you get this?
    What bill said. I think. It has been long enough that I don't really remember how I got there, but I think it was in ftp.mozilla.org\pub\mozilla.org\calendar\lightning \nightly\latest-trunk\windows-xpi

  9. #9
    urban@abak is offline Active Member
    Join Date
    Dec 2006
    Posts
    43
    Rep Power
    8

    Default

    interesting, i'm getting a non-compatibility error... it says that lightning 0.4a1 only works with thunderbird 3.0a1...

  10. #10
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    You've downloaded the wrong version, you want the version for T'bird 1.5 or 2 a bit further down the page.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra, WM5.0, AS + problem with regional fonts
    By wojo2000 in forum Zimbra Mobile
    Replies: 7
    Last Post: 06-25-2007, 01:04 AM
  2. strange MTA Relay Problem
    By pfuschi in forum Installation
    Replies: 0
    Last Post: 10-31-2006, 11:51 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •