Results 1 to 2 of 2

Thread: Blob Not Found -- Help, Please. Different issue than others.

  1. #1
    AnnieJohnson is offline Starter Member
    Join Date
    Mar 2013
    Posts
    1
    Rep Power
    2

    Default Blob Not Found -- Help, Please. Different issue than others.

    Hi,
    So, I've read through all the other responses to seemingly related problems, but can't find the answer. I believe I may be SOL, but I really hope not. All of the blobs associated with my mail from the past 5 years were deleted. So, I've run zmblobchk, but they are still gone and not stored anywhere else. I can see the headers of my emails which is infuriating, but cannot access any. For whatever reason, it will not let me restore the account, either. I tried imapsync, but since the blobs were missing, it couldn't copy them (figured, but thought I'd try). Any advice or should I get what I can from my headers, mourn the loss, then get on with my life? Thanks so much for any advice.

    ~Annie

  2. #2
    bofh is offline Elite Member
    Join Date
    May 2010
    Posts
    272
    Rep Power
    5

    Default

    its simple
    zimbra stores the header, meta info etc in the database
    the raw data in the storage diretory /opt/zimbra/store

    if those get lost the data isnt there anymore - plain and simple - no way to restore it except restore your storage directory

    another case could be that the reference in the mysql to the corresponding blobfile got lost
    so the data is there but zimbra cant find it - in that case its possible to restore it

    when you run zmblobchk you should also get a bunch of unexpected blobs - if thats the case you may got lucky
    it could mean the blobs are missing are still there but no longere referenced

    you can reinject unexpected blobs easy so they apear as a new mail, but bevore we do that check if unexpected blobs are there


    in case theres no execpected but ONLY missing blobs - its gone - deal with it - my condolences but youre screwed -

    dont you have backups?
    if you have a backup of the hole server restore it on a virtualhost (make a new one or whatever) - get it running locally (as a backup parallel to the production system)
    and extract the mails there

    i DO NOT SUGGEST to recreate the storage dir or mails in it from backups - do it on a restore vhost and export your mails there

    i got recently very deep into that topic for a customer - and believe me nothing is better than a machine you can play on and try to get data back
    you can do pretty bad low level stuff there without risking your production machine

    on production always work on a high level by zimbra tools (like import export, imapsync sand so so) do not manipulate the database or storage on your own on a production machine never ever until you very shure what youre doing and also with a fresh backup

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. blob not found
    By Jan S in forum Administrators
    Replies: 4
    Last Post: 11-21-2012, 07:13 AM
  2. no such blob
    By Sam159 in forum Administrators
    Replies: 3
    Last Post: 08-30-2012, 06:22 AM
  3. Replies: 3
    Last Post: 10-12-2011, 06:12 AM
  4. msg: no such blob
    By eric-telkomsa in forum Administrators
    Replies: 2
    Last Post: 03-22-2010, 09:01 PM
  5. Replies: 2
    Last Post: 06-28-2007, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •