Hello team,

Have you ever encountered this message with nginx?
"worker_connections are not enough while connecting to upstream"

In order to fix this message, we have increased the worker_connections. But still we are seeing this message.

Based on my investigation, nginx will use the max FD from the user's settings.
Which means, if zimbra user's max FD is 524288, each worker processes's max FD is 524288, too.

So, in order to limit the max FD for each worker process, I am planing to use worker_rlimit_nofile.

Does anybody agree with my idea?

Thank you very much
Takashi.