Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: How to set smtpd_reject_unlisted_recipient = yes

  1. #11
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,265
    Rep Power
    10

    Default

    As already noted, this is fixed for ZCS 8.0.4.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  2. #12
    guruhs is offline Member
    Join Date
    Jun 2007
    Posts
    11
    Rep Power
    8

    Default

    Zimbra Version: 8.0.4 Community
    OS: Ubuntu 12.10 Server 64 Bit

    I have newly installed Zimbra 8.0.4 FOSS with mostly default configurations. But i am seeing lot of mails to unlisted id's bouncing instead of rejecting. Please help us to
    resolve this issue.
    Thanks
    Gururaj

  3. #13
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,490
    Rep Power
    56

    Default

    Quote Originally Posted by guruhs View Post
    I have newly installed Zimbra 8.0.4 FOSS with mostly default configurations. But i am seeing lot of mails to unlisted id's bouncing instead of rejecting. Please help us to
    resolve this issue.
    This was fixed in ZCS 8.0.4 as mentioned above, in post #9 there are details of what the setting should be - check your configuration and see what is the current setting.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    mclemen2 is offline Junior Member
    Join Date
    Jan 2012
    Posts
    8
    Rep Power
    3

    Default

    Just did an upgrade from 8.0.4 to 8.0.6. I checked the main.cf and saw smtpd_reject_unlisted_recipient = no. So I ran zmlocalconfig -e smtpd_reject_unlisted_recipient=yes and restarted. Check main.cf again only to see smtpd_reject_unlisted_recipient=no again.

    This is what zmlocalconfig shows:
    zmlocalconfig smtpd_reject_unlisted_recipient
    smtpd_reject_unlisted_recipient = yes

    It would appear that the setting is being ignored.

  5. #15
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,265
    Rep Power
    10

    Default

    I suggest you look at what zmlocalconfig keys are named, and set the right key.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  6. #16
    mclemen2 is offline Junior Member
    Join Date
    Jan 2012
    Posts
    8
    Rep Power
    3

    Default

    Thank you for pointing me in the right direction. I was setting "smtpd_reject_unlisted_recipient" not "postfix_smtpd_reject_unlisted_recipient".

    I have had this thread bookmarked for some time and others on the same topic. While it was mentioned elsewhere that the default value for this was changed in 8.0.2, it does not get updated on an upgrade. So in my documentation on upgrading Zimbra I have a line in there to remind me to check this setting after every upgrade. Which is why I even noticed this anyway. Now I can remove this item from my checklist.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 06-06-2012, 02:17 PM
  2. simple how-to question (smtpd_reject_unlisted_recipient)
    By That Guy from that Place in forum Administrators
    Replies: 2
    Last Post: 10-30-2009, 01:58 PM
  3. [SOLVED] smtpd_reject_unlisted_recipient ignored
    By stl in forum Administrators
    Replies: 14
    Last Post: 09-28-2009, 07:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •