Results 1 to 8 of 8

Thread: Not Receing Mail

  1. #1
    Join Date
    Oct 2008
    Posts
    51
    Rep Power
    6

    Default Not Receing Mail

    Thanks for reading.

    I am unable to receive mail on a new setup.

    Either externally or internally. Though I actually think the source is two seperate issues.

    I have all of the local ips for this server in the trusted MTA section.

    I have now disabled 'Enable DNS lookup' and set my zimbra server to relay mail for this server. I would like a fix that does not use a relay server though.

    Here is a tail from /var/log/zimbra.log, that I think will help with the local issue
    Code:
    Feb  3 19:52:22 lks postfix/qmgr[573]: 5B4675CC9E0: from=<sentto-14370071-1726-1359938623-username=domain.com@returns.groups.yahoo.com>, size=22702, nrcpt=1 (queu
    e active)
    Feb  3 19:52:23 lks postfix/qmgr[573]: 0F8A95CB578: from=<Edward.Aho@ympesdujan.com>, size=11557, nrcpt=1 (queue active)
    Feb  3 19:52:23 lks postfix/qmgr[573]: 0D06E5CB572: from=<diara@pasaf.co.uk>, size=11307, nrcpt=1 (queue active)
    Feb  3 19:52:27 lks postfix/smtpd[28223]: connect from unknown[24.68.176.10]
    Feb  3 19:52:28 lks postfix/smtpd[28223]: disconnect from unknown[24.68.176.10]
    Feb  3 19:52:48 lks postfix/lmtp[28238]: connect to server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out
    Feb  3 19:52:48 lks postfix/lmtp[28238]: 580695CCB1A: to=<username@domain.com>, relay=none, delay=64, delays=0.58/0/63/0, dsn=4.4.1, status=deferred (connect to
     server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out)
    Feb  3 19:53:19 lks zmmailboxdmgr[13929]: status requested
    Feb  3 19:53:19 lks zmmailboxdmgr[13929]: status OK
    Feb  3 19:53:19 lks zmmailboxdmgr[13945]: status requested
    Feb  3 19:53:19 lks zmmailboxdmgr[13945]: status OK
    Feb  3 19:53:26 lks postfix/lmtp[9167]: connect to server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out
    Feb  3 19:53:26 lks postfix/lmtp[9168]: connect to server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out
    Feb  3 19:53:26 lks postfix/lmtp[9151]: connect to server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out
    Feb  3 19:53:26 lks postfix/lmtp[9168]: 0D06E5CB572: to=<username@domain.com>, relay=none, delay=9013, delays=8950/0.22/63/0, dsn=4.4.1, status=deferred (connect
    to server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out)
    Feb  3 19:53:26 lks postfix/lmtp[9167]: 0F8A95CB578: to=<username@domain.com>, relay=none, delay=9006, delays=8943/0.21/63/0, dsn=4.4.1, status=deferred (connect
    to server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out)
    Feb  3 19:53:26 lks postfix/lmtp[9151]: 5B4675CC9E0: to=<username@domain.com>, relay=none, delay=586, delays=523/0.25/63/0, dsn=4.4.1, status=deferred (connect to
     server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out)
    Here is a log tail that I think shows to external issue
    Code:
    terrismith@domain.com
    Here is an example of my /var/log/zimbra.log:
    Feb 3 21:57:12 lks postfix/qmgr[28626]: 847005C1262: from=<davidedwardgill33@gmail.com>, size=2657, nrcpt=1 (queue active)
    Feb 3 21:57:12 lks amavis[28267]: (28267-02) FWD via SMTP: <davidedwardgill33@gmail.com> -> <user@domain.com>,BODY=7BIT 250 2.0.0 from MTA([127.0.
    0.1]:10025): 250 2.0.0 Ok: queued as 847005C1262
    Feb 3 21:57:12 lks amavis[28267]: (28267-02) Passed CLEAN, [209.85.212.46] [209.85.212.46] <davidedwardgill33@gmail.com> -> <user@domain.com>, Mes
    sage-ID: <CAFKTQZzOr5ri-8n_ZGkobCKX5YgrfLoMXinX0ytCNdazF8AycA@mail.gmail.com>, mail_id: O3NySVu+lOaY, Hits: 0.111, size: 1754, queued_as: 847005C1262, dkim_i
    d=@gmail.com, 9452 ms
    Feb 3 21:57:12 lks postfix/smtp[8090]: F1E0D5C0FBC: to=<user@domain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=9.6, delays=0.16/0.01/0/9.5, dsn
    =2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 847005C1262)
    Feb 3 21:57:12 lks postfix/qmgr[28626]: F1E0D5C0FBC: removed
    Both of the folloring host commands were run from an separate server
    # host -t a server.domain.com
    server.domain.com has address external.ipaddress.goes.here

    # host -t mx domain.com
    domain.com mail is handled by 1 server.domain.com.

    /etc/hosts
    127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
    192.168.4.33 mail.domain.com mail
    192.168.4.33 www.domain.com www
    192.168.4.33 server.domain.com lks
    192.168.4.33 webmail.domain.com webmail

    /etc/resolv.conf
    nameserver 192.168.4.33

    Telnets:
    # telnet server.domain.com 7025
    Trying external.ipaddress.goes.here...
    Connected to server.domain.com.
    Escape character is '^]'.
    220 server.domain.com Zimbra LMTP server ready

    [root@pcks ~]# telnet server.domain.com 25
    Trying external.ipaddress.goes.here...
    Connected to server.domain.com (external.ipaddress.goes.here).
    Escape character is '^]'.
    220 lks.lkelectric.com ESMTP Postfix

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    Your hosts file is incorrect, you have too many lines in there with the ZCS server IP. You're obviously behind a NAT router yet you haven't mentioned a Split DNS (you need one), follow that article and install the DNS and fix the hosts file. You should also take a look at some of the many forum threads on this topic.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2008
    Posts
    51
    Rep Power
    6

    Default

    Thanks for the response.

    The host file is actually pulled from the backup of this same server, which was previously running Zimbra without issue. Also, I've already had the host file only have the main server name and received the same results. I will however change it back now.

    I have not had to use a split DNS in the past. I will go through the steps listed in the documentation, and see if that helps at all.

    Infact my server is behind a NAT and I am not infact running split DNS. Perhaps because I am not running network-manager though.

    Thank you for the advice, I will give it a try and reply with the results.

  4. #4
    Join Date
    Oct 2008
    Posts
    51
    Rep Power
    6

    Default

    I've attempted a split DNS Setup. I get to dnsmasq is failing to start, and I'm failing to find a log file for it. Does anyone happen to know where that is? I've already attempted to manually set a log file to no avail.

    Also doesn't dnsmaq use port 53? As I understand it only listens on 127.0.0.1, and I've got bind listening on my local IP. I just want to make certain I am understanding that correctly.

    Also in many other threads people are disabling DNS lookup to resolve their receiving issues. I have done that, but it of course forces me to use a relay server. How is it that not one other post mentions them needing to use a relay.

    Mostly though, I've setup and have running multiple Zimbra servers not a single one using split DNS. I've got notes that I fallow for the setup. I haven't diverted from those notes a single line... I am simply hating this setup. I am not understanding how I am literally spending 8 hours on a setup that normally takes me 10 minutes.

    Why don't I ask it this way, why is split DNS required?
    MTA - Zimbra :: Wiki
    is the only explanation I could find. It is awsomely vage.

    In short, why is it sending ALL my main to my external IP when my server should look in /etc/hosts first before turning to bind?

    Even without split DNS shouldn't I be able to receive external mail? I am not receiving external or internal when DNS lookup is enabled.

    Again I am asking these questions because there is odviously an easier way then using split DNS. I've got other server running without it!

  5. #5
    Join Date
    Oct 2008
    Posts
    51
    Rep Power
    6

    Default

    I appear to have resolved this issue by fallowing the steps in:
    Incoming Mail Problems - Zimbra :: Wiki

    running:
    #zmlocalconfig -e postfix_lmtp_host_lookup=native

    This is not in my notes. Also my other servers do not appear to have this setting @ native.

    Even with this working. I wouldn't mind going back and forth a little more to understand MTA a little better.

  6. #6
    Join Date
    Oct 2008
    Posts
    51
    Rep Power
    6

    Default

    I wanted to note that now it is routing all lmtp traffic to the local IP.

    So this line:
    Feb 3 19:53:26 lks postfix/lmtp[9151]: 5B4675CC9E0: to=<username@domain.com>, relay=none, delay=586, delays=523/0.25/63/0, dsn=4.4.1, status=deferred (connect to
    server.domain.com[external.ipaddress.goes.here]:7025: Connection timed out)

    would now show the local ip, rather than the external IP. It also shows status=delivered. Then of course it is actually in the inbox.

    I don't fully understand MTA, but why would it send via DNS by default? Why wouldn't it look directly to the hosts file? Honestly who wants the chance of all their local mail being routed through their modem to their ISP then back again...

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    Quote Originally Posted by dave.gill@yourpcknights.c View Post
    I don't fully understand MTA, but why would it send via DNS by default?
    Mail delivery by postfix is always done via a DNS lookup to the MX record.

    [QUOTE=dave.gill@yourpcknights.c;258927Honestly who wants the chance of all their local mail being routed through their modem to their ISP then back again...[/QUOTE]That isn't what happens with a correctly configured local DNS server, it doesn't do that for me nor anyone else that uses that configuration - all local mail goes from one local mailbox to another local mailbox and it doesn't leave my network.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Oct 2008
    Posts
    51
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Mail delivery by postfix is always done via a DNS lookup to the MX record.

    That isn't what happens with a correctly configured local DNS server, it doesn't do that for me nor anyone else that uses that configuration - all local mail goes from one local mailbox to another local mailbox and it doesn't leave my network.
    Is that due to dns masq? I ask because bind is working, and tests good on my system. I'd also love to find a better reference for the dnsmasq daemon config. Due to following the steps listed: Split DNS - Zimbra :: Wiki, didn't work out for me. More then anything I spent about 1/2 hour looking for a log file and couldn't find it.

    Is lmtp now using my local hosts file for look up rather then DNS? Am I misunderstanding the use of changing the postfix_lmtp_host_lookup config? I understand that it is going to DNS for the sake of getting a host name, what I mean is it just resolving the hostname to IP locally. Also, is there an issue with configuring the server this way.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 02-22-2012, 11:37 AM
  2. Replies: 2
    Last Post: 02-22-2012, 05:33 AM
  3. Replies: 6
    Last Post: 07-15-2011, 11:07 PM
  4. Replies: 2
    Last Post: 06-05-2011, 11:56 PM
  5. Replies: 4
    Last Post: 01-03-2008, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •