Results 1 to 9 of 9

Thread: Cant send emails

  1. #1
    Corne is offline Junior Member
    Join Date
    Jan 2013
    Posts
    7
    Rep Power
    2

    Default Cant send emails

    Hi there.

    I'm also a newbie here and totally new in Zimbra Administration. We've been using ZCS for almost 2 years now with no issues at all. A few days ago we started experiencing issues with sending emails. We get the following error.

    "An unknown error (mail.TRY_AGAIN) has occurred."

    After a couple of attempts, the error goes away but then returns again when trying to send a new mail.

    Please help.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by Corne View Post
    I'm also a newbie here and totally new in Zimbra Administration. We've been using ZCS for almost 2 years now with no issues at all. A few days ago we started experiencing issues with sending emails. We get the following error.

    "An unknown error (mail.TRY_AGAIN) has occurred."

    After a couple of attempts, the error goes away but then returns again when trying to send a new mail.
    You need to look in the log files to see what errors you're getting and also which version of ZCS is in use by running the following command:

    Code:
    zmcontrol -v
    Quote Originally Posted by Corne View Post
    Please help.
    Not without more information and you probably can find an answer if you search the forums, I'll also move this to the correct forum as it's not a question about Zimbra Desktop (which is where you posted).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Corne is offline Junior Member
    Join Date
    Jan 2013
    Posts
    7
    Rep Power
    2

    Default

    No Problem thanks. Will use the correct forum.

    Much appreciated.

  4. #4
    Corne is offline Junior Member
    Join Date
    Jan 2013
    Posts
    7
    Rep Power
    2

    Default

    We are running ZCS 6.0.13. I've looked in the log files and cannot see anything weird. I still have no idea why it's happening as there were no changes made. I'm not sure where else to look and what to look for.

  5. #5
    epahestus is offline Junior Member
    Join Date
    Jan 2013
    Location
    Italy
    Posts
    5
    Rep Power
    2

    Default

    I cannot send email but withou any error

  6. #6
    Corne is offline Junior Member
    Join Date
    Jan 2013
    Posts
    7
    Rep Power
    2

    Default

    Quote Originally Posted by Corne View Post
    We are running ZCS 6.0.13. I've looked in the log files and cannot see anything weird. I still have no idea why it's happening as there were
    no changes made. I'm not sure where else to look and what to look for.
    Anyone with a solution? The following message is still popping up.

    "An unknown error (mail.TRY_AGAIN) has occurred".

  7. #7
    Corne is offline Junior Member
    Join Date
    Jan 2013
    Posts
    7
    Rep Power
    2

    Default

    Quote Originally Posted by vavai View Post
    Try to look at your logs file as suggested by Phoenix, something like :

    Code:
    tail -f /opt/zimbra/log/mailbox.log
    and then try to send email and paste the relevant error message here. Without any error message, it's difficult to resolve the problem.
    Hi Vavai.

    This is what I get :
    Code:mail.TRY_AGAIN
    at com.zimbra.cs.mailbox.MailServiceException.TRY_AGA IN(MailServiceException.java:471)
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:138)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:420)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:274)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:158)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:725)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:181)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:814)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:511)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1166)
    at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(Set HeaderFilter.java:79)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:388)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:218)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:182)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:422)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.DebugHandler.handle(Debu gHandler.java:77)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:326)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:543)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:946)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:756)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:212)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:405)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:410)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)

    Caused by: com.zimbra.cs.mailbox.MailSender$SafeMessagingExce ption: Could not connect to SMTP host: mail.example.co.za, port: xx; chained exception is:
    java.net.SocketTimeoutException: connect timed out
    at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTra nsport.java:1545)
    at com.sun.mail.smtp.SMTPTransport.protocolConnect(SM TPTransport.java:453)
    at javax.mail.Service.connect(Service.java:291)
    at javax.mail.Service.connect(Service.java:172)
    at javax.mail.Service.connect(Service.java:121)
    at com.zimbra.cs.mailbox.MailSender.sendMessageToHost (MailSender.java:843)
    at com.zimbra.cs.mailbox.MailSender.sendMessage(MailS ender.java:764)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:474)
    Last edited by Corne; 01-19-2013 at 01:10 AM.

  8. #8
    Corne is offline Junior Member
    Join Date
    Jan 2013
    Posts
    7
    Rep Power
    2

    Default

    Quote Originally Posted by vavai View Post
    Hi Corne,

    The problem came from this portion of error message :


    Within your Zimbra mailbox server (assume that you have multi server scenario according to your logs) try :

    Code:
    nslookup mail.example.co.za
    telnet mail.example.co.za xx
    Where xx is your MTA server port. Paste here the command and it's response to see whether your MTA up and running or not. It seems that your mailbox server could not access to your MTA server for whatever reason.
    Hi Vavai,

    Hmmm.... for some weird reason, mails are going out fine now without any errors. Very strange indeed because nothing was changed.

  9. #9
    Corne is offline Junior Member
    Join Date
    Jan 2013
    Posts
    7
    Rep Power
    2

    Default

    Quote Originally Posted by vavai View Post
    It;s Okay, but for whatever reason , would you like to paste the above command?

    Code:
    nslookup mail.example.co.za
    telnet mail.example.co.za xx
    Did you manage multi server scenario? It seems that the problem came from the error connection between mailbox server and mta server, and it solved by
    accident due to restored connection between mailbox and mta server.
    Hi Vavai,

    All still good on my side.

    As per your request, please see the follwing:
    root@mail:~# nslookup mail.example.co.za
    Server: 192.168.0.1
    Address: 192.168.0.1#53

    Non-authoritative answer:
    Name: mail.example.co.za
    Address: xxx.xxx.xxx.xxx
    .................................................. ..............
    root@mail:~# telnet mail.example.co.za 53
    Trying xxx.xxx.xxx.xxx
    Connected to mail.example.co.za
    Escape character is '^]'.
    Connection closed by foreign host.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't send system emails
    By surrealist in forum Installation
    Replies: 0
    Last Post: 09-28-2010, 07:01 AM
  2. Can't send any emails at all
    By ghstridr in forum Administrators
    Replies: 3
    Last Post: 05-18-2009, 01:56 AM
  3. cant send emails/ims
    By christy123 in forum Administrators
    Replies: 2
    Last Post: 09-19-2008, 07:51 PM
  4. cant send emails
    By derr1ck in forum Administrators
    Replies: 0
    Last Post: 06-25-2007, 09:55 AM
  5. Can't send emails out
    By jack-Z in forum Installation
    Replies: 8
    Last Post: 02-18-2006, 08:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •