Results 1 to 7 of 7

Thread: Upgrade Paths

  1. #1
    pbrunnen's Avatar
    pbrunnen is offline Loyal Member
    Join Date
    Mar 2007
    Location
    Rochester, NY
    Posts
    89
    Rep Power
    8

    Question Upgrade Paths

    Hello all,

    Does anyone know where I can find a maintained listing of upgrade paths for the Network edition versions?

    I got caught with my pants down last night trying to do an upgrade... I made the assumption that any v6.x release could be upgraded to any v7.x release. This is not the case and got me stuck. I had assumed you could go from 6.0.16 to 7.1.4, but this is a no-go...

    Thanks! -Cheers, Peter.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,468
    Rep Power
    56

    Default

    Upgrade paths are always in the relevant Release Notes for each version of ZCS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    pbrunnen's Avatar
    pbrunnen is offline Loyal Member
    Join Date
    Mar 2007
    Location
    Rochester, NY
    Posts
    89
    Rep Power
    8

    Default

    Hi Bill,

    Where prey tell in the release notes?

    The only section that seems to references it is "Upgrade Process" and all it says is "To upgrade from 5.0.x or 6.0.x to 7.1.x, download the latest ZCS 7.1.x and run the upgrade."

    So in my case, nowhere did I find that 6.0.16 could not upgrade to 7.1.4.
    I was using "http://files2.zimbra.com/website/docs/7.0/Zimbra%20NE%20Release%20Notes%207.1.4-2.pdf" linked as the release notes from the downloads page.

    Thanks!
    - Cheers, Peter.

  4. #4
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    Peter,

    It says it right there, and you quoted it: "To upgrade from 5.0.x or 6.0.x to 7.1.x, download the latest ZCS 7.1.x and run
    the upgrade."

    If you are at 6.0.x, you just download the 7.1.x release you want to update to and run the upgrade.

    You say you are at 6.0.14 == 6.0.x
    You want to upgrade to 7.1.4 == 7.1.x

    Where is the confusion?
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

  5. #5
    Brad_C is offline Loyal Member
    Join Date
    Apr 2012
    Posts
    90
    Rep Power
    3

    Default

    Quote Originally Posted by pbrunnen View Post
    I made the assumption that any v6.x release could be upgraded to any v7.x release. This is not the case and got me stuck. I had assumed you could go from 6.0.16 to 7.1.4, but this is a no-go...
    Your initial assumption is correct, and you *should* be able to upgrade any zimbra release to any later zimbra release. There is a comprehensive procedure as part of the upgrade system that progressively rolls all the required version forward until you get to where you want to go, so if it did not work for you then you need to provide some more information for us to go on. Error messages, logs, whatever else you have to hand.

    It *should* work. Having said that sometimes stuff happens. I initially installed 7.0.1 and the upgrade to 7.1 refused to work. I had to manually edit a text file in /opt/zimbra to get it to proceed.

    Probably does not help you, but I replicate my zimbra VM (and associated data files) and attempt to perform the upgrade on the backup. If it succeeds (which it usually does) then I make the upgraded VM the prime and discard the old one.
    Once bitten ...

  6. #6
    pbrunnen's Avatar
    pbrunnen is offline Loyal Member
    Join Date
    Mar 2007
    Location
    Rochester, NY
    Posts
    89
    Rep Power
    8

    Default

    Quote Originally Posted by Brad_C View Post
    Probably does not help you, but I replicate my zimbra VM (and associated data files) and attempt to perform the upgrade on the backup. If it succeeds (which it usually does) then I make the upgraded VM the prime and discard the old one.
    Once bitten ...
    Actually Brad, that is a good idea. I make snapshots of the OS currently but my big hang-up is that all the raw data is raw device mapped onto our san. I should look at our san's snapshot capabilities... maybe I can duplicate a snapshot off to a test system. At least test the upgrade on the duplicated dataset first and I will know what should happen in production.

    Thanks! -Cheers, Peter.

  7. #7
    pbrunnen's Avatar
    pbrunnen is offline Loyal Member
    Join Date
    Mar 2007
    Location
    Rochester, NY
    Posts
    89
    Rep Power
    8

    Default

    Quote Originally Posted by Krishopper View Post
    Peter,

    It says it right there, and you quoted it: "To upgrade from 5.0.x or 6.0.x to 7.1.x, download the latest ZCS 7.1.x and run
    the upgrade."

    If you are at 6.0.x, you just download the 7.1.x release you want to update to and run the upgrade.

    You say you are at 6.0.14 == 6.0.x
    You want to upgrade to 7.1.4 == 7.1.x

    Where is the confusion?
    Yea... you are right. So why did the software not allow me to upgrade??

    Furthermore, I looked at v7.0.0 as I considered that seeing as maybe 6.0.x to 7.1.x was too big of a jump. Zimbra support said that you can't upgrade 6.0.16 to 7.0.0 because 6.0.16 was released after 7.0.0 was... Yet the 7.0.0 release notes say "To upgrade from 5.0.x or 6.0.x to 7.0.x, download the latest ZCS 7.0.x and run the upgrade." which is by Zimbra support team's own words - wrong.

    It should read something like "To upgrade from 5.0.x or <=6.0.8 to 7.0.x, download the latest ZCS 7.0.x and run the upgrade." (or whatever is the current version of the 6.0 train that was released at the time of the 7.0.x release). This is clear and would not have lead me down the wrong path.

    The thing though that has me all fired up is that the installer should check and error that this is not a possible upgrade *Before* removing the old packages and installing the new ones. The installer replaces all the packages and then connects to the database and says the equivalent of 'oops' and ends. Nevermind that my datastores were not actually upgraded. If I had not had snapshots of my VM, I would have been SOL because the install script balked immediately at attempting to install 6.0.16 again saying it can't downgrade 7.1.4 to 6.0.16... and I certainly didn't want to delete the programs manually and cause the script to handle it like a new install... that would have meant even more work.

    Sorry... It was been a very testing few days.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. using internal ip and resoving briecase paths..
    By timothyalangorman in forum Administrators
    Replies: 0
    Last Post: 11-10-2011, 07:41 AM
  2. Zimbra-Upgrade and Server-Move inkl. Ubuntu-Dist-Upgrade
    By karl.kowald in forum Administrators
    Replies: 5
    Last Post: 10-25-2011, 10:24 AM
  3. IM Paths.
    By simonb256 in forum Developers
    Replies: 0
    Last Post: 06-16-2008, 07:19 AM
  4. 5.0.4 upgrade backup procedure; prevent new mail during upgrade?
    By adam.vollrath in forum Administrators
    Replies: 6
    Last Post: 04-11-2008, 07:51 AM
  5. Replies: 1
    Last Post: 01-03-2008, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •