Results 1 to 9 of 9

Thread: cannot disable X-Originating-IP in 8.0.2

  1. #1
    Labsy is offline Elite Member
    Join Date
    Nov 2009
    Location
    Ljubljana, Slovenia
    Posts
    268
    Rep Power
    5

    Exclamation cannot disable X-Originating-IP in 8.0.2

    Hi,

    a small problem evolved and because of simple setting of MTA on server "Add X-Originating-IP" my mail server with hundreds of domains is half dead now.

    Reading the posts, with 8.0.2 ZCS introduced some new functionality, which checks X-Originating-IP (that is client public IP address) against spamhouse.org and other blacklists, and prevents him/her to send mail out. Trying to remove X-Originating-IP from server fails:

    Method 1:
    Disable via Admin GUI...
    Save
    restart zimbra services "zmcontrol restart"
    Nothing! X-Originating-IP option is still checked in Admin GUI

    Method 2:
    Via command line as Zimbra user:
    HTML Code:
    zimbra@zimbra:/home/zimbra$ zmprov gacf | grep zimbraSmtpSendAddOriginatingIP
    zimbraSmtpSendAddOriginatingIP: TRUE
    zimbra@zimbra:/home/zimbra$ zmprov gacf zimbraSmtpSendAddOriginatingIP FALSE
    zimbraSmtpSendAddOriginatingIP: TRUE
    zimbra@zimbra:/home/zimbra$ zmprov gacf | grep zimbraSmtpSendAddOriginatingIP
    zimbraSmtpSendAddOriginatingIP: TRUE
    ???

    Any idea how to disable X-originating-IP?

    *** EDIT ***
    Actually, cannot edit ANY setting in Admin GUI under Server "Global Settings".
    Permission issue?
    Bug?
    Last edited by Labsy; 01-04-2013 at 03:38 AM.
    Zimbra on SGH dedicated hosting farm, Slovenia.
    In 2013 we announce new program of low cost SSL server certificates.

  2. #2
    Labsy is offline Elite Member
    Join Date
    Nov 2009
    Location
    Ljubljana, Slovenia
    Posts
    268
    Rep Power
    5

    Default

    Hmmm...
    Switching from Chrome to FireFox and at the same time using gear-icon on top right --> choosing SAVE...well, this procedure saved settings

    But still removing option "Add X-Originating-IP to messages" does not remove X-Originating-IP from mail, which uses SMTP, but rather only from mail, sent via Web Client. So I had to remove "zen.spamhaus.org" from RBL to pass mail thru.
    Zimbra on SGH dedicated hosting farm, Slovenia.
    In 2013 we announce new program of low cost SSL server certificates.

  3. #3
    magneticinduction is offline Active Member
    Join Date
    Apr 2009
    Posts
    27
    Rep Power
    6

    Default

    Quote Originally Posted by Labsy View Post
    So I had to remove "zen.spamhaus.org" from RBL to pass mail thru.
    That is how I am getting around the bug over here. I hope it gets fixed soon.

  4. #4
    quanah is online now Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,195
    Rep Power
    9

    Default

    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #5
    AlchemyCS is offline New Member
    Join Date
    Jan 2013
    Posts
    3
    Rep Power
    2

    Default

    I am evaluating Zimbra (I am quite familiar with its underlying technologies however) and I too have this problem of the X-Originating-IP not being able to be un-set.
    However, not running my inbound emails through the zen RBL is not enough--the X-Originating-IP is still scanned at some remote sites and is causing emails to get bounced--because I can't set this in Zimbra itself, if I force this change in Postfix, how much trouble will that cause later on? Or will that even work (eg, does Zimbra actively overwrite Postfix's config files?)

  6. #6
    Alex_Filatau is offline New Member
    Join Date
    Dec 2010
    Posts
    3
    Rep Power
    4

    Default

    I've retested this on a single node installation and looks to be working fine to me. Changes (Admin Console / Configure / Global Settings / MTA /Add X-Originating-IP to messages ) are accepted right away. Messages from web client, via port 25 and 587 are being sent without X-Originating-IP if I set this setting to false.
    Use "zmprov gcf zimbraSmtpSendAddOriginatingIP" to get current setting and "zmprov mcf zimbraSmtpSendAddOriginatingIP FALSE" to disable it.
    Do you try it on single node deployment?

  7. #7
    AlchemyCS is offline New Member
    Join Date
    Jan 2013
    Posts
    3
    Rep Power
    2

    Default

    Ah!
    When I set it via the command line with your commands, it worked (I must have been mistyping it before).
    However, the GUI checkbox doesn't appear to work.
    I set it back to true via the command line & then went back to the GUI & tried to set it via there, and immediately after it said GlobalConfig is modified, I ran 'zmprov gcf zimbraSmtpSendAddOriginatingIP' on the command line again, and it still reports true.

    I'm good for now; but hopefully this will get fixed.
    Thank you!

  8. #8
    Labsy is offline Elite Member
    Join Date
    Nov 2009
    Location
    Ljubljana, Slovenia
    Posts
    268
    Rep Power
    5

    Default

    The main problem still persists: Mail clients, like Outlook, by default add "X-Originating-IP" to mail header and this cannot be avoided. But by itself it wouldn't be problematic, if this particular IP would not be checked against RBL even for authenticated senders (should be checked only for non-authenticated incoming mail).
    The problem and workaround (not solution) is also discussed here:
    8.0.2 Community Edition - no longer allows SMTP auth users send email - RBL blocked
    Zimbra on SGH dedicated hosting farm, Slovenia.
    In 2013 we announce new program of low cost SSL server certificates.

  9. #9
    AlchemyCS is offline New Member
    Join Date
    Jan 2013
    Posts
    3
    Rep Power
    2

    Default works in a different install...

    Interestingly, I made a new zimbra test machine; exact same VM & OS settings, and this time the GUI button works.
    Just thought I'd toss that out there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Any reason not to disable X-Originating-IP
    By yonatan in forum Administrators
    Replies: 5
    Last Post: 05-26-2012, 11:26 PM
  2. Removing (or changing) X-Originating-IP
    By ekmeek in forum Administrators
    Replies: 1
    Last Post: 08-19-2010, 08:27 AM
  3. I can't disable X-Originating-IP
    By gnoul in forum Administrators
    Replies: 7
    Last Post: 04-09-2010, 08:16 AM
  4. Adding client X-Originating-IP
    By anthonyclark in forum Administrators
    Replies: 3
    Last Post: 09-09-2009, 11:03 PM
  5. X-Originating-IP Header
    By malheiros in forum Users
    Replies: 5
    Last Post: 07-10-2006, 03:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •