Results 1 to 6 of 6

Thread: External account mails sent with local address in ZCS 8. Help needed!

  1. #1
    b0rek is offline Member
    Join Date
    Nov 2011
    Posts
    11
    Rep Power
    3

    Default External account mails sent with local address in ZCS 8. Help needed!

    Hello,

    Can anybody help me diagnose this. I've searched forums and bugzilla and couldn't find solution.

    In standard Zimbra account external one was added i Settings->Accounts. When creating new mail in web client there is dropdown with accounts. After selecting external one and hitting send mail is sent with internal address in From field (visible in /var/log/zimbra.log) not external address, which is wrong and not acceptable.

    Server was upgraded from 7.2.0_GA_2669 to 8.0.0.GA.5434. Is there any setting responsible for this behavior? Has anything changed during upgrade?
    Can anybody point me what may be wrong or where to look, or at least debug it, please?

    Thank you in advance

    Leszek
    Release 8.0.0.GA.5434.UBUNTU12.64 UBUNTU12_64 FOSS edition.

  2. #2
    b0rek is offline Member
    Join Date
    Nov 2011
    Posts
    11
    Rep Power
    3

    Default

    I've just installed and tested fresh 8.0.1.GA.5438.UBUNTU12.64 UBUNTU12_64 FOSS edition and it's the same. No one has problem with this? Anybody?
    Release 8.0.0.GA.5434.UBUNTU12.64 UBUNTU12_64 FOSS edition.

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Quote Originally Posted by b0rek View Post
    When creating new mail in web client there is dropdown with accounts. After selecting external one and hitting send mail is sent with internal address in From field (visible in /var/log/zimbra.log) not external address, which is wrong and not acceptable.
    What do you mean by "internal address"? It works for me, if I select the gmail (in my case) Inbox and review any messages then either reply to an email or create a new email it goes with the correct from address and the correct 'reply to' that I've set in the external account settings. This is currently on a ZCS 7.2.1 server Are you saying it worked on your server before the upgrade and now it doesn't?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    lindworm is offline Senior Member
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    74
    Rep Power
    8

    Default

    Hi,

    it's the same behavior with 8.0.3 here. It seems to be a bug.

    You can go to the administration and activate the option "Allow sending email from any address" or add the single address to "Allow sending mail only from these addresses:". After that it works again.

    Maybe someone has the time to file a bug

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Quote Originally Posted by lindworm View Post
    it's the same behavior with 8.0.3 here. It seems to be a bug.
    As he never answered the question of what was meant by 'internal address' we'll never know if the question was the same as yours.

    Quote Originally Posted by lindworm View Post
    Maybe someone has the time to file a bug
    This is Community supported forums, you file your own bug reports.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    b0rek is offline Member
    Join Date
    Nov 2011
    Posts
    11
    Rep Power
    3

    Default

    To phoenix
    Read whole post with understanding:
    In standard Zimbra account external one was added in Settings->Accounts.
    By internal address I mean user address from zimbra server as opposed to external address (f.e. gmail) added as external account in sessings->accounts.

    To lindworm comment: all is set correctly.

    Bug was reported Bug 79127 ? when sendnig mail from external account sender set to local account

    My current Zimbra version: 8.0.2_GA_5569 20121210115059 20121210-1156 FOSS
    Release 8.0.0.GA.5434.UBUNTU12.64 UBUNTU12_64 FOSS edition.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. restriction of sending mails from local account
    By thedoctor46 in forum Administrators
    Replies: 1
    Last Post: 11-21-2012, 03:40 AM
  2. [SOLVED] Send mails from external account trough Zimbra
    By fleiben in forum Administrators
    Replies: 4
    Last Post: 11-06-2012, 01:18 AM
  3. Relaying Local zimbra mails to external server
    By zim_love in forum Installation
    Replies: 9
    Last Post: 08-01-2012, 04:54 AM
  4. Mails from external pop account getting purged
    By JoeKar in forum Administrators
    Replies: 0
    Last Post: 06-08-2012, 10:40 AM
  5. Replies: 1
    Last Post: 06-07-2008, 02:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •