Since a server reboot yesterday, I'm getting a very very annoying by on my Zimbra 8.0.1 (network edition).

Whenever zimbra receives an e-mail over LMTP, the following happens:
2012-11-30 15:08:44,253 INFO [LmtpServer-3] [ip=172.22.25.39;] lmtp - Delivering message: size=4434 bytes, nrcpts=1, sender=billing12@twitterbadges.com, msgid=<ioeo.oljlm@twitterbadges.com>
2012-11-30 15:08:44,257 INFO [LmtpServer-3] [name=stgraber@stgraber.org;mid=3;ip=172.22.25.39;] mailop - Adding Message: id=1453646, Message-ID=<ioeo.oljlm@twitterbadges.com>, parentId=-1, folderId=4, folderName=Junk.
2012-11-30 15:08:44,306 WARN [LmtpServer-3] [name=stgraber@stgraber.org;mid=3;ip=172.22.25.39;] lmtp - try again for message from=billing12@twitterbadges.com,to=stgraber@stgra ber.org
java.lang.NullPointerException
at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.addToDe dupeCache(ZimbraLmtpBackend.java:274)
at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:613 )
at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:375)
at com.zimbra.cs.lmtpserver.LmtpHandler.processMessag eData(LmtpHandler.java:376)
at com.zimbra.cs.lmtpserver.TcpLmtpHandler.continueDA TA(TcpLmtpHandler.java:73)
at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:365)
at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:181)
at com.zimbra.cs.lmtpserver.TcpLmtpHandler.processCom mand(TcpLmtpHandler.java:66)
at com.zimbra.cs.server.ProtocolHandler.processConnec tion(ProtocolHandler.java:188)
at com.zimbra.cs.server.ProtocolHandler.run(ProtocolH andler.java:127)
at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
2012-11-30 15:08:44,307 INFO [LmtpServer-3] [name=stgraber@stgraber.org;mid=3;ip=172.22.25.39;] lmtp - S: 451 4.0.0 Temporary message delivery failure try again (DATA)
2012-11-30 15:08:44,307 INFO [LmtpServer-3] [] lmtp - Handler exiting normally


This is happening for every single e-mail the server receives. The e-mail is correctly added to the pool and I can see it in my mail client, however as the server returns a 451 to my inbound SMTP server, the e-mail delivery is attempted over and over again, leading to a ton of duplicate e-mails.

So far I've tried:
- Upgrade to 8.0.1 (I was on 8.0.0)
- Remove all the indexes and rebuild them for all accounts
- Turn off the deduplication feature in the COS and for all accounts
- Set the deduplication cache size to 0 (which should turn it off completely)
- Checked the DB integrity

The server still has plenty of free disk space, plenty of free inodes and 25GB of free memory.

Any idea?