Results 1 to 4 of 4

Thread: External LDAP Authentication

  1. #1
    samdm is offline New Member
    Join Date
    Dec 2006
    Posts
    4
    Rep Power
    8

    Default External LDAP Authentication

    Hi,

    I configured Zimbra to use external LDAP for GAL and for authentication. "Test" in the end of both wizards in the corresponding Administration area is successful.

    The question is: why when I try to login into mail interface with credentials from external LDAP, I get "The username or password is incorrect."?

    Regards, Stepan.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    That depends, is your login set to use the domain name part of your email address? You can set the external authentication to require the domain name part of your details or you may have it set to optional. Have a look at your settings again, there's also some info in the wiki. I assume you do have this username set in your external LDAP?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    samdm is offline New Member
    Join Date
    Dec 2006
    Posts
    4
    Rep Power
    8

    Default

    Well, my config is:
    LDAP filter: mail=%u@mydomain.com
    LDAP search base: dc=mydomain,dc=com

    In the log of my external LDAP server there're no traces of activity when I try to login.

    When I click "Test", it shows request coming in.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    The filter should be in this format (uid=%n) with brackets, in your example it should be (mail=%n) - there's some details in the wiki about authentication.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. External LDAP with GSSAPI authentication method
    By izvictor in forum Installation
    Replies: 17
    Last Post: 03-11-2009, 08:14 AM
  2. Disable local authentication with an external ldap
    By turmace in forum Administrators
    Replies: 4
    Last Post: 05-17-2007, 02:13 AM
  3. External LDAP Problem
    By facerw in forum Installation
    Replies: 7
    Last Post: 05-08-2007, 04:29 AM
  4. External LDAP Authentication Issue
    By xtreme-one in forum Installation
    Replies: 10
    Last Post: 02-16-2007, 07:52 PM
  5. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 03:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •